summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2014-11-24 14:44:23 +0000
committerJonas Gorski <jogo@openwrt.org>2014-11-24 14:44:23 +0000
commit89000dea4cb73def05c1973909bb339b8f889db0 (patch)
treeddea0f5e818783bd18a2086fcad586f0f8ee4cf9 /target/linux/brcm63xx
parent13d6fa008189f8c5a6b9c68ffc9afb665e7e878a (diff)
downloadmaster-31e0f0ae-89000dea4cb73def05c1973909bb339b8f889db0.tar.gz
master-31e0f0ae-89000dea4cb73def05c1973909bb339b8f889db0.tar.bz2
master-31e0f0ae-89000dea4cb73def05c1973909bb339b8f889db0.zip
brcm63xx: Add DT support for RG100A
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> SVN-Revision: 43360
Diffstat (limited to 'target/linux/brcm63xx')
-rw-r--r--target/linux/brcm63xx/dts/rg100a.dts30
-rwxr-xr-xtarget/linux/brcm63xx/image/Makefile14
-rw-r--r--target/linux/brcm63xx/patches-3.14/369-MIPS-BCM63XX-populate-the-compatible-to-board_info-l.patch3
-rw-r--r--target/linux/brcm63xx/profiles/alcatel.mk16
4 files changed, 50 insertions, 13 deletions
diff --git a/target/linux/brcm63xx/dts/rg100a.dts b/target/linux/brcm63xx/dts/rg100a.dts
new file mode 100644
index 0000000000..df628dc75c
--- /dev/null
+++ b/target/linux/brcm63xx/dts/rg100a.dts
@@ -0,0 +1,30 @@
+/dts-v1/;
+
+/include/ "bcm6358.dtsi"
+
+/ {
+ model = "Alcatel RG100A";
+ compatible = "alcatel,rg100a", "brcm,bcm6358";
+};
+
+&pflash {
+ status = "ok";
+
+ linux,part-probe = "bcm63xxpart";
+
+ cfe@0 {
+ label = "CFE";
+ reg = <0x000000 0x020000>;
+ read-only;
+ };
+
+ linux@20000 {
+ label = "linux";
+ reg = <0x020000 0xfc0000>;
+ };
+
+ nvram@fe0000 {
+ label = "nvram";
+ reg = <0xfe0000 0x020000>;
+ };
+};
diff --git a/target/linux/brcm63xx/image/Makefile b/target/linux/brcm63xx/image/Makefile
index 9f0227c7d3..89eefa3ca7 100755
--- a/target/linux/brcm63xx/image/Makefile
+++ b/target/linux/brcm63xx/image/Makefile
@@ -71,15 +71,6 @@ define Image/Build/ZYXCFEDTB
rm -f $(BIN_DIR)/openwrt-$(5)-$(1).tmp
endef
-define Image/Build/RG100A
- # Generate the tagged image
- $(STAGING_DIR_HOST)/bin/imagetag -i $(KDIR)/vmlinux.lzma.cfe -f $(KDIR)/root.$(1) \
- --output $(BIN_DIR)/openwrt-$(5)-$(1)-cfe.bin \
- --boardid $(2) --chipid $(3) --entry $(LOADADDR) \
- --load-addr $(LOADADDR) --block-size 0x20000 \
- --image-offset $(4) --info1 "-$(call Image/LimitName16,$(5))" --info2 $(1)
-endef
-
define Image/Build/RedBoot
cp $(KDIR)/vmlinux.elf $(BIN_DIR)/openwrt-$(1)-vmlinux.elf
gzip -9 -c $(KDIR)/vmlinux > $(KDIR)/vmlinux.bin.gz
@@ -279,9 +270,6 @@ define Image/Build
# Inventel Livebox
$(call Image/Build/RedBoot,livebox)
- # RG100A,DB120 etc.
- $(call Image/Build/RG100A,$(1),96358VW2,6358,0x20000,RG100A_DB120)
-
# Telsey CPVA642-type (e.g. CPA-ZNTE60T)
$(call Image/Build/CFE,$(1),CPVA642,6358,CPA-ZNTE60T,,--signature "Telsey Tlc",--signature2 "99.99.999",--second-image-flag "0")
@@ -336,6 +324,8 @@ $(eval $(call CfeImageDTB,96368MVWG,bcm96368MVWG,96368MVWG,6368,96368MVWG-generi
$(eval $(call CfeImageDTB,A4001N,a4001n,96328dg2x2,6328,A4001N,,--pad 8))
# ADB P.DG A4001N1
$(eval $(call CfeImageDTB,A4001N1,a4001n1,963281T_TEF,6328,A4001N1,,--pad 8))
+# Alcatel RG100A
+$(eval $(call CfeImageDTB,RG100A,rg100a,96358VW2,6358,RG100A,,--block-size 0x20000 --image-offset 0x20000))
# Asmax AR 1004g
$(eval $(call CfeImageDTB,AR1004G,ar1004g,96348GW-10,6348,AR1004G))
# Comtrend AR-5381u
diff --git a/target/linux/brcm63xx/patches-3.14/369-MIPS-BCM63XX-populate-the-compatible-to-board_info-l.patch b/target/linux/brcm63xx/patches-3.14/369-MIPS-BCM63XX-populate-the-compatible-to-board_info-l.patch
index 3ae3b94482..765cf2a79f 100644
--- a/target/linux/brcm63xx/patches-3.14/369-MIPS-BCM63XX-populate-the-compatible-to-board_info-l.patch
+++ b/target/linux/brcm63xx/patches-3.14/369-MIPS-BCM63XX-populate-the-compatible-to-board_info-l.patch
@@ -14,7 +14,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
+++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -736,6 +736,42 @@ static const struct board_info __initcon
+@@ -736,6 +736,43 @@ static const struct board_info __initcon
};
static struct of_device_id const bcm963xx_boards_dt[] = {
@@ -41,6 +41,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
+ { .compatible = "sagem,f@st2404", .data = &board_FAST2404, },
+#endif
+#ifdef CONFIG_BCM63XX_CPU_6358
++ { .compatible = "alcatel,rg100a", .data = &board_96358vw2, },
+ { .compatible = "brcm,bcm96358vw", .data = &board_96358vw, },
+ { .compatible = "brcm,bcm96358vw2", .data = &board_96358vw2, },
+ { .compatible = "pirelli,a226g", .data = &board_DWVS0, },
diff --git a/target/linux/brcm63xx/profiles/alcatel.mk b/target/linux/brcm63xx/profiles/alcatel.mk
new file mode 100644
index 0000000000..ec93a19739
--- /dev/null
+++ b/target/linux/brcm63xx/profiles/alcatel.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/RG100A
+ NAME:=Alcatel RG100A
+ PACKAGES:=kmod-b43 wpad-mini\
+ kmod-usb2 kmod-usb-ohci
+endef
+define Profile/RG100A/Description
+ Package set optimized for RG100A.
+endef
+$(eval $(call Profile,RG100A))