summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2008-04-01 21:10:47 +0000
committerFlorian Fainelli <florian@openwrt.org>2008-04-01 21:10:47 +0000
commit62240465c4e4e322446117a9c40d020d11e5793d (patch)
treeded0289112280d03a7ec1ddbeffdb0d66d4538ce /target/linux/brcm63xx
parenta6cb5b8300053260d38b2b854400e6564dcfd90a (diff)
downloadmaster-31e0f0ae-62240465c4e4e322446117a9c40d020d11e5793d.tar.gz
master-31e0f0ae-62240465c4e4e322446117a9c40d020d11e5793d.tar.bz2
master-31e0f0ae-62240465c4e4e322446117a9c40d020d11e5793d.zip
brcm63xx image generation cleanups (#3169)
SVN-Revision: 10703
Diffstat (limited to 'target/linux/brcm63xx')
-rw-r--r--target/linux/brcm63xx/image/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/target/linux/brcm63xx/image/Makefile b/target/linux/brcm63xx/image/Makefile
index 04231b4e85..fab73efd20 100644
--- a/target/linux/brcm63xx/image/Makefile
+++ b/target/linux/brcm63xx/image/Makefile
@@ -39,10 +39,15 @@ define Image/Prepare
TARGET="$(KDIR)" \
clean install
echo -ne "\\x00" >> $(KDIR)/loader.gz
+ rm -f $(KDIR)/fs_mark
+ touch $(KDIR)/fs_mark
+ $(call prepare_generic_squashfs,$(KDIR)/fs_mark)
endef
define Image/Build
+ifneq($(1),ext2)
$(STAGING_DIR_HOST)/bin/trx -o $(BIN_DIR)/openwrt-$(BOARD)-$(1).trx -f $(KDIR)/loader.gz -f $(KDIR)/vmlinux.lzma $(call trxalign/$(1)) -f $(KDIR)/root.$(1)
+endif
endef
$(eval $(call BuildImage))