summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2014-10-02 12:26:07 +0000
committerJonas Gorski <jogo@openwrt.org>2014-10-02 12:26:07 +0000
commit57214b00aed49a43bf8070772d87663971b2af14 (patch)
tree84e49adadb7b218640868ccdbbf54f3da6f6b004 /target/linux/brcm63xx
parent477826ef31a6aecf20ec2e9e563c5f9985a17cc5 (diff)
downloadmaster-31e0f0ae-57214b00aed49a43bf8070772d87663971b2af14.tar.gz
master-31e0f0ae-57214b00aed49a43bf8070772d87663971b2af14.tar.bz2
master-31e0f0ae-57214b00aed49a43bf8070772d87663971b2af14.zip
brcm63xx: Add DT support for 96368MVWG
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 42738
Diffstat (limited to 'target/linux/brcm63xx')
-rw-r--r--target/linux/brcm63xx/dts/bcm96368MVWG.dts8
-rwxr-xr-xtarget/linux/brcm63xx/image/Makefile4
-rw-r--r--target/linux/brcm63xx/patches-3.14/520-bcm63xx-add-support-for-96368MVWG-board.patch5
-rw-r--r--target/linux/brcm63xx/patches-3.14/521-bcm63xx-add-support-for-96368MVNgr-board.patch4
-rw-r--r--target/linux/brcm63xx/patches-3.14/523-MIPS-BCM63XX-add-963281TAN-reference-board.patch2
-rw-r--r--target/linux/brcm63xx/patches-3.14/524-board_dsl_274xb_rev_f.patch2
-rw-r--r--target/linux/brcm63xx/patches-3.14/525-board_96348w3.patch2
-rw-r--r--target/linux/brcm63xx/patches-3.14/526-board_CT6373-1.patch2
-rw-r--r--target/linux/brcm63xx/patches-3.14/527-board_dva-g3810bn-tl-1.patch2
-rw-r--r--target/linux/brcm63xx/patches-3.14/528-board_nb6.patch2
-rw-r--r--target/linux/brcm63xx/patches-3.14/529-board_fast2604.patch2
-rw-r--r--target/linux/brcm63xx/patches-3.14/530-board_A4001N1.patch2
-rw-r--r--target/linux/brcm63xx/patches-3.14/531-board_AR-5387un.patch2
-rw-r--r--target/linux/brcm63xx/patches-3.14/532-board_AR-5381u.patch2
-rw-r--r--target/linux/brcm63xx/patches-3.14/533-board_rta770bw.patch2
-rw-r--r--target/linux/brcm63xx/patches-3.14/534-board_hw556.patch2
-rw-r--r--target/linux/brcm63xx/patches-3.14/535-board_rta770w.patch2
-rw-r--r--target/linux/brcm63xx/patches-3.14/536-board_fast2704.patch2
-rw-r--r--target/linux/brcm63xx/patches-3.14/537-board_fast2504n.patch2
-rw-r--r--target/linux/brcm63xx/patches-3.14/555-board_96318ref.patch2
-rw-r--r--target/linux/brcm63xx/patches-3.14/556-board_96318ref_p300.patch2
-rw-r--r--target/linux/brcm63xx/patches-3.14/557-board_bcm963269bhr.patch4
-rw-r--r--target/linux/brcm63xx/patches-3.14/558-board_AR1004G.patch2
-rw-r--r--target/linux/brcm63xx/patches-3.14/559-board_vw6339gu.patch4
-rw-r--r--target/linux/brcm63xx/patches-3.14/560-board_963268gu_p300.patch4
-rw-r--r--target/linux/brcm63xx/patches-3.14/561-board_WAP-5813n.patch4
-rw-r--r--target/linux/brcm63xx/patches-3.14/562-board_VR-3025u.patch4
-rw-r--r--target/linux/brcm63xx/patches-3.14/563-board_VR-3025un.patch4
-rw-r--r--target/linux/brcm63xx/patches-3.14/564-board_P870HW-51a_v2.patch4
-rw-r--r--target/linux/brcm63xx/patches-3.14/565-board_hw520.patch2
-rw-r--r--target/linux/brcm63xx/patches-3.14/566-board_A4001N.patch2
-rw-r--r--target/linux/brcm63xx/patches-3.14/567-board_dsl-2751b_e1.patch2
-rw-r--r--target/linux/brcm63xx/profiles/01-generic.mk9
33 files changed, 59 insertions, 41 deletions
diff --git a/target/linux/brcm63xx/dts/bcm96368MVWG.dts b/target/linux/brcm63xx/dts/bcm96368MVWG.dts
new file mode 100644
index 0000000000..f462411c94
--- /dev/null
+++ b/target/linux/brcm63xx/dts/bcm96368MVWG.dts
@@ -0,0 +1,8 @@
+/dts-v1/;
+
+/include/ "bcm6368.dtsi"
+
+/ {
+ model = "Broadcom BCM96368MVWG reference board";
+ compatible = "brcm,bcm96368mvwg", "brcm,bcm6368";
+};
diff --git a/target/linux/brcm63xx/image/Makefile b/target/linux/brcm63xx/image/Makefile
index 63528ddcb2..b7789cf368 100755
--- a/target/linux/brcm63xx/image/Makefile
+++ b/target/linux/brcm63xx/image/Makefile
@@ -233,8 +233,6 @@ endef
define Image/Build
dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) bs=128k conv=sync
- # Various routers
- $(call Image/Build/CFE,$(1),96368MVWG,6368,96368MVWG-generic)
# BT Voyager V210_BTR
$(call Image/Build/CFE,$(1),V210_BB,6348,BTV210_BTR,,--layoutver 5)
@@ -351,6 +349,8 @@ $(eval $(call CfeImageDTB,96358VW,bcm96358VW,96358VW,6358,96358VW-generic))
$(eval $(call CfeImageDTB,96358VW2,bcm96358VW2,96358VW2,6358,96358VW2-generic))
# Generic 96368MVNgr
$(eval $(call CfeImageDTB,96368MVNgr,bcm96368MVNgr,96368MVNgr,6368,96368MVNgr-generic))
+# Generic 96368MVWG
+$(eval $(call CfeImageDTB,96368MVWG,bcm96368MVWG,96368MVWG,6368,96368MVWG-generic))
# ADB P.DG A4001N
$(eval $(call CfeImageDTB,A4001N,a4001n,96328dg2x2,6328,A4001N,,--pad 8))
diff --git a/target/linux/brcm63xx/patches-3.14/520-bcm63xx-add-support-for-96368MVWG-board.patch b/target/linux/brcm63xx/patches-3.14/520-bcm63xx-add-support-for-96368MVWG-board.patch
index c320f77c7b..2256bd86b7 100644
--- a/target/linux/brcm63xx/patches-3.14/520-bcm63xx-add-support-for-96368MVWG-board.patch
+++ b/target/linux/brcm63xx/patches-3.14/520-bcm63xx-add-support-for-96368MVWG-board.patch
@@ -10,7 +10,7 @@ Subject: [PATCH 32/63] bcm63xx: add support for 96368MVWG board.
--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
+++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -1936,6 +1936,85 @@ static struct board_info __initdata boar
+@@ -1936,6 +1936,86 @@ static struct board_info __initdata boar
#endif /* CONFIG_BCM63XX_CPU_6358 */
/*
@@ -19,6 +19,7 @@ Subject: [PATCH 32/63] bcm63xx: add support for 96368MVWG board.
+#ifdef CONFIG_BCM63XX_CPU_6368
+static struct board_info __initdata board_96368mvwg = {
+ .name = "96368MVWG",
++ .of_board_id = "brcm,bcm96368mvwg",
+ .expected_cpu_id = 0x6368,
+
+ .has_uart0 = 1,
@@ -96,7 +97,7 @@ Subject: [PATCH 32/63] bcm63xx: add support for 96368MVWG board.
* all boards
*/
static const struct board_info __initconst *bcm963xx_boards[] = {
-@@ -1987,6 +2066,10 @@ static const struct board_info __initcon
+@@ -1987,6 +2067,10 @@ static const struct board_info __initcon
&board_HW553,
&board_spw303v,
#endif
diff --git a/target/linux/brcm63xx/patches-3.14/521-bcm63xx-add-support-for-96368MVNgr-board.patch b/target/linux/brcm63xx/patches-3.14/521-bcm63xx-add-support-for-96368MVNgr-board.patch
index 720ea6d1ad..ccd24cabb5 100644
--- a/target/linux/brcm63xx/patches-3.14/521-bcm63xx-add-support-for-96368MVNgr-board.patch
+++ b/target/linux/brcm63xx/patches-3.14/521-bcm63xx-add-support-for-96368MVNgr-board.patch
@@ -9,7 +9,7 @@ Subject: [PATCH 33/63] bcm63xx: add support for 96368MVNgr board.
--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
+++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -2012,6 +2012,73 @@ static struct board_info __initdata boar
+@@ -2013,6 +2013,73 @@ static struct board_info __initdata boar
.has_ohci0 = 1,
.has_ehci0 = 1,
};
@@ -83,7 +83,7 @@ Subject: [PATCH 33/63] bcm63xx: add support for 96368MVNgr board.
#endif /* CONFIG_BCM63XX_CPU_6368 */
/*
-@@ -2069,6 +2136,7 @@ static const struct board_info __initcon
+@@ -2070,6 +2137,7 @@ static const struct board_info __initcon
#ifdef CONFIG_BCM63XX_CPU_6368
&board_96368mvwg,
diff --git a/target/linux/brcm63xx/patches-3.14/523-MIPS-BCM63XX-add-963281TAN-reference-board.patch b/target/linux/brcm63xx/patches-3.14/523-MIPS-BCM63XX-add-963281TAN-reference-board.patch
index ec7b95bbe2..e0ad162765 100644
--- a/target/linux/brcm63xx/patches-3.14/523-MIPS-BCM63XX-add-963281TAN-reference-board.patch
+++ b/target/linux/brcm63xx/patches-3.14/523-MIPS-BCM63XX-add-963281TAN-reference-board.patch
@@ -87,7 +87,7 @@ Subject: [PATCH] MIPS: BCM63XX: add 963281TAN reference board
#endif /* CONFIG_BCM63XX_CPU_6328 */
/*
-@@ -2122,6 +2193,7 @@ static const struct board_info __initcon
+@@ -2123,6 +2194,7 @@ static const struct board_info __initcon
#endif
#ifdef CONFIG_BCM63XX_CPU_6328
&board_96328avng,
diff --git a/target/linux/brcm63xx/patches-3.14/524-board_dsl_274xb_rev_f.patch b/target/linux/brcm63xx/patches-3.14/524-board_dsl_274xb_rev_f.patch
index e14663d24d..67f42dfc10 100644
--- a/target/linux/brcm63xx/patches-3.14/524-board_dsl_274xb_rev_f.patch
+++ b/target/linux/brcm63xx/patches-3.14/524-board_dsl_274xb_rev_f.patch
@@ -122,7 +122,7 @@ Subject: [PATCH 70/79] MIPS: BCM63XX: Add board definition for D-Link
#endif /* CONFIG_BCM63XX_CPU_6328 */
/*
-@@ -2194,6 +2299,7 @@ static const struct board_info __initcon
+@@ -2195,6 +2300,7 @@ static const struct board_info __initcon
#ifdef CONFIG_BCM63XX_CPU_6328
&board_96328avng,
&board_963281TAN,
diff --git a/target/linux/brcm63xx/patches-3.14/525-board_96348w3.patch b/target/linux/brcm63xx/patches-3.14/525-board_96348w3.patch
index 0ed9f532f2..911dcc5f72 100644
--- a/target/linux/brcm63xx/patches-3.14/525-board_96348w3.patch
+++ b/target/linux/brcm63xx/patches-3.14/525-board_96348w3.patch
@@ -60,7 +60,7 @@
static struct board_info __initdata board_96348_D4PW = {
.name = "D-4P-W",
.expected_cpu_id = 0x6348,
-@@ -2329,6 +2382,7 @@ static const struct board_info __initcon
+@@ -2330,6 +2383,7 @@ static const struct board_info __initcon
&board_ct536_ct5621,
&board_96348A_122,
&board_CPVA502plus,
diff --git a/target/linux/brcm63xx/patches-3.14/526-board_CT6373-1.patch b/target/linux/brcm63xx/patches-3.14/526-board_CT6373-1.patch
index 00b00aa464..5659af1237 100644
--- a/target/linux/brcm63xx/patches-3.14/526-board_CT6373-1.patch
+++ b/target/linux/brcm63xx/patches-3.14/526-board_CT6373-1.patch
@@ -139,7 +139,7 @@
static struct board_info __initdata board_HW553 = {
.name = "HW553",
.of_board_id = "huawei,hg553",
-@@ -2394,6 +2519,7 @@ static const struct board_info __initcon
+@@ -2395,6 +2520,7 @@ static const struct board_info __initcon
&board_dsl_274xb_rev_c,
&board_nb4_ser_r0,
&board_nb4_fxc_r1,
diff --git a/target/linux/brcm63xx/patches-3.14/527-board_dva-g3810bn-tl-1.patch b/target/linux/brcm63xx/patches-3.14/527-board_dva-g3810bn-tl-1.patch
index a71be36ecf..685bd16ed8 100644
--- a/target/linux/brcm63xx/patches-3.14/527-board_dva-g3810bn-tl-1.patch
+++ b/target/linux/brcm63xx/patches-3.14/527-board_dva-g3810bn-tl-1.patch
@@ -75,7 +75,7 @@
#endif /* CONFIG_BCM63XX_CPU_6358 */
/*
-@@ -2522,6 +2590,7 @@ static const struct board_info __initcon
+@@ -2523,6 +2591,7 @@ static const struct board_info __initcon
&board_ct6373_1,
&board_HW553,
&board_spw303v,
diff --git a/target/linux/brcm63xx/patches-3.14/528-board_nb6.patch b/target/linux/brcm63xx/patches-3.14/528-board_nb6.patch
index 26ad63c1fc..28a62f62d3 100644
--- a/target/linux/brcm63xx/patches-3.14/528-board_nb6.patch
+++ b/target/linux/brcm63xx/patches-3.14/528-board_nb6.patch
@@ -123,7 +123,7 @@
/*
* known 6368 boards
*/
-@@ -2593,6 +2695,10 @@ static const struct board_info __initcon
+@@ -2594,6 +2696,10 @@ static const struct board_info __initcon
&board_DVAG3810BN,
#endif
diff --git a/target/linux/brcm63xx/patches-3.14/529-board_fast2604.patch b/target/linux/brcm63xx/patches-3.14/529-board_fast2604.patch
index 55a01c9101..34bf6b5fea 100644
--- a/target/linux/brcm63xx/patches-3.14/529-board_fast2604.patch
+++ b/target/linux/brcm63xx/patches-3.14/529-board_fast2604.patch
@@ -58,7 +58,7 @@
static struct board_info __initdata board_rta1025w_16 = {
.name = "RTA1025W_16",
.of_board_id = "dynalink,rta1025w",
-@@ -2666,6 +2717,7 @@ static const struct board_info __initcon
+@@ -2667,6 +2718,7 @@ static const struct board_info __initcon
&board_96348gw_10,
&board_96348gw_11,
&board_FAST2404,
diff --git a/target/linux/brcm63xx/patches-3.14/530-board_A4001N1.patch b/target/linux/brcm63xx/patches-3.14/530-board_A4001N1.patch
index f56b677c74..881319bb27 100644
--- a/target/linux/brcm63xx/patches-3.14/530-board_A4001N1.patch
+++ b/target/linux/brcm63xx/patches-3.14/530-board_A4001N1.patch
@@ -135,7 +135,7 @@
static struct board_info __initdata board_dsl_274xb_f1 = {
.name = "AW4339U",
.expected_cpu_id = 0x6328,
-@@ -2698,6 +2826,7 @@ static const struct board_info __initcon
+@@ -2699,6 +2827,7 @@ static const struct board_info __initcon
#ifdef CONFIG_BCM63XX_CPU_6328
&board_96328avng,
&board_963281TAN,
diff --git a/target/linux/brcm63xx/patches-3.14/531-board_AR-5387un.patch b/target/linux/brcm63xx/patches-3.14/531-board_AR-5387un.patch
index 07af3cc0e1..851337ac85 100644
--- a/target/linux/brcm63xx/patches-3.14/531-board_AR-5387un.patch
+++ b/target/linux/brcm63xx/patches-3.14/531-board_AR-5387un.patch
@@ -117,7 +117,7 @@
static struct board_info __initdata board_963281TAN = {
.name = "963281TAN",
.of_board_id = "brcm,bcm963281TAN",
-@@ -2825,6 +2935,7 @@ static const struct board_info __initcon
+@@ -2826,6 +2936,7 @@ static const struct board_info __initcon
#endif
#ifdef CONFIG_BCM63XX_CPU_6328
&board_96328avng,
diff --git a/target/linux/brcm63xx/patches-3.14/532-board_AR-5381u.patch b/target/linux/brcm63xx/patches-3.14/532-board_AR-5381u.patch
index 134114ec4b..bc8ef76c9a 100644
--- a/target/linux/brcm63xx/patches-3.14/532-board_AR-5381u.patch
+++ b/target/linux/brcm63xx/patches-3.14/532-board_AR-5381u.patch
@@ -93,7 +93,7 @@
static struct sprom_fixup __initdata ar5387un_fixups[] = {
{ .offset = 2, .value = 0x05bb },
{ .offset = 65, .value = 0x1204 },
-@@ -2935,6 +3021,7 @@ static const struct board_info __initcon
+@@ -2936,6 +3022,7 @@ static const struct board_info __initcon
#endif
#ifdef CONFIG_BCM63XX_CPU_6328
&board_96328avng,
diff --git a/target/linux/brcm63xx/patches-3.14/533-board_rta770bw.patch b/target/linux/brcm63xx/patches-3.14/533-board_rta770bw.patch
index 504598e783..d9dddc65db 100644
--- a/target/linux/brcm63xx/patches-3.14/533-board_rta770bw.patch
+++ b/target/linux/brcm63xx/patches-3.14/533-board_rta770bw.patch
@@ -56,7 +56,7 @@
#endif /* CONFIG_BCM63XX_CPU_6345 */
/*
-@@ -3035,6 +3084,7 @@ static const struct board_info __initcon
+@@ -3036,6 +3085,7 @@ static const struct board_info __initcon
#endif
#ifdef CONFIG_BCM63XX_CPU_6345
&board_96345gw2,
diff --git a/target/linux/brcm63xx/patches-3.14/534-board_hw556.patch b/target/linux/brcm63xx/patches-3.14/534-board_hw556.patch
index aefe4074d2..216e5a443c 100644
--- a/target/linux/brcm63xx/patches-3.14/534-board_hw556.patch
+++ b/target/linux/brcm63xx/patches-3.14/534-board_hw556.patch
@@ -414,7 +414,7 @@
/* T-Home Speedport W 303V Typ B */
static struct board_info __initdata board_spw303v = {
.name = "96358-502V",
-@@ -3120,6 +3520,9 @@ static const struct board_info __initcon
+@@ -3121,6 +3521,9 @@ static const struct board_info __initcon
&board_nb4_fxc_r1,
&board_ct6373_1,
&board_HW553,
diff --git a/target/linux/brcm63xx/patches-3.14/535-board_rta770w.patch b/target/linux/brcm63xx/patches-3.14/535-board_rta770w.patch
index a66a53606a..ef8c8f47ca 100644
--- a/target/linux/brcm63xx/patches-3.14/535-board_rta770w.patch
+++ b/target/linux/brcm63xx/patches-3.14/535-board_rta770w.patch
@@ -61,7 +61,7 @@
#endif /* CONFIG_BCM63XX_CPU_6345 */
/*
-@@ -3485,6 +3539,7 @@ static const struct board_info __initcon
+@@ -3486,6 +3540,7 @@ static const struct board_info __initcon
#ifdef CONFIG_BCM63XX_CPU_6345
&board_96345gw2,
&board_rta770bw,
diff --git a/target/linux/brcm63xx/patches-3.14/536-board_fast2704.patch b/target/linux/brcm63xx/patches-3.14/536-board_fast2704.patch
index e8fba3176a..486d87a13c 100644
--- a/target/linux/brcm63xx/patches-3.14/536-board_fast2704.patch
+++ b/target/linux/brcm63xx/patches-3.14/536-board_fast2704.patch
@@ -135,7 +135,7 @@ Signed-off-by: Marcin Jurkowski <marcin1j@gmail.com>
#endif /* CONFIG_BCM63XX_CPU_6328 */
/*
-@@ -3529,6 +3645,7 @@ static const struct board_info __initcon
+@@ -3530,6 +3646,7 @@ static const struct board_info __initcon
&board_963281TAN,
&board_A4001N1,
&board_dsl_274xb_f1,
diff --git a/target/linux/brcm63xx/patches-3.14/537-board_fast2504n.patch b/target/linux/brcm63xx/patches-3.14/537-board_fast2504n.patch
index cb65d697cc..ca9047f7bc 100644
--- a/target/linux/brcm63xx/patches-3.14/537-board_fast2504n.patch
+++ b/target/linux/brcm63xx/patches-3.14/537-board_fast2504n.patch
@@ -103,7 +103,7 @@ Signed-off-by: Max Staudt <openwrt.max@enpas.org>
#endif /* CONFIG_BCM63XX_CPU_6362 */
/*
-@@ -3701,6 +3791,7 @@ static const struct board_info __initcon
+@@ -3702,6 +3792,7 @@ static const struct board_info __initcon
#ifdef CONFIG_BCM63XX_CPU_6362
&board_nb6,
diff --git a/target/linux/brcm63xx/patches-3.14/555-board_96318ref.patch b/target/linux/brcm63xx/patches-3.14/555-board_96318ref.patch
index dc904eb3fe..4bdd841883 100644
--- a/target/linux/brcm63xx/patches-3.14/555-board_96318ref.patch
+++ b/target/linux/brcm63xx/patches-3.14/555-board_96318ref.patch
@@ -94,7 +94,7 @@
* known 6328 boards
*/
#ifdef CONFIG_BCM63XX_CPU_6328
-@@ -3959,6 +4046,9 @@ static const struct board_info __initcon
+@@ -3960,6 +4047,9 @@ static const struct board_info __initcon
#ifdef CONFIG_BCM63XX_CPU_3368
&board_cvg834g,
#endif
diff --git a/target/linux/brcm63xx/patches-3.14/556-board_96318ref_p300.patch b/target/linux/brcm63xx/patches-3.14/556-board_96318ref_p300.patch
index 6bb1a63a8d..6905295718 100644
--- a/target/linux/brcm63xx/patches-3.14/556-board_96318ref_p300.patch
+++ b/target/linux/brcm63xx/patches-3.14/556-board_96318ref_p300.patch
@@ -95,7 +95,7 @@
#endif /* CONFIG_BCM63XX_CPU_6318 */
/*
-@@ -4048,6 +4136,7 @@ static const struct board_info __initcon
+@@ -4049,6 +4137,7 @@ static const struct board_info __initcon
#endif
#ifdef CONFIG_BCM63XX_CPU_6318
&board_96318ref,
diff --git a/target/linux/brcm63xx/patches-3.14/557-board_bcm963269bhr.patch b/target/linux/brcm63xx/patches-3.14/557-board_bcm963269bhr.patch
index 7691f11d2c..663fe6e4bd 100644
--- a/target/linux/brcm63xx/patches-3.14/557-board_bcm963269bhr.patch
+++ b/target/linux/brcm63xx/patches-3.14/557-board_bcm963269bhr.patch
@@ -1,6 +1,6 @@
--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
+++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4128,6 +4128,75 @@ static struct board_info __initdata boar
+@@ -4129,6 +4129,75 @@ static struct board_info __initdata boar
#endif /* CONFIG_BCM63XX_CPU_6368 */
/*
@@ -76,7 +76,7 @@
* all boards
*/
static const struct board_info __initconst *bcm963xx_boards[] = {
-@@ -4208,6 +4277,9 @@ static const struct board_info __initcon
+@@ -4209,6 +4278,9 @@ static const struct board_info __initcon
&board_96368mvwg,
&board_96368mvngr,
#endif
diff --git a/target/linux/brcm63xx/patches-3.14/558-board_AR1004G.patch b/target/linux/brcm63xx/patches-3.14/558-board_AR1004G.patch
index 21feb6dc69..9881b19b83 100644
--- a/target/linux/brcm63xx/patches-3.14/558-board_AR1004G.patch
+++ b/target/linux/brcm63xx/patches-3.14/558-board_AR1004G.patch
@@ -61,7 +61,7 @@ Signed-off-by: Adrian Feliks <mexit@o2.pl>
/* BT Voyager 2110 */
static struct board_info __initdata board_V2110 = {
-@@ -4248,6 +4294,7 @@ static const struct board_info __initcon
+@@ -4249,6 +4295,7 @@ static const struct board_info __initcon
&board_96348A_122,
&board_CPVA502plus,
&board_96348W3,
diff --git a/target/linux/brcm63xx/patches-3.14/559-board_vw6339gu.patch b/target/linux/brcm63xx/patches-3.14/559-board_vw6339gu.patch
index 1038b07192..518556385a 100644
--- a/target/linux/brcm63xx/patches-3.14/559-board_vw6339gu.patch
+++ b/target/linux/brcm63xx/patches-3.14/559-board_vw6339gu.patch
@@ -1,6 +1,6 @@
--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
+++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4240,6 +4240,108 @@ static struct board_info __initdata boar
+@@ -4241,6 +4241,108 @@ static struct board_info __initdata boar
},
},
};
@@ -109,7 +109,7 @@
#endif /* CONFIG_BCM63XX_CPU_63268 */
/*
-@@ -4326,6 +4428,7 @@ static const struct board_info __initcon
+@@ -4327,6 +4429,7 @@ static const struct board_info __initcon
#endif
#ifdef CONFIG_BCM63XX_CPU_63268
&board_963269bhr,
diff --git a/target/linux/brcm63xx/patches-3.14/560-board_963268gu_p300.patch b/target/linux/brcm63xx/patches-3.14/560-board_963268gu_p300.patch
index b4e1c4997e..ef0fe51c66 100644
--- a/target/linux/brcm63xx/patches-3.14/560-board_963268gu_p300.patch
+++ b/target/linux/brcm63xx/patches-3.14/560-board_963268gu_p300.patch
@@ -1,6 +1,6 @@
--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
+++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4177,6 +4177,131 @@ static struct board_info __initdata boar
+@@ -4178,6 +4178,131 @@ static struct board_info __initdata boar
* known 63268/63269 boards
*/
#ifdef CONFIG_BCM63XX_CPU_63268
@@ -132,7 +132,7 @@
static struct board_info __initdata board_963269bhr = {
.name = "963269BHR",
.expected_cpu_id = 0x63268,
-@@ -4427,6 +4552,7 @@ static const struct board_info __initcon
+@@ -4428,6 +4553,7 @@ static const struct board_info __initcon
&board_96368mvngr,
#endif
#ifdef CONFIG_BCM63XX_CPU_63268
diff --git a/target/linux/brcm63xx/patches-3.14/561-board_WAP-5813n.patch b/target/linux/brcm63xx/patches-3.14/561-board_WAP-5813n.patch
index 8566595049..22ab61b2a7 100644
--- a/target/linux/brcm63xx/patches-3.14/561-board_WAP-5813n.patch
+++ b/target/linux/brcm63xx/patches-3.14/561-board_WAP-5813n.patch
@@ -8,7 +8,7 @@
#include <linux/platform_device.h>
#include <linux/spi/spi.h>
#include <linux/spi/spi_gpio.h>
-@@ -4171,6 +4172,118 @@ static struct board_info __initdata boar
+@@ -4172,6 +4173,118 @@ static struct board_info __initdata boar
.has_ohci0 = 1,
.has_ehci0 = 1,
};
@@ -127,7 +127,7 @@
#endif /* CONFIG_BCM63XX_CPU_6368 */
/*
-@@ -4550,6 +4663,7 @@ static const struct board_info __initcon
+@@ -4551,6 +4664,7 @@ static const struct board_info __initcon
#ifdef CONFIG_BCM63XX_CPU_6368
&board_96368mvwg,
&board_96368mvngr,
diff --git a/target/linux/brcm63xx/patches-3.14/562-board_VR-3025u.patch b/target/linux/brcm63xx/patches-3.14/562-board_VR-3025u.patch
index ce5a2d122f..05f55edaa9 100644
--- a/target/linux/brcm63xx/patches-3.14/562-board_VR-3025u.patch
+++ b/target/linux/brcm63xx/patches-3.14/562-board_VR-3025u.patch
@@ -1,6 +1,6 @@
--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
+++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4173,6 +4173,117 @@ static struct board_info __initdata boar
+@@ -4174,6 +4174,117 @@ static struct board_info __initdata boar
.has_ehci0 = 1,
};
@@ -118,7 +118,7 @@
static struct b53_platform_data WAP5813n_b53_pdata = {
.alias = "eth0",
};
-@@ -4663,6 +4774,7 @@ static const struct board_info __initcon
+@@ -4664,6 +4775,7 @@ static const struct board_info __initcon
#ifdef CONFIG_BCM63XX_CPU_6368
&board_96368mvwg,
&board_96368mvngr,
diff --git a/target/linux/brcm63xx/patches-3.14/563-board_VR-3025un.patch b/target/linux/brcm63xx/patches-3.14/563-board_VR-3025un.patch
index c985bb61af..09ba60390c 100644
--- a/target/linux/brcm63xx/patches-3.14/563-board_VR-3025un.patch
+++ b/target/linux/brcm63xx/patches-3.14/563-board_VR-3025un.patch
@@ -1,6 +1,6 @@
--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
+++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4284,6 +4284,117 @@ static struct board_info __initdata boar
+@@ -4285,6 +4285,117 @@ static struct board_info __initdata boar
},
};
@@ -118,7 +118,7 @@
static struct b53_platform_data WAP5813n_b53_pdata = {
.alias = "eth0",
};
-@@ -4775,6 +4886,7 @@ static const struct board_info __initcon
+@@ -4776,6 +4887,7 @@ static const struct board_info __initcon
&board_96368mvwg,
&board_96368mvngr,
&board_VR3025u,
diff --git a/target/linux/brcm63xx/patches-3.14/564-board_P870HW-51a_v2.patch b/target/linux/brcm63xx/patches-3.14/564-board_P870HW-51a_v2.patch
index f219e42b93..a9cde2f0e8 100644
--- a/target/linux/brcm63xx/patches-3.14/564-board_P870HW-51a_v2.patch
+++ b/target/linux/brcm63xx/patches-3.14/564-board_P870HW-51a_v2.patch
@@ -1,6 +1,6 @@
--- a/arch/mips/bcm63xx/boards/board_bcm963xx.c
+++ b/arch/mips/bcm63xx/boards/board_bcm963xx.c
-@@ -4182,6 +4182,97 @@ static struct sprom_fixup __initdata vr3
+@@ -4183,6 +4183,97 @@ static struct sprom_fixup __initdata vr3
{ .offset = 115, .value = 0xfad9 },
};
@@ -98,7 +98,7 @@
static struct board_info __initdata board_VR3025u = {
.name = "96368M-1541N",
.of_board_id = "comtrend,vr-3025u",
-@@ -4885,6 +4976,7 @@ static const struct board_info __initcon
+@@ -4886,6 +4977,7 @@ static const struct board_info __initcon
#ifdef CONFIG_BCM63XX_CPU_6368
&board_96368mvwg,
&board_96368mvngr,
diff --git a/target/linux/brcm63xx/patches-3.14/565-board_hw520.patch b/target/linux/brcm63xx/patches-3.14/565-board_hw520.patch
index ebdd899b6b..245f594809 100644
--- a/target/linux/brcm63xx/patches-3.14/565-board_hw520.patch
+++ b/target/linux/brcm63xx/patches-3.14/565-board_hw520.patch
@@ -58,7 +58,7 @@
static struct board_info __initdata board_HW553 = {
.name = "HW553",
.of_board_id = "huawei,hg553",
-@@ -4960,6 +5011,7 @@ static const struct board_info __initcon
+@@ -4961,6 +5012,7 @@ static const struct board_info __initcon
&board_nb4_ser_r0,
&board_nb4_fxc_r1,
&board_ct6373_1,
diff --git a/target/linux/brcm63xx/patches-3.14/566-board_A4001N.patch b/target/linux/brcm63xx/patches-3.14/566-board_A4001N.patch
index de4fd11275..454e5cfe00 100644
--- a/target/linux/brcm63xx/patches-3.14/566-board_A4001N.patch
+++ b/target/linux/brcm63xx/patches-3.14/566-board_A4001N.patch
@@ -97,7 +97,7 @@
static struct board_info __initdata board_A4001N1 = {
.name = "963281T_TEF",
.of_board_id = "adb,a4001n1",
-@@ -4962,6 +5052,7 @@ static const struct board_info __initcon
+@@ -4963,6 +5053,7 @@ static const struct board_info __initcon
&board_AR5381u,
&board_AR5387un,
&board_963281TAN,
diff --git a/target/linux/brcm63xx/patches-3.14/567-board_dsl-2751b_e1.patch b/target/linux/brcm63xx/patches-3.14/567-board_dsl-2751b_e1.patch
index 7c7abeb51b..7a20959156 100644
--- a/target/linux/brcm63xx/patches-3.14/567-board_dsl-2751b_e1.patch
+++ b/target/linux/brcm63xx/patches-3.14/567-board_dsl-2751b_e1.patch
@@ -142,7 +142,7 @@
#endif /* CONFIG_BCM63XX_CPU_6318 */
/*
-@@ -5046,6 +5181,7 @@ static const struct board_info __initcon
+@@ -5047,6 +5182,7 @@ static const struct board_info __initcon
#ifdef CONFIG_BCM63XX_CPU_6318
&board_96318ref,
&board_96318ref_p300,
diff --git a/target/linux/brcm63xx/profiles/01-generic.mk b/target/linux/brcm63xx/profiles/01-generic.mk
index f190141a41..2a9eb15e00 100644
--- a/target/linux/brcm63xx/profiles/01-generic.mk
+++ b/target/linux/brcm63xx/profiles/01-generic.mk
@@ -112,3 +112,12 @@ define Profile/96368MVNgr/Description
Package set optimized for 96368MVNgr.
endef
$(eval $(call Profile,96368MVNgr))
+
+define Profile/96368MVWG
+ NAME:=Generic 96368MVWG
+ PACKAGES:=
+endef
+define Profile/96368MVWG/Description
+ Package set optimized for 96368MVWG.
+endef
+$(eval $(call Profile,96368MVWG))