summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2014-12-01 00:51:04 +0000
committerJonas Gorski <jogo@openwrt.org>2014-12-01 00:51:04 +0000
commit40350a5dafbdd73b3d2e88353e503c8651c18de2 (patch)
tree7a87fa44a5bbefb0b62c74a75ba54ff1fb5fdaee /target/linux/brcm63xx
parent3872151ce042eded57c3dbf84cae1504c55dd5fd (diff)
downloadmaster-31e0f0ae-40350a5dafbdd73b3d2e88353e503c8651c18de2.tar.gz
master-31e0f0ae-40350a5dafbdd73b3d2e88353e503c8651c18de2.tar.bz2
master-31e0f0ae-40350a5dafbdd73b3d2e88353e503c8651c18de2.zip
brcm63xx: add DT support for F@ST2704V2
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> SVN-Revision: 43449
Diffstat (limited to 'target/linux/brcm63xx')
-rw-r--r--target/linux/brcm63xx/dts/fast2704v2.dts8
-rwxr-xr-xtarget/linux/brcm63xx/image/Makefile5
-rw-r--r--target/linux/brcm63xx/patches-3.14/536-board_fast2704.patch8
-rw-r--r--target/linux/brcm63xx/profiles/sagem.mk10
4 files changed, 28 insertions, 3 deletions
diff --git a/target/linux/brcm63xx/dts/fast2704v2.dts b/target/linux/brcm63xx/dts/fast2704v2.dts
new file mode 100644
index 0000000000..f001b77d4d
--- /dev/null
+++ b/target/linux/brcm63xx/dts/fast2704v2.dts
@@ -0,0 +1,8 @@
+/dts-v1/;
+
+/include/ "bcm6328.dtsi"
+
+/ {
+ model = "Sagem F@ST2704V2";
+ compatible = "sagem,f@st2704v2", "brcm,bcm6328";
+};
diff --git a/target/linux/brcm63xx/image/Makefile b/target/linux/brcm63xx/image/Makefile
index 21e3825fca..14d07309f7 100755
--- a/target/linux/brcm63xx/image/Makefile
+++ b/target/linux/brcm63xx/image/Makefile
@@ -220,9 +220,6 @@ define Image/Build
# TP-Link 8900GB
$(call Image/Build/CFE,$(1),96348GW-11,6348,TD8900GB,$(shell printf 'PRID\x89\x10\x00\x02'))
- # Sagem F@ST2704V2
- $(call Image/Build/CFE,$(1),F@ST2704V2,6328,F@ST2704V2-cfe)
- $(call Image/Build/CFE,$(1),F@ST2704V2,6328,F@ST2704V2,OpenWRT-$(REVISION))
# Inventel Livebox
$(call Image/Build/RedBoot,livebox)
@@ -324,6 +321,8 @@ $(eval $(call ImageDTB,CFEDTB,A226M,a226m-fwb,DWV-S0,6358,A226M-FWB,--block-size
$(eval $(call ImageDTB,CFEDTB,FAST2404,fast2404,F@ST2404,6348,F@ST2404))
# Sagem F@ST2604
$(eval $(call ImageDTB,CFEDTB,FAST2604,fast2604,F@ST2604,6348,F@ST2604))
+# Sagem F@ST2704V2
+$(eval $(call ImageDTB,CFEDTB,FAST2704V2,fast2704v2,F@ST2704V2,6328,F@ST2704V2))
# T-Com Speedport W 303V Typ B
$(eval $(call ImageDTB,SPW303VCFEDTB,SPW303V,spw303v,96358-502V,6358,SPW303V,--pad 4))
# T-Com Speedport W 500V
diff --git a/target/linux/brcm63xx/patches-3.14/536-board_fast2704.patch b/target/linux/brcm63xx/patches-3.14/536-board_fast2704.patch
index c647396c47..a974aa34ce 100644
--- a/target/linux/brcm63xx/patches-3.14/536-board_fast2704.patch
+++ b/target/linux/brcm63xx/patches-3.14/536-board_fast2704.patch
@@ -143,3 +143,11 @@ Signed-off-by: Marcin Jurkowski <marcin1j@gmail.com>
#endif
#ifdef CONFIG_BCM63XX_CPU_6338
&board_96338gw,
+@@ -3576,6 +3693,7 @@ static struct of_device_id const bcm963x
+ { .compatible = "brcm,bcm96328avng", .data = &board_96328avng, },
+ { .compatible = "comtrend,ar-5381u", .data = &board_AR5381u, },
+ { .compatible = "comtrend,ar-5387un", .data = &board_AR5387un, },
++ { .compatible = "sagem,f@st2704v2", .data = &board_FAST2704V2, },
+ #endif
+ #ifdef CONFIG_BCM63XX_CPU_6338
+ { .compatible = "brcm,bcm96338gw", .data = &board_96338gw, },
diff --git a/target/linux/brcm63xx/profiles/sagem.mk b/target/linux/brcm63xx/profiles/sagem.mk
index 17686d3b83..80ae8932f1 100644
--- a/target/linux/brcm63xx/profiles/sagem.mk
+++ b/target/linux/brcm63xx/profiles/sagem.mk
@@ -22,3 +22,13 @@ define Profile/FAST2604/Description
Package set optimized for F@ST2604.
endef
$(eval $(call Profile,FAST2604))
+
+define Profile/FAST2704V2
+ NAME:=Sagem F@ST2704V2
+ PACKAGES:=kmod-b43 wpad-mini\
+ kmod-usb2 kmod-usb-ohci
+endef
+define Profile/FAST2704V2/Description
+ Package set optimized for F@ST2704V2.
+endef
+$(eval $(call Profile,FAST2704V2))