summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-07-14 09:57:45 +0000
committerJohn Crispin <john@openwrt.org>2015-07-14 09:57:45 +0000
commit096b3759a98cdbbc710d8620e948eaa7ee2045ed (patch)
treeddec733630e2353a6f2890b81f65410dbfdf165c /target/linux/brcm63xx
parent3846bb9ac92060669f9c798c3c128057a6d32809 (diff)
downloadmaster-31e0f0ae-096b3759a98cdbbc710d8620e948eaa7ee2045ed.tar.gz
master-31e0f0ae-096b3759a98cdbbc710d8620e948eaa7ee2045ed.tar.bz2
master-31e0f0ae-096b3759a98cdbbc710d8620e948eaa7ee2045ed.zip
build: Prevent more gzip timestamps
To improve reproducibility, prevent the inclusion of timestamps in the gzip header. Signed-off-by: Reiner Herrmann <reiner@reiner-h.de> SVN-Revision: 46361
Diffstat (limited to 'target/linux/brcm63xx')
-rwxr-xr-xtarget/linux/brcm63xx/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/brcm63xx/image/Makefile b/target/linux/brcm63xx/image/Makefile
index e6dc2a8b57..63cd90a17d 100755
--- a/target/linux/brcm63xx/image/Makefile
+++ b/target/linux/brcm63xx/image/Makefile
@@ -95,7 +95,7 @@ endef
define Image/Build/RedBootDTB
# Prepare kernel and rootfs
cat $(KDIR)/vmlinux $(DTS_DIR)/$(3).dtb > $(KDIR)/vmlinux-$(3)
- gzip -9 -c $(KDIR)/vmlinux-$(3) > $(KDIR)/vmlinux-$(3).bin.gz
+ gzip -9n -c $(KDIR)/vmlinux-$(3) > $(KDIR)/vmlinux-$(3).bin.gz
dd if=$(KDIR)/vmlinux-$(3).bin.gz of=$(BIN_DIR)/$(IMG_PREFIX)-$(2)-vmlinux.gz bs=65536 conv=sync
dd if=$(KDIR)/root.squashfs of="$(BIN_DIR)/$(IMG_PREFIX)-$(2)-root.squashfs" bs=64k conv=sync
echo -ne \\xDE\\xAD\\xC0\\xDE >> "$(BIN_DIR)/$(IMG_PREFIX)-$(2)-root.squashfs"