summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx/smp
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2013-05-02 15:28:31 +0000
committerJonas Gorski <jogo@openwrt.org>2013-05-02 15:28:31 +0000
commit24636fcabf64031a93a930ea1cd26f086acd30f8 (patch)
tree52ff84a46508e1d89c9048e9034772b713846068 /target/linux/brcm63xx/smp
parentd11efa14286ba8b6e6bfa3af0f3c16e1f8492682 (diff)
downloadmaster-31e0f0ae-24636fcabf64031a93a930ea1cd26f086acd30f8.tar.gz
master-31e0f0ae-24636fcabf64031a93a930ea1cd26f086acd30f8.tar.bz2
master-31e0f0ae-24636fcabf64031a93a930ea1cd26f086acd30f8.zip
bcm63xx: split into two subtargets, generic and SMP
Make SMP a subtarget, since it only supports BCM6362 and BCM6368. Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 36527
Diffstat (limited to 'target/linux/brcm63xx/smp')
-rw-r--r--target/linux/brcm63xx/smp/config-default25
-rw-r--r--target/linux/brcm63xx/smp/profiles/100-Broadcom.mk17
-rw-r--r--target/linux/brcm63xx/smp/profiles/101-Broadcom-wl.mk19
-rw-r--r--target/linux/brcm63xx/smp/profiles/102-Atheros.mk17
-rw-r--r--target/linux/brcm63xx/smp/profiles/103-Ralink.mk13
-rw-r--r--target/linux/brcm63xx/smp/profiles/104-No-WiFi.mk17
-rw-r--r--target/linux/brcm63xx/smp/profiles/105-Broadcom-brcmsmac.mk17
-rw-r--r--target/linux/brcm63xx/smp/target.mk8
8 files changed, 133 insertions, 0 deletions
diff --git a/target/linux/brcm63xx/smp/config-default b/target/linux/brcm63xx/smp/config-default
new file mode 100644
index 0000000000..f68cd6ed2f
--- /dev/null
+++ b/target/linux/brcm63xx/smp/config-default
@@ -0,0 +1,25 @@
+# CONFIG_BCM63XX_CPU_6328 is not set
+# CONFIG_BCM63XX_CPU_6338 is not set
+# CONFIG_BCM63XX_CPU_6345 is not set
+# CONFIG_BCM63XX_CPU_6348 is not set
+# CONFIG_BCM63XX_CPU_6358 is not set
+CONFIG_BCM63XX_CPU_6362=y
+CONFIG_BCM63XX_CPU_6368=y
+CONFIG_CPU_BMIPS=y
+CONFIG_CPU_BMIPS4350=y
+# CONFIG_CPU_MIPS32_R1 is not set
+CONFIG_CPU_RMAP=y
+# CONFIG_KEXEC is not set
+CONFIG_MUTEX_SPIN_ON_OWNER=y
+CONFIG_NR_CPUS=2
+CONFIG_RFS_ACCEL=y
+CONFIG_RPS=y
+CONFIG_SMP=y
+CONFIG_STOP_MACHINE=y
+CONFIG_SYS_HAS_CPU_BMIPS4350=y
+CONFIG_SYS_SUPPORTS_HOTPLUG_CPU=y
+CONFIG_SYS_SUPPORTS_SMP=y
+CONFIG_TREE_RCU=y
+CONFIG_USE_GENERIC_SMP_HELPERS=y
+CONFIG_WEAK_ORDERING=y
+CONFIG_XPS=y
diff --git a/target/linux/brcm63xx/smp/profiles/100-Broadcom.mk b/target/linux/brcm63xx/smp/profiles/100-Broadcom.mk
new file mode 100644
index 0000000000..bc68f14937
--- /dev/null
+++ b/target/linux/brcm63xx/smp/profiles/100-Broadcom.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom
+ NAME:=Broadcom WiFi (default)
+ PACKAGES:=kmod-b43 wpad-mini
+endef
+
+define Profile/Broadcom/Description
+ Package set compatible with hardware using Broadcom WiFi cards
+endef
+$(eval $(call Profile,Broadcom))
+
diff --git a/target/linux/brcm63xx/smp/profiles/101-Broadcom-wl.mk b/target/linux/brcm63xx/smp/profiles/101-Broadcom-wl.mk
new file mode 100644
index 0000000000..4f2d605eb7
--- /dev/null
+++ b/target/linux/brcm63xx/smp/profiles/101-Broadcom-wl.mk
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-wl
+ NAME:=Broadcom BCM43xx WiFi (wl, proprietary)
+ PACKAGES:= kmod-brcm-wl wlc nas
+endef
+
+define Profile/Broadcom-wl/Description
+ Package set compatible with hardware using Broadcom BCM43xx cards
+ using the proprietary broadcom wireless "wl" driver.
+endef
+
+$(eval $(call Profile,Broadcom-wl))
+
diff --git a/target/linux/brcm63xx/smp/profiles/102-Atheros.mk b/target/linux/brcm63xx/smp/profiles/102-Atheros.mk
new file mode 100644
index 0000000000..b214185c5d
--- /dev/null
+++ b/target/linux/brcm63xx/smp/profiles/102-Atheros.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Atheros
+ NAME:=Atheros WiFi (default)
+ PACKAGES:=kmod-ath5k kmod-ath9k wpad-mini
+endef
+
+define Profile/Atheros/Description
+ Package set compatible with hardware using Atheros WiFi cards
+endef
+$(eval $(call Profile,Atheros))
+
diff --git a/target/linux/brcm63xx/smp/profiles/103-Ralink.mk b/target/linux/brcm63xx/smp/profiles/103-Ralink.mk
new file mode 100644
index 0000000000..412c5a45ad
--- /dev/null
+++ b/target/linux/brcm63xx/smp/profiles/103-Ralink.mk
@@ -0,0 +1,13 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Ralink
+ NAME:=Ralink WiFi
+ PACKAGES:=kmod-rt61-pci wpad-mini
+endef
+$(eval $(call Profile,Ralink))
+
diff --git a/target/linux/brcm63xx/smp/profiles/104-No-WiFi.mk b/target/linux/brcm63xx/smp/profiles/104-No-WiFi.mk
new file mode 100644
index 0000000000..0f5ec37cf6
--- /dev/null
+++ b/target/linux/brcm63xx/smp/profiles/104-No-WiFi.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/NoWiFi
+ NAME:=No WiFi
+ PACKAGES:=
+endef
+
+define Profile/NoWiFi/description
+ Package set compatible with BCM63xx routers without Wi-Fi.
+endef
+
+$(eval $(call Profile,NoWiFi))
diff --git a/target/linux/brcm63xx/smp/profiles/105-Broadcom-brcmsmac.mk b/target/linux/brcm63xx/smp/profiles/105-Broadcom-brcmsmac.mk
new file mode 100644
index 0000000000..bb558d1390
--- /dev/null
+++ b/target/linux/brcm63xx/smp/profiles/105-Broadcom-brcmsmac.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-brcmsmac
+ NAME:=Broadcom WiFi (brcmsmac)
+ PACKAGES:=kmod-brcmsmac wpad-mini
+endef
+
+define Profile/Broadcom-brcmsmac/Description
+ Package set compatible with hardware using Broadcom WiFi cards
+endef
+$(eval $(call Profile,Broadcom-brcmsmac))
+
diff --git a/target/linux/brcm63xx/smp/target.mk b/target/linux/brcm63xx/smp/target.mk
new file mode 100644
index 0000000000..b0ccf97498
--- /dev/null
+++ b/target/linux/brcm63xx/smp/target.mk
@@ -0,0 +1,8 @@
+BOARDNAME:=smp
+
+define Target/Description
+ Build firmware images for BCM63XX boards with SMP support.
+ Currently only BCM6362 and BCM6368 supported.
+endef
+
+