summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx/profiles
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-12-02 22:18:20 +0000
committerJonas Gorski <jogo@openwrt.org>2015-12-02 22:18:20 +0000
commitd12502b6663e8443dfd23e903c91b0e66a064be2 (patch)
treee6082aeec20180096e7c3b9278cfec16c9021641 /target/linux/brcm63xx/profiles
parent9d7e058a237f04d99797174f2764d90ac8b41818 (diff)
downloadmaster-31e0f0ae-d12502b6663e8443dfd23e903c91b0e66a064be2.tar.gz
master-31e0f0ae-d12502b6663e8443dfd23e903c91b0e66a064be2.tar.bz2
master-31e0f0ae-d12502b6663e8443dfd23e903c91b0e66a064be2.zip
brcm63xx: Add NuCom R5010UNv2 support
This patch adds support for the NuCom R5010UNv2. It's a BCM6328 based board. It has an onboard BCM43217 wifi chip. For this wifi chip looks like the brcmsmac driver isn't still supported, b43 drivers are used for the profile of the router. It's worth mentioning this board was affected by a bug solved with https://dev.openwrt.org/changeset/46707 Tested-by: Angel Fontan <angel.fontan@gmail.com> Signed-off-by: Daniel Gonzalez <dgcbueu@gmail.com> Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 47697
Diffstat (limited to 'target/linux/brcm63xx/profiles')
-rw-r--r--target/linux/brcm63xx/profiles/nucom.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/brcm63xx/profiles/nucom.mk b/target/linux/brcm63xx/profiles/nucom.mk
new file mode 100644
index 0000000000..2cd8801879
--- /dev/null
+++ b/target/linux/brcm63xx/profiles/nucom.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/R5010UNV2
+ NAME:=NuCom R5010UN v2
+ PACKAGES:=kmod-b43 wpad-mini \
+ kmod-usb2 kmod-usb-ohci kmod-ledtrig-usbdev
+endef
+define Profile/R5010UNV2/Description
+ Package set optimized for R5010UNV2.
+endef
+$(eval $(call Profile,R5010UNV2))