summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx/profiles
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-03-16 11:52:10 +0000
committerJonas Gorski <jogo@openwrt.org>2015-03-16 11:52:10 +0000
commitca7f6d28c8f811a1aa851554253304157f44256b (patch)
tree76d8b5741def450c320ad7228868a5052db47e4f /target/linux/brcm63xx/profiles
parent9dc137397fa64f2c47847d183260ff2d1cf052ae (diff)
downloadmaster-31e0f0ae-ca7f6d28c8f811a1aa851554253304157f44256b.tar.gz
master-31e0f0ae-ca7f6d28c8f811a1aa851554253304157f44256b.tar.bz2
master-31e0f0ae-ca7f6d28c8f811a1aa851554253304157f44256b.zip
brcm63xx: Add DGND3700 v1 / DGND3800B support
This adds support for the Netgear DGND3700 v1 and DGND3800B. DGND3700 v1 and DGND3800B are exactly the same router, only one difference, the factory firmware. This patch produces two factory firmwares for each router. The router includes an onboard NAND flash for extra storage. NAND is currently not supported in bcm63xx, so no code added for this part. The NOR flash (32MB) is enough for storing an openwrt firmware. Signed-off-by: Daniel Gonzalez <dgcbueu@gmail.com> [jogo: Add back commit message from v1] Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 44831
Diffstat (limited to 'target/linux/brcm63xx/profiles')
-rw-r--r--target/linux/brcm63xx/profiles/netgear.mk11
1 files changed, 10 insertions, 1 deletions
diff --git a/target/linux/brcm63xx/profiles/netgear.mk b/target/linux/brcm63xx/profiles/netgear.mk
index 75ddab53ce..20224a259a 100644
--- a/target/linux/brcm63xx/profiles/netgear.mk
+++ b/target/linux/brcm63xx/profiles/netgear.mk
@@ -12,7 +12,6 @@ endef
define Profile/CVG834G/Description
Package set optimized for CVG834G.
endef
-
$(eval $(call Profile,CVG834G))
define Profile/DG834GTPN
@@ -23,3 +22,13 @@ define Profile/DG834GTPN/Description
Package set optimized for DG834GT/PN.
endef
$(eval $(call Profile,DG834GTPN))
+
+define Profile/DGND3700v1_3800B
+ NAME:=Netgear DGND3700 v1 / DGND3800B
+ PACKAGES:=kmod-b43 wpad-mini \
+ kmod-usb2 kmod-usb-ohci kmod-ledtrig-usbdev
+endef
+define Profile/DGND3700v1_3800B/Description
+ Package set optimized for DGND3700 v1 / DGND3800B.
+endef
+$(eval $(call Profile,DGND3700v1_3800B))