summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx/profiles
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2014-12-08 16:10:46 +0000
committerJonas Gorski <jogo@openwrt.org>2014-12-08 16:10:46 +0000
commitb0ae41f849c237d2e1c842a9819fb3e3ec73f9b5 (patch)
tree44cb6b62c0fa75c50194e0dd23f2f92f8b241230 /target/linux/brcm63xx/profiles
parent84200cf18977336a2f74980f5ba25c88848bb1f1 (diff)
downloadmaster-31e0f0ae-b0ae41f849c237d2e1c842a9819fb3e3ec73f9b5.tar.gz
master-31e0f0ae-b0ae41f849c237d2e1c842a9819fb3e3ec73f9b5.tar.bz2
master-31e0f0ae-b0ae41f849c237d2e1c842a9819fb3e3ec73f9b5.zip
brcm63xx: add DT support for TD-W8900GB
According to the vendor tarball, the TD-w8900GB's flash has 64k erase block size, but CFE spans two blocks. So fixup the image offset accordingly but keep block size at its default (64k). Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> [jogo: add commit message, add image offset, change nvram offset] Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 43572
Diffstat (limited to 'target/linux/brcm63xx/profiles')
-rw-r--r--target/linux/brcm63xx/profiles/tp-link.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/target/linux/brcm63xx/profiles/tp-link.mk b/target/linux/brcm63xx/profiles/tp-link.mk
new file mode 100644
index 0000000000..a7e7f26e20
--- /dev/null
+++ b/target/linux/brcm63xx/profiles/tp-link.mk
@@ -0,0 +1,15 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/TDW8900GB
+ NAME:=TP-Link TD-W8900GB
+ PACKAGES:=kmod-b43 wpad-mini
+endef
+define Profile/TDW8900GB/Description
+ Package set optimized for TD-W8900GB.
+endef
+$(eval $(call Profile,TDW8900GB))