summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx/profiles
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-02-27 17:39:07 +0000
committerJonas Gorski <jogo@openwrt.org>2015-02-27 17:39:07 +0000
commit9a65e1a5706a9ae9ed45761fa78c863e5b811642 (patch)
tree6acd33fb69d26f74004c234885ff6ecc6f6a6695 /target/linux/brcm63xx/profiles
parent69b327247ca2e9a9b1c9ee8daafaccc507a165c3 (diff)
downloadmaster-31e0f0ae-9a65e1a5706a9ae9ed45761fa78c863e5b811642.tar.gz
master-31e0f0ae-9a65e1a5706a9ae9ed45761fa78c863e5b811642.tar.bz2
master-31e0f0ae-9a65e1a5706a9ae9ed45761fa78c863e5b811642.zip
brcm63xx: use dtb for cvg834g
Add a dtsi for bcm3368, add a dts and profile for cvg834g, and convert it to use ImageDTB. Since HCS requires more arguments, enhance the max arguments of the call. The image name is intentionally left blank to prevent non-initramfs images to be built, as they currently contain no rootfs and consequently won't work. Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 44561
Diffstat (limited to 'target/linux/brcm63xx/profiles')
-rw-r--r--target/linux/brcm63xx/profiles/netgear.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/brcm63xx/profiles/netgear.mk b/target/linux/brcm63xx/profiles/netgear.mk
index 562e0f5969..75ddab53ce 100644
--- a/target/linux/brcm63xx/profiles/netgear.mk
+++ b/target/linux/brcm63xx/profiles/netgear.mk
@@ -5,6 +5,16 @@
# See /LICENSE for more information.
#
+define Profile/CVG834G
+ NAME:=Netgear CVG834G
+ PACKAGES:=
+endef
+define Profile/CVG834G/Description
+ Package set optimized for CVG834G.
+endef
+
+$(eval $(call Profile,CVG834G))
+
define Profile/DG834GTPN
NAME:=Netgear DG834GT/PN
PACKAGES:=kmod-ath5k wpad-mini