summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx/profiles
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2014-08-21 11:28:46 +0000
committerJonas Gorski <jogo@openwrt.org>2014-08-21 11:28:46 +0000
commit2f09960e46f4f308a764ce04e4a466ab2ee06aa2 (patch)
tree3828b80fcfcfada857bbcef2ca14c1ed2612679c /target/linux/brcm63xx/profiles
parent7bc83fdd13ec436e635771a0c19cc56d2751779b (diff)
downloadmaster-31e0f0ae-2f09960e46f4f308a764ce04e4a466ab2ee06aa2.tar.gz
master-31e0f0ae-2f09960e46f4f308a764ce04e4a466ab2ee06aa2.tar.bz2
master-31e0f0ae-2f09960e46f4f308a764ce04e4a466ab2ee06aa2.zip
brcm63xx: Add DT support for HG520v
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> [jogo: fix nvram partition offset] Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 42246
Diffstat (limited to 'target/linux/brcm63xx/profiles')
-rw-r--r--target/linux/brcm63xx/profiles/huawei.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/brcm63xx/profiles/huawei.mk b/target/linux/brcm63xx/profiles/huawei.mk
index b0775c1343..1014884143 100644
--- a/target/linux/brcm63xx/profiles/huawei.mk
+++ b/target/linux/brcm63xx/profiles/huawei.mk
@@ -5,6 +5,15 @@
# See /LICENSE for more information.
#
+define Profile/HG520v
+ NAME:=Huawei EchoLife HG520v
+ PACKAGES:=kmod-b43 wpad-mini
+endef
+define Profile/HG520v/Description
+ Package set optimized for Huawei HG520v.
+endef
+$(eval $(call Profile,HG520v))
+
define Profile/HG556a_AB
NAME:=Huawei EchoLife HG556a (version A/B - Atheros)
PACKAGES:=kmod-ath9k wpad-mini \