summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx/profiles
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-03-25 15:35:12 +0000
committerJonas Gorski <jogo@openwrt.org>2015-03-25 15:35:12 +0000
commit2d3371cd0fa1bd3631633ad9c2ddd1d232d8397f (patch)
tree0d96527eccb0e68a4bddf9cf90cc07c5a057f4b4 /target/linux/brcm63xx/profiles
parent065d6e9047d235ffa916dcf0ce330bfc124e2fd0 (diff)
downloadmaster-31e0f0ae-2d3371cd0fa1bd3631633ad9c2ddd1d232d8397f.tar.gz
master-31e0f0ae-2d3371cd0fa1bd3631633ad9c2ddd1d232d8397f.tar.bz2
master-31e0f0ae-2d3371cd0fa1bd3631633ad9c2ddd1d232d8397f.zip
brcm63xx: Add BT Home Hub 2A support.
Support for the BT HomeHub 2.0 Type A. This router was manufactured by Thomson, and it's BCM6358 based. The leds are controled by two chained HC594, all working ok. The BCM5325 switch has the RESET# pin wired to the GPIO15, but currently there is no way to tell the b53 driver how to get this gpio number in brcm63xx, therefore swconfig won't use it when performing a switch reset. The patch was tested with several firmwares, and all except unsupported stuff (i.e xDSL) works pretty well. Tested-by: Tahir <tahir00ali@gmail.com> Signed-off-by: Daniel Gonzalez <dgcbueu@gmail.com> SVN-Revision: 44985
Diffstat (limited to 'target/linux/brcm63xx/profiles')
-rw-r--r--target/linux/brcm63xx/profiles/bt.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/brcm63xx/profiles/bt.mk b/target/linux/brcm63xx/profiles/bt.mk
index 0863752412..3ca8fe16ff 100644
--- a/target/linux/brcm63xx/profiles/bt.mk
+++ b/target/linux/brcm63xx/profiles/bt.mk
@@ -5,6 +5,16 @@
# See /LICENSE for more information.
#
+define Profile/BTHOMEHUB2A
+ NAME:=BT Home Hub 2A
+ PACKAGES:=kmod-b43 wpad-mini \
+ kmod-usb2 kmod-usb-ohci kmod-ledtrig-usbdev
+endef
+define Profile/BTHOMEHUB2A/Description
+ Package set optimized for BTHOMEHUB2A.
+endef
+$(eval $(call Profile,BTHOMEHUB2A))
+
define Profile/BTV2500V
NAME:=BT Voyager V2500V
PACKAGES:=kmod-b43 wpad-mini