summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx/patches-3.10/416-BCM63XX-add-a-fixup-for-ath9k-devices.patch
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2014-01-13 12:11:45 +0000
committerJonas Gorski <jogo@openwrt.org>2014-01-13 12:11:45 +0000
commitf08f0cafc24619242853e3fe11e2e5876c498551 (patch)
tree8d78856b36f0108ed23f2c724aff41e6690108dc /target/linux/brcm63xx/patches-3.10/416-BCM63XX-add-a-fixup-for-ath9k-devices.patch
parentd0a757147bcfb1813585638b08ee8e6a8d743254 (diff)
downloadmaster-31e0f0ae-f08f0cafc24619242853e3fe11e2e5876c498551.tar.gz
master-31e0f0ae-f08f0cafc24619242853e3fe11e2e5876c498551.tar.bz2
master-31e0f0ae-f08f0cafc24619242853e3fe11e2e5876c498551.zip
brcm63xx: update HSSPI driver with upstream submission
Update the HSSPI driver with the upstream submitted one that has a workaround for the auto cs down issue. Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 39264
Diffstat (limited to 'target/linux/brcm63xx/patches-3.10/416-BCM63XX-add-a-fixup-for-ath9k-devices.patch')
-rw-r--r--target/linux/brcm63xx/patches-3.10/416-BCM63XX-add-a-fixup-for-ath9k-devices.patch6
1 files changed, 4 insertions, 2 deletions
diff --git a/target/linux/brcm63xx/patches-3.10/416-BCM63XX-add-a-fixup-for-ath9k-devices.patch b/target/linux/brcm63xx/patches-3.10/416-BCM63XX-add-a-fixup-for-ath9k-devices.patch
index 8e2feb8bf6..5977a43b58 100644
--- a/target/linux/brcm63xx/patches-3.10/416-BCM63XX-add-a-fixup-for-ath9k-devices.patch
+++ b/target/linux/brcm63xx/patches-3.10/416-BCM63XX-add-a-fixup-for-ath9k-devices.patch
@@ -15,7 +15,7 @@ Subject: [PATCH 61/72] BCM63XX: add a fixup for ath9k devices
+++ b/arch/mips/bcm63xx/Makefile
@@ -2,7 +2,7 @@ obj-y += clk.o cpu.o cs.o gpio.o irq.o
setup.o timer.o dev-dsp.o dev-enet.o dev-flash.o \
- dev-hsspi.o dev-pcmcia.o dev-rng.o dev-spi.o dev-uart.o \
+ dev-pcmcia.o dev-rng.o dev-spi.o dev-hsspi.o dev-uart.o \
dev-wdt.o dev-usb-ehci.o dev-usb-ohci.o dev-usb-usbd.o \
- usb-common.o
+ pci-ath9k-fixup.o usb-common.o
@@ -24,7 +24,7 @@ Subject: [PATCH 61/72] BCM63XX: add a fixup for ath9k devices
obj-y += boards/
--- /dev/null
+++ b/arch/mips/bcm63xx/pci-ath9k-fixup.c
-@@ -0,0 +1,190 @@
+@@ -0,0 +1,192 @@
+/*
+ * Broadcom BCM63XX Ath9k EEPROM fixup helper.
+ *
@@ -53,6 +53,8 @@ Subject: [PATCH 61/72] BCM63XX: add a fixup for ath9k devices
+#include <bcm63xx_dev_hsspi.h>
+#include <pci_ath9k_fixup.h>
+
++#define bcm_hsspi_writel(v, o) bcm_rset_writel(RSET_HSSPI, (v), (o))
++
+struct ath9k_fixup {
+ unsigned slot;
+ u8 mac[ETH_ALEN];