summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx/patches-2.6.28/006-pcmcia_cardbus_support.patch
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2009-10-25 21:13:46 +0000
committerFlorian Fainelli <florian@openwrt.org>2009-10-25 21:13:46 +0000
commit338490bd50ce517c6fc8ccaac73dba65ec3c15d3 (patch)
tree846716da3415a035df64b7c801cc830d3ba262f3 /target/linux/brcm63xx/patches-2.6.28/006-pcmcia_cardbus_support.patch
parent7100c1efd9dd899ea7df82e425e7fa0fe744bd95 (diff)
downloadmaster-31e0f0ae-338490bd50ce517c6fc8ccaac73dba65ec3c15d3.tar.gz
master-31e0f0ae-338490bd50ce517c6fc8ccaac73dba65ec3c15d3.tar.bz2
master-31e0f0ae-338490bd50ce517c6fc8ccaac73dba65ec3c15d3.zip
remove 2.6.28 support, we never really used it
SVN-Revision: 18156
Diffstat (limited to 'target/linux/brcm63xx/patches-2.6.28/006-pcmcia_cardbus_support.patch')
-rw-r--r--target/linux/brcm63xx/patches-2.6.28/006-pcmcia_cardbus_support.patch43
1 files changed, 0 insertions, 43 deletions
diff --git a/target/linux/brcm63xx/patches-2.6.28/006-pcmcia_cardbus_support.patch b/target/linux/brcm63xx/patches-2.6.28/006-pcmcia_cardbus_support.patch
deleted file mode 100644
index e6e867f174..0000000000
--- a/target/linux/brcm63xx/patches-2.6.28/006-pcmcia_cardbus_support.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-From b17597be763621ba63534fda6e1ea0a802be2087 Mon Sep 17 00:00:00 2001
-From: Maxime Bizon <mbizon@freebox.fr>
-Date: Fri, 18 Jul 2008 21:18:51 +0200
-Subject: [PATCH] [MIPS] BCM63XX: Add PCMCIA & Cardbus support.
-
-Signed-off-by: Maxime Bizon <mbizon@freebox.fr>
----
- arch/mips/bcm63xx/Makefile | 1 +
- arch/mips/bcm63xx/dev-pcmcia.c | 135 +++++
- drivers/pcmcia/Kconfig | 4 +
- drivers/pcmcia/Makefile | 1 +
- drivers/pcmcia/bcm63xx_pcmcia.c | 521 ++++++++++++++++++++
- drivers/pcmcia/bcm63xx_pcmcia.h | 65 +++
- include/asm-mips/mach-bcm63xx/bcm63xx_dev_pcmcia.h | 13 +
- 7 files changed, 740 insertions(+), 0 deletions(-)
- create mode 100644 arch/mips/bcm63xx/dev-pcmcia.c
- create mode 100644 drivers/pcmcia/bcm63xx_pcmcia.c
- create mode 100644 drivers/pcmcia/bcm63xx_pcmcia.h
- create mode 100644 include/asm-mips/mach-bcm63xx/bcm63xx_dev_pcmcia.h
-
---- a/drivers/pcmcia/Kconfig
-+++ b/drivers/pcmcia/Kconfig
-@@ -192,6 +192,10 @@ config PCMCIA_AU1X00
- tristate "Au1x00 pcmcia support"
- depends on SOC_AU1X00 && PCMCIA
-
-+config PCMCIA_BCM63XX
-+ tristate "bcm63xx pcmcia support"
-+ depends on BCM63XX && PCMCIA
-+
- config PCMCIA_SA1100
- tristate "SA1100 support"
- depends on ARM && ARCH_SA1100 && PCMCIA
---- a/drivers/pcmcia/Makefile
-+++ b/drivers/pcmcia/Makefile
-@@ -27,6 +27,7 @@ obj-$(CONFIG_PCMCIA_SA1111) += sa11xx_
- obj-$(CONFIG_M32R_PCC) += m32r_pcc.o
- obj-$(CONFIG_M32R_CFC) += m32r_cfc.o
- obj-$(CONFIG_PCMCIA_AU1X00) += au1x00_ss.o
-+obj-$(CONFIG_PCMCIA_BCM63XX) += bcm63xx_pcmcia.o
- obj-$(CONFIG_PCMCIA_VRC4171) += vrc4171_card.o
- obj-$(CONFIG_PCMCIA_VRC4173) += vrc4173_cardu.o
- obj-$(CONFIG_OMAP_CF) += omap_cf.o