summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx/patches-2.6.27/020-watchdog.patch
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2008-12-17 14:06:03 +0000
committerFlorian Fainelli <florian@openwrt.org>2008-12-17 14:06:03 +0000
commit7ab973e1af9cd0f8153daa892c88cfacfe3ebf4c (patch)
tree3531da38ed263505765e424ed6e31d45b5621a6c /target/linux/brcm63xx/patches-2.6.27/020-watchdog.patch
parent0a74666c128cc3ba64c700a0e05b5f9d27bfbf0c (diff)
downloadmaster-31e0f0ae-7ab973e1af9cd0f8153daa892c88cfacfe3ebf4c.tar.gz
master-31e0f0ae-7ab973e1af9cd0f8153daa892c88cfacfe3ebf4c.tar.bz2
master-31e0f0ae-7ab973e1af9cd0f8153daa892c88cfacfe3ebf4c.zip
Add bcm63xx_wdt but do not enable it yet
SVN-Revision: 13677
Diffstat (limited to 'target/linux/brcm63xx/patches-2.6.27/020-watchdog.patch')
-rw-r--r--target/linux/brcm63xx/patches-2.6.27/020-watchdog.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/target/linux/brcm63xx/patches-2.6.27/020-watchdog.patch b/target/linux/brcm63xx/patches-2.6.27/020-watchdog.patch
new file mode 100644
index 0000000000..54f8a793a4
--- /dev/null
+++ b/target/linux/brcm63xx/patches-2.6.27/020-watchdog.patch
@@ -0,0 +1,29 @@
+--- a/drivers/watchdog/Makefile 2008-12-05 21:03:02.000000000 +0100
++++ b/drivers/watchdog/Makefile 2008-12-14 23:42:27.000000000 +0100
+@@ -102,6 +102,7 @@
+ obj-$(CONFIG_SIBYTE_WDOG) += sb_wdog.o
+ obj-$(CONFIG_AR7_WDT) += ar7_wdt.o
+ obj-$(CONFIG_TXX9_WDT) += txx9wdt.o
++obj-$(CONFIG_BCM63XX_WDT) += bcm63xx_wdt.o
+
+ # PARISC Architecture
+
+--- a/drivers/watchdog/Kconfig 2008-12-05 21:03:02.000000000 +0100
++++ b/drivers/watchdog/Kconfig 2008-12-14 23:43:55.000000000 +0100
+@@ -704,6 +704,16 @@
+ help
+ Hardware driver for the built-in watchdog timer on TXx9 MIPS SoCs.
+
++config BCM63XX_WDT
++ tristate "Broadcom BCM63xx hardware watchdog"
++ depends on BCM63XX
++ help
++ Watchdog driver for the built in watchdog hardware in Broadcom
++ BCM63xx SoC.
++
++ To compile thi driver as a loadable module, choose M here.
++ The module will be called bcm63xx_wdt.
++
+ # PARISC Architecture
+
+ # POWERPC Architecture