summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx/image
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-12-02 22:18:20 +0000
committerJonas Gorski <jogo@openwrt.org>2015-12-02 22:18:20 +0000
commitd12502b6663e8443dfd23e903c91b0e66a064be2 (patch)
treee6082aeec20180096e7c3b9278cfec16c9021641 /target/linux/brcm63xx/image
parent9d7e058a237f04d99797174f2764d90ac8b41818 (diff)
downloadmaster-31e0f0ae-d12502b6663e8443dfd23e903c91b0e66a064be2.tar.gz
master-31e0f0ae-d12502b6663e8443dfd23e903c91b0e66a064be2.tar.bz2
master-31e0f0ae-d12502b6663e8443dfd23e903c91b0e66a064be2.zip
brcm63xx: Add NuCom R5010UNv2 support
This patch adds support for the NuCom R5010UNv2. It's a BCM6328 based board. It has an onboard BCM43217 wifi chip. For this wifi chip looks like the brcmsmac driver isn't still supported, b43 drivers are used for the profile of the router. It's worth mentioning this board was affected by a bug solved with https://dev.openwrt.org/changeset/46707 Tested-by: Angel Fontan <angel.fontan@gmail.com> Signed-off-by: Daniel Gonzalez <dgcbueu@gmail.com> Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 47697
Diffstat (limited to 'target/linux/brcm63xx/image')
-rw-r--r--target/linux/brcm63xx/image/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/linux/brcm63xx/image/Makefile b/target/linux/brcm63xx/image/Makefile
index 95811168ba..53e4c217e8 100644
--- a/target/linux/brcm63xx/image/Makefile
+++ b/target/linux/brcm63xx/image/Makefile
@@ -590,6 +590,8 @@ $(eval $(call bcm63xxCfeRamdisk,DG834GV4,DG834GTv4,dg834g_v4,96348W3,6348))
$(eval $(call bcm63xxCfeNetgear,DGND3700v1_3800B,DGND3700v1,dgnd3700v1,96368MVWG,6368,--image-offset 0x20000 --block-size 0x20000,U12L144T01_NETGEAR_NEWLED,1))
# Netgear DGND3800B
$(eval $(call bcm63xxCfeNetgear,DGND3700v1_3800B,DGND3800B,dgnd3700v1,96368MVWG,6368,--image-offset 0x20000 --block-size 0x20000,U12L144T11_NETGEAR_NEWLED,1))
+# NuCom R5010UNv2
+$(eval $(call bcm63xxCfe,R5010UNV2,R5010UNv2,r5010unv2,96328ang,6328,--pad 8))
# Pirelli Alice Gate VoIP 2 Plus Wi-Fi AGPF-S0
$(eval $(call bcm63xxCfe,AGPF_S0,AGV2+W,agpf-s0,AGPF-S0,6358,--block-size 0x20000 --image-offset 0x20000 --signature2 IMAGE --tag-version 8))
# Pirelli A226G