summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx/image
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2014-12-08 16:10:46 +0000
committerJonas Gorski <jogo@openwrt.org>2014-12-08 16:10:46 +0000
commitb0ae41f849c237d2e1c842a9819fb3e3ec73f9b5 (patch)
tree44cb6b62c0fa75c50194e0dd23f2f92f8b241230 /target/linux/brcm63xx/image
parent84200cf18977336a2f74980f5ba25c88848bb1f1 (diff)
downloadmaster-31e0f0ae-b0ae41f849c237d2e1c842a9819fb3e3ec73f9b5.tar.gz
master-31e0f0ae-b0ae41f849c237d2e1c842a9819fb3e3ec73f9b5.tar.bz2
master-31e0f0ae-b0ae41f849c237d2e1c842a9819fb3e3ec73f9b5.zip
brcm63xx: add DT support for TD-W8900GB
According to the vendor tarball, the TD-w8900GB's flash has 64k erase block size, but CFE spans two blocks. So fixup the image offset accordingly but keep block size at its default (64k). Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> [jogo: add commit message, add image offset, change nvram offset] Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 43572
Diffstat (limited to 'target/linux/brcm63xx/image')
-rwxr-xr-xtarget/linux/brcm63xx/image/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/target/linux/brcm63xx/image/Makefile b/target/linux/brcm63xx/image/Makefile
index 48492fabf6..ac92c55248 100755
--- a/target/linux/brcm63xx/image/Makefile
+++ b/target/linux/brcm63xx/image/Makefile
@@ -207,9 +207,6 @@ define Image/Build
# Belkin f5d7633
$(call Image/Build/CFE,$(1),96348GW-10,6348,F5D7633)
- # TP-Link 8900GB
- $(call Image/Build/CFE,$(1),96348GW-11,6348,TD8900GB,$(shell printf 'PRID\x89\x10\x00\x02'))
-
# Inventel Livebox
$(call Image/Build/RedBoot,livebox)
@@ -329,6 +326,8 @@ $(eval $(call ImageDTB,CFEDTB,GW6000,gw6000,96348GW,6348,GW6000))
$(eval $(call ImageDTB,CFEDTB,GW6200,gw6200,96348GW,6348,GW6200,--rsa-signature "$(shell printf '\x99')"))
# Telsey CPVA642-type (e.g. CPA-ZNTE60T)
$(eval $(call ImageDTB,CFEDTB,CPVA642,cpva642,CPVA642,6358,CPA-ZNTE60T,--signature "Telsey Tlc" --signature2 "99.99.999" --second-image-flag "0" --pad 4))
+# TP-Link TD-W8900GB
+$(eval $(call ImageDTB,CFEDTB,TDW8900GB,td-w8900gb,96348GW-11,6348,TD-W8900GB,--rsa-signature "$(shell printf 'PRID\x89\x10\x00\x02')" --image-offset 0x20000))
# SFR Neufbox 4
$(eval $(call ImageDTB,CFEDTB,Neufbox4,nb4-ser-r0,96358VW,6358,NEUFBOX4-SER,--rsa-signature "OpenWRT-$(REVISION)"))
$(eval $(call ImageDTB,CFEDTB,Neufbox4,nb4-fxc-r1,96358VW,6358,NEUFBOX4-FXC,--rsa-signature "OpenWRT-$(REVISION)"))