summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx/image
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-08-14 13:05:22 +0000
committerJonas Gorski <jogo@openwrt.org>2015-08-14 13:05:22 +0000
commit8e69c9f7ef2e1ca40b33a4a33c76b460c1f62861 (patch)
tree350321a0e1cd4bf2449f960da1422253c73d2cff /target/linux/brcm63xx/image
parent4ecae78c1605e48d35f130dbd62b7b3dcb9a0540 (diff)
downloadmaster-31e0f0ae-8e69c9f7ef2e1ca40b33a4a33c76b460c1f62861.tar.gz
master-31e0f0ae-8e69c9f7ef2e1ca40b33a4a33c76b460c1f62861.tar.bz2
master-31e0f0ae-8e69c9f7ef2e1ca40b33a4a33c76b460c1f62861.zip
image.mk: store the device name variable
Make the device name accessible for any build commands instead of forcing targets to define it themselves. Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 46597
Diffstat (limited to 'target/linux/brcm63xx/image')
-rwxr-xr-xtarget/linux/brcm63xx/image/Makefile13
1 files changed, 1 insertions, 12 deletions
diff --git a/target/linux/brcm63xx/image/Makefile b/target/linux/brcm63xx/image/Makefile
index c5c982f5e1..f15b30b5f1 100755
--- a/target/linux/brcm63xx/image/Makefile
+++ b/target/linux/brcm63xx/image/Makefile
@@ -175,10 +175,9 @@ define Device/Default
PROFILES = Default $$(DEVICE_PROFILE)
KERNEL_INITRAMFS_IMAGE = $$(KERNEL_INITRAMFS_PREFIX).elf
DEVICE_PROFILE :=
- DEVICE_NAME :=
DEVICE_DTS :=
endef
-DEVICE_VARS += DEVICE_PROFILE DEVICE_NAME DEVICE_DTS
+DEVICE_VARS += DEVICE_PROFILE DEVICE_DTS
# BCM33xx HCS devices: only generates ramdisks (unsupported bin images)
define Device/bcm33xxHcsRamdisk
@@ -313,7 +312,6 @@ define bcm33xxHcsRamdisk
define Device/$(2)
$$(Device/bcm33xxHcsRamdisk)
DEVICE_PROFILE := $(1)
- DEVICE_NAME := $(2)
DEVICE_DTS := $(3)
HCS_MAGIC_BYTES := $(4)
HCS_REV_MIN := $(5)
@@ -329,7 +327,6 @@ define bcm63xxCfeRamdisk
define Device/$(2)
$$(Device/bcm63xxCfeRamdisk)
DEVICE_PROFILE := $(1)
- DEVICE_NAME := $(2)
DEVICE_DTS := $(3)
endef
TARGET_DEVICES += $(2)
@@ -345,7 +342,6 @@ define bcm63xxCfe
define Device/$(2)
$$(Device/bcm63xxCfe)
DEVICE_PROFILE := $(1)
- DEVICE_NAME := $(2)
DEVICE_DTS := $(3)
CFE_BOARD_ID := $(4)
CFE_CHIP_ID := $(5)
@@ -364,7 +360,6 @@ define bcm63xxCfeMultiFlash
define Device/$(2)
$$(Device/bcm63xxCfeMultiFlash)
DEVICE_PROFILE := $(1)
- DEVICE_NAME := $(2)
DEVICE_DTS := $(3)
CFE_BOARD_ID := $(4)
CFE_CHIP_ID := $(5)
@@ -383,7 +378,6 @@ define bcm63xxCfeBc221
define Device/$(2)
$$(Device/bcm63xxCfeBc221)
DEVICE_PROFILE := $(1)
- DEVICE_NAME := $(2)
DEVICE_DTS := $(3)
CFE_BOARD_ID := $(4)
CFE_CHIP_ID := $(5)
@@ -404,7 +398,6 @@ define bcm63xxCfeNetgear
define Device/$(2)
$$(Device/bcm63xxCfeNetgear)
DEVICE_PROFILE := $(1)
- DEVICE_NAME := $(2)
DEVICE_DTS := $(3)
CFE_BOARD_ID := $(4)
CFE_CHIP_ID := $(5)
@@ -425,7 +418,6 @@ define bcm63xxCfeOld
define Device/$(2)
$$(Device/bcm63xxCfeOld)
DEVICE_PROFILE := $(1)
- DEVICE_NAME := $(2)
DEVICE_DTS := $(3)
CFE_BOARD_ID := $(4)
CFE_CHIP_ID := $(5)
@@ -444,7 +436,6 @@ define bcm63xxCfeSpw303v
define Device/$(2)
$$(Device/bcm63xxCfeSpw303v)
DEVICE_PROFILE := $(1)
- DEVICE_NAME := $(2)
DEVICE_DTS := $(3)
CFE_BOARD_ID := $(4)
CFE_CHIP_ID := $(5)
@@ -463,7 +454,6 @@ define bcm63xxCfeZyxel
define Device/$(2)
$$(Device/bcm63xxCfeZyxel)
DEVICE_PROFILE := $(1)
- DEVICE_NAME := $(2)
DEVICE_DTS := $(3)
CFE_BOARD_ID := $(4)
CFE_CHIP_ID := $(5)
@@ -479,7 +469,6 @@ define bcm63xxRedBoot
define Device/$(2)
$$(Device/bcm63xxRedBoot)
DEVICE_PROFILE := $(1)
- DEVICE_NAME := $(2)
DEVICE_DTS := $(3)
endef
TARGET_DEVICES += $(2)