summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx/image
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-07-16 11:13:47 +0000
committerJonas Gorski <jogo@openwrt.org>2015-07-16 11:13:47 +0000
commit71e0bd0165e4efc6c49cddaab80f1660b7fc58db (patch)
tree4cd14ada49ea982b744a33b3c0e05a913ba0cd9e /target/linux/brcm63xx/image
parente7b5dd0e1dd5eacd13bee7bc5da2eeea8882e668 (diff)
downloadmaster-31e0f0ae-71e0bd0165e4efc6c49cddaab80f1660b7fc58db.tar.gz
master-31e0f0ae-71e0bd0165e4efc6c49cddaab80f1660b7fc58db.tar.bz2
master-31e0f0ae-71e0bd0165e4efc6c49cddaab80f1660b7fc58db.zip
brcm63xx: make use of the new BuildDTB command
Now that we have a BuildDTB command, make use of it instead of calling dtc directly. Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 46390
Diffstat (limited to 'target/linux/brcm63xx/image')
-rwxr-xr-xtarget/linux/brcm63xx/image/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/brcm63xx/image/Makefile b/target/linux/brcm63xx/image/Makefile
index 63cd90a17d..98d145276c 100755
--- a/target/linux/brcm63xx/image/Makefile
+++ b/target/linux/brcm63xx/image/Makefile
@@ -198,7 +198,7 @@ endef
define Image/PrepareCFELzmaKernelDTB
# compile the dts (the dtb will be later reused for the lzma loader)
- $(LINUX_DIR)/scripts/dtc/dtc -O dtb -o $(DTS_DIR)/$(1).dtb ../dts/$(1).dts
+ $(call Image/BuildDTB,../dts/$(1).dts,$(DTS_DIR)/$(1).dtb)
cat $(KDIR)/vmlinux $(DTS_DIR)/$(1).dtb > $(KDIR)/vmlinux-$(1)
$(call Image/PrepareCFELzmaKernel,-$(1))
rm -f $(KDIR)/vmlinux-$(1)