summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx/image
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-05-21 19:31:54 +0000
committerJonas Gorski <jogo@openwrt.org>2015-05-21 19:31:54 +0000
commit509c3211d66ec5d3bc741361c06eff993bf39b85 (patch)
treeb621d227112a6e8a32bec3d59d29e4304938e57c /target/linux/brcm63xx/image
parent8304c0c04d4ab254d4b2ac2467f70e927b553a1a (diff)
downloadmaster-31e0f0ae-509c3211d66ec5d3bc741361c06eff993bf39b85.tar.gz
master-31e0f0ae-509c3211d66ec5d3bc741361c06eff993bf39b85.tar.bz2
master-31e0f0ae-509c3211d66ec5d3bc741361c06eff993bf39b85.zip
brcm63xx: Add Huawei HG655b support
This patch adds support for the Huawei HG655b. Nothing much special in this router, it's just another BCM6368 with a Ralink RT3062 wifi chip and the calibration data embedded in the main flash chip at offset 0x7c0000. There is also configuration data used by the OEM firmware before the cal_data partition, this area is protected by the board_data partition in this patch. Signed-off-by: Daniel Gonzalez <dgcbueu@gmail.com> Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 45708
Diffstat (limited to 'target/linux/brcm63xx/image')
-rwxr-xr-xtarget/linux/brcm63xx/image/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/linux/brcm63xx/image/Makefile b/target/linux/brcm63xx/image/Makefile
index e98011d56f..0d8ce5338f 100755
--- a/target/linux/brcm63xx/image/Makefile
+++ b/target/linux/brcm63xx/image/Makefile
@@ -360,6 +360,8 @@ $(eval $(call ImageDTB,CFEDTB,HG553,HG553,hg553,HW553,6358,--rsa-signature "Echo
$(eval $(call ImageDTB,CFEDTB,HG556a_AB,HG556a_A,hg556a-a,HW556,6358,--rsa-signature "EchoLife_HG556a" --image-offset 0x20000 --block-size 0x10000 --tag-version 8))
$(eval $(call ImageDTB,CFEDTB,HG556a_AB,HG556a_B,hg556a-b,HW556,6358,--rsa-signature "EchoLife_HG556a" --image-offset 0x20000 --block-size 0x20000 --tag-version 8))
$(eval $(call ImageDTB,CFEDTB,HG556a_C,HG556a_C,hg556a-c,HW556,6358,--rsa-signature "EchoLife_HG556a" --image-offset 0x20000 --block-size 0x20000 --tag-version 8))
+# Huawei HG655b
+$(eval $(call ImageDTB,CFEDTB,HG655b,HG655b,hg655b,HW65x,6368,--image-offset 0x20000 --tag-version 7 --pad 4))
# Inteno VG50
$(eval $(call ImageDTB,Dummy,VG50,vg50,vg50,VW6339GU,63268))
# Inventel Livebox 1