summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx/image/Makefile
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-03-16 11:52:10 +0000
committerJonas Gorski <jogo@openwrt.org>2015-03-16 11:52:10 +0000
commitca7f6d28c8f811a1aa851554253304157f44256b (patch)
tree76d8b5741def450c320ad7228868a5052db47e4f /target/linux/brcm63xx/image/Makefile
parent9dc137397fa64f2c47847d183260ff2d1cf052ae (diff)
downloadmaster-31e0f0ae-ca7f6d28c8f811a1aa851554253304157f44256b.tar.gz
master-31e0f0ae-ca7f6d28c8f811a1aa851554253304157f44256b.tar.bz2
master-31e0f0ae-ca7f6d28c8f811a1aa851554253304157f44256b.zip
brcm63xx: Add DGND3700 v1 / DGND3800B support
This adds support for the Netgear DGND3700 v1 and DGND3800B. DGND3700 v1 and DGND3800B are exactly the same router, only one difference, the factory firmware. This patch produces two factory firmwares for each router. The router includes an onboard NAND flash for extra storage. NAND is currently not supported in bcm63xx, so no code added for this part. The NOR flash (32MB) is enough for storing an openwrt firmware. Signed-off-by: Daniel Gonzalez <dgcbueu@gmail.com> [jogo: Add back commit message from v1] Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 44831
Diffstat (limited to 'target/linux/brcm63xx/image/Makefile')
-rwxr-xr-xtarget/linux/brcm63xx/image/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/target/linux/brcm63xx/image/Makefile b/target/linux/brcm63xx/image/Makefile
index dd1635527f..3fb9b1cd2b 100755
--- a/target/linux/brcm63xx/image/Makefile
+++ b/target/linux/brcm63xx/image/Makefile
@@ -111,6 +111,12 @@ define Image/Build/HCSDTB
--output_file=$(BIN_DIR)/openwrt-$(2)-$(1).bin
endef
+define Image/Build/ChkDTB
+ # Generate Netgear factory image
+ $(STAGING_DIR_HOST)/bin/mkchkimg -o $(BIN_DIR)/openwrt-$(2)-$(1)-factory.chk \
+ -k $(BIN_DIR)/openwrt-$(4)-$(1)-cfe.bin -b $(5) -r $(6)
+endef
+
define Build/Clean
$(MAKE) -C lzma-loader clean
endef
@@ -303,6 +309,12 @@ $(eval $(call ImageDTB,RedBootDTB,Livebox,livebox,livebox-blue-5g))
$(eval $(call ImageDTB,HCSDTB,CVG834G,,cvg834g,a020,0001,0022,vmlinux-cvg834g))
# Netgear DG834GT/PN
$(eval $(call ImageDTB,CFEDTB,DG834GTPN,DG834GT_PN,dg834gtpn,96348GW-10,6348))
+# Netgear DGND3700 v1 / DGND3800B
+$(eval $(call ImageDTB,CFEDTB,DGND3700v1_3800B,DGND3700v1_3800B,dgnd3700v1,96368MVWG,6368,--image-offset 0x20000 --block-size 0x20000))
+#Netgear DGND3700 v1 factory firmware
+$(eval $(call ImageDTB,ChkDTB,DGND3700v1_3800B,DGND3700v1,,DGND3700v1_3800B,U12L144T01_NETGEAR_NEWLED,1))
+#Netgear DGND3800B factory firmware
+$(eval $(call ImageDTB,ChkDTB,DGND3700v1_3800B,DGND3800B,,DGND3700v1_3800B,U12L144T11_NETGEAR_NEWLED,1))
# Pirelli Alice Gate VoIP 2 Plus Wi-Fi AGPF-S0
$(eval $(call ImageDTB,CFEDTB,AGPF_S0,AGV2+W,agpf-s0,AGPF-S0,6358,--block-size 0x20000 --image-offset 0x20000 --signature2 IMAGE --tag-version 8))
# Pirelli A226G