summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx/generic
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2014-07-12 12:31:39 +0000
committerJonas Gorski <jogo@openwrt.org>2014-07-12 12:31:39 +0000
commite5cadabb58808a0a65ca4a7530befc176b085646 (patch)
tree66deec2229fc027ca0dcf8e5987eb04ba5815783 /target/linux/brcm63xx/generic
parentbeb25f96eb444b5770008959f3247a50225a16db (diff)
downloadmaster-31e0f0ae-e5cadabb58808a0a65ca4a7530befc176b085646.tar.gz
master-31e0f0ae-e5cadabb58808a0a65ca4a7530befc176b085646.tar.bz2
master-31e0f0ae-e5cadabb58808a0a65ca4a7530befc176b085646.zip
brcm63xx: Fix HW553 support
- adsl and lan leds are swapped. - internetkey is labeled as hspa. - enable status led and reset button for failsafe. - use new leds script. - fix switch configuration. - remove enet0 from board_info. - add profile. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 41588
Diffstat (limited to 'target/linux/brcm63xx/generic')
-rw-r--r--target/linux/brcm63xx/generic/profiles/201-Huawei.mk (renamed from target/linux/brcm63xx/generic/profiles/201-HW556.mk)13
1 files changed, 11 insertions, 2 deletions
diff --git a/target/linux/brcm63xx/generic/profiles/201-HW556.mk b/target/linux/brcm63xx/generic/profiles/201-Huawei.mk
index 68861b3ef2..3cdd018ace 100644
--- a/target/linux/brcm63xx/generic/profiles/201-HW556.mk
+++ b/target/linux/brcm63xx/generic/profiles/201-Huawei.mk
@@ -1,10 +1,20 @@
#
-# Copyright (C) 2012 OpenWrt.org
+# Copyright (C) 2012-2014 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
+define Profile/HW553
+ NAME:=Huawei HG553
+ PACKAGES:=kmod-b43 wpad-mini \
+ kmod-usb2 kmod-usb-ohci kmod-ledtrig-usbdev
+endef
+define Profile/HW553/Description
+ Package set optimized for Huawei HG553 using open-source b43 WiFi driver
+endef
+$(eval $(call Profile,HW553))
+
define Profile/HW556
NAME:=HW556 WiFi
PACKAGES:=kmod-rt2800-pci kmod-ath9k wpad-mini
@@ -14,4 +24,3 @@ define Profile/HW556/Description
Package set compatible with hardware using Atheros or Ralink WiFi cards (Huawei HG556a)
endef
$(eval $(call Profile,HW556))
-