summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm63xx-2.6/profiles/Broadcom.mk
diff options
context:
space:
mode:
authorTim Yardley <lst@openwrt.org>2007-03-02 23:02:38 +0000
committerTim Yardley <lst@openwrt.org>2007-03-02 23:02:38 +0000
commit03beb39e5f76f6361adc99244afb4d274310d158 (patch)
treead51f5b31163969f63c468720c0ac606bf0fe17e /target/linux/brcm63xx-2.6/profiles/Broadcom.mk
parentfa859ea32a7d0775e426b80757b37c09e3e2282c (diff)
downloadmaster-31e0f0ae-03beb39e5f76f6361adc99244afb4d274310d158.tar.gz
master-31e0f0ae-03beb39e5f76f6361adc99244afb4d274310d158.tar.bz2
master-31e0f0ae-03beb39e5f76f6361adc99244afb4d274310d158.zip
split out profile definitions from Makefiles
structure is as follows: target/linux/<arch>/profiles/<profilename>.mk These files are included by a blob match in the target Makefile The files should be labeled based on their profile Name in the definition SVN-Revision: 6468
Diffstat (limited to 'target/linux/brcm63xx-2.6/profiles/Broadcom.mk')
-rw-r--r--target/linux/brcm63xx-2.6/profiles/Broadcom.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/target/linux/brcm63xx-2.6/profiles/Broadcom.mk b/target/linux/brcm63xx-2.6/profiles/Broadcom.mk
new file mode 100644
index 0000000000..5fe71bb525
--- /dev/null
+++ b/target/linux/brcm63xx-2.6/profiles/Broadcom.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom
+ NAME:=Broadcom WiFi (default)
+ PACKAGES:=kmod-net-bcm43xx
+endef
+
+define Profile/Broadcom/Description
+ Package set compatible with hardware using Broadcom WiFi cards
+endef
+$(eval $(call Profile,Broadcom))
+