summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm47xx
diff options
context:
space:
mode:
authorRafał Miłecki <zajec5@gmail.com>2016-03-08 18:33:16 +0000
committerRafał Miłecki <zajec5@gmail.com>2016-03-08 18:33:16 +0000
commit6eb0df3543a22f17d820f75dfd2637d349564fea (patch)
tree602028202700e88cba9ef270b53587a77f461746 /target/linux/brcm47xx
parent0ca70716324d88e5e8b956035ee71cc1b32bda8d (diff)
downloadmaster-31e0f0ae-6eb0df3543a22f17d820f75dfd2637d349564fea.tar.gz
master-31e0f0ae-6eb0df3543a22f17d820f75dfd2637d349564fea.tar.bz2
master-31e0f0ae-6eb0df3543a22f17d820f75dfd2637d349564fea.zip
brcm47xx: image: switch D-Link DWL-3150 to the new building system
Signed-off-by: Rafał Miłecki <zajec5@gmail.com> SVN-Revision: 48970
Diffstat (limited to 'target/linux/brcm47xx')
-rw-r--r--target/linux/brcm47xx/image/Makefile20
1 files changed, 13 insertions, 7 deletions
diff --git a/target/linux/brcm47xx/image/Makefile b/target/linux/brcm47xx/image/Makefile
index c290f9a4fa..f4e0acb192 100644
--- a/target/linux/brcm47xx/image/Makefile
+++ b/target/linux/brcm47xx/image/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2012 OpenWrt.org
+# Copyright (C) 2006-2016 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -39,11 +39,6 @@ define Image/Build/wgt634u
cat $(BIN_DIR)/$(IMG_PREFIX)-$(1).trx >> $(BIN_DIR)/$(IMG_PREFIX)-wgt634u-$(2).bin
endef
-define Image/Build/dwl3150
- cp $(BIN_DIR)/$(IMG_PREFIX)-$(1).trx $(BIN_DIR)/$(IMG_PREFIX)-dwl3150-$(2).bin
- echo "BCM-5352-2050-0000000-01" >> $(BIN_DIR)/$(IMG_PREFIX)-dwl3150-$(2).bin
-endef
-
# $(1): filesystem type.
# $(2): device model (used for output file).
# $(3): pattern (device specific magic).
@@ -131,6 +126,10 @@ define Build/linksys-bin
mv $@.new $@
endef
+define Build/tailed-bin
+ echo $(BIN_TAIL) >> $@
+endef
+
#################################################
# Devices
#################################################
@@ -138,6 +137,7 @@ endef
DEVICE_VARS += PRODUCTID
DEVICE_VARS += DEVICE_ID VERSION
DEVICE_VARS += NETGEAR_BOARD_ID NETGEAR_REGION
+DEVICE_VARS += BIN_TAIL
define Device/Default
KERNEL := kernel-bin
@@ -217,7 +217,6 @@ endef
# $(1): filesystem type.
define Image/Build/legacy/devices-with-64k-blocks
- $(call Image/Build/dwl3150,$(1),$(patsubst jffs2-%,jffs2,$(1)))
$(call Image/Build/Edi,$(1),ps1208mfg,$(patsubst jffs2-%,jffs2,$(1)))
$(call Image/Build/Huawei,$(1),e970,$(1))
$(call Image/Build/Motorola,$(1),wa840g,2,$(patsubst jffs2-%,jffs2,$(1)))
@@ -242,6 +241,12 @@ define Image/Build/legacy/squashfs
$(call Image/Build/legacy/devices-with-128k-blocks,$(1))
endef
+define Device/dlink-dwl-3150
+ IMAGES := bin
+ IMAGE/bin := trx-with-loader | tailed-bin
+ BIN_TAIL := BCM-5352-2050-0000000-01
+endef
+
define Device/linksys-wrt54gs
$(Device/linksys)
FILESYSTEMS := $(FS_128K)
@@ -258,6 +263,7 @@ endef
ifeq ($(SUBTARGET),legacy)
TARGET_DEVICES += \
+ dlink-dwl-3150 \
linksys-wrt54gs \
linksys-wrtsl54gs