summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm47xx
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-07-30 14:19:11 +0200
committerFelix Fietkau <nbd@nbd.name>2016-07-31 12:25:25 +0200
commit63b525dd6b209af5554a2d053efd4b3ce6f60c9c (patch)
treeb4bf688fa7ce3b9cbbad996dd0d60730eacbede9 /target/linux/brcm47xx
parent9201e88f518dbe5246aa2f77342175805ef10cdd (diff)
downloadmaster-31e0f0ae-63b525dd6b209af5554a2d053efd4b3ce6f60c9c.tar.gz
master-31e0f0ae-63b525dd6b209af5554a2d053efd4b3ce6f60c9c.tar.bz2
master-31e0f0ae-63b525dd6b209af5554a2d053efd4b3ce6f60c9c.zip
image: add a helper variable for getting kernel/rootfs from within image Build/* templates
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux/brcm47xx')
-rw-r--r--target/linux/brcm47xx/image/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/brcm47xx/image/Makefile b/target/linux/brcm47xx/image/Makefile
index a65e9e00c3..b9cdbf4393 100644
--- a/target/linux/brcm47xx/image/Makefile
+++ b/target/linux/brcm47xx/image/Makefile
@@ -53,7 +53,7 @@ define Build/trx-with-loader
-m 33554432 \
-o $@ \
-f $(KDIR)/loader.gz \
- -f $(word 1,$^) \
+ -f $(IMAGE_KERNEL) \
$(call trxalign/$(FILESYSTEM),$(FILESYSTEM))
endef
@@ -72,7 +72,7 @@ define Build/trx-without-loader
$(STAGING_DIR_HOST)/bin/trx \
-m 33554432 \
-o $@ \
- -f $(word 1,$^) \
+ -f $(IMAGE_KERNEL) \
$(call trxalign/$(FILESYSTEM),$(FILESYSTEM))
endef