summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm47xx
diff options
context:
space:
mode:
authorRafał Miłecki <zajec5@gmail.com>2016-03-09 06:34:29 +0000
committerRafał Miłecki <zajec5@gmail.com>2016-03-09 06:34:29 +0000
commit4e6e23582b963f963e8a44eb5db7b30749a7a4d3 (patch)
treee9b0f532bc9cd1fc8fc3125dcae6633b9b05a02a /target/linux/brcm47xx
parent9a6ad203f65cfe9e4a134f8c4f2b0af72730dd94 (diff)
downloadmaster-31e0f0ae-4e6e23582b963f963e8a44eb5db7b30749a7a4d3.tar.gz
master-31e0f0ae-4e6e23582b963f963e8a44eb5db7b30749a7a4d3.tar.bz2
master-31e0f0ae-4e6e23582b963f963e8a44eb5db7b30749a7a4d3.zip
brcm47xx: image: move disabled devices to the new building system
This only drops WGR614 V9 which has 2 MiB flash and it's unlikely to get any interest. Signed-off-by: Rafał Miłecki <zajec5@gmail.com> SVN-Revision: 48975
Diffstat (limited to 'target/linux/brcm47xx')
-rw-r--r--target/linux/brcm47xx/image/Makefile16
1 files changed, 3 insertions, 13 deletions
diff --git a/target/linux/brcm47xx/image/Makefile b/target/linux/brcm47xx/image/Makefile
index 4ce6f42b4d..bbdb36b55e 100644
--- a/target/linux/brcm47xx/image/Makefile
+++ b/target/linux/brcm47xx/image/Makefile
@@ -34,15 +34,6 @@ endif
$(call prepare_generic_squashfs,$(KDIR)/fs_mark)
endef
-# $(1): filesystem type.
-# $(2): device model (used for output file).
-# $(3): board_id (device specific magic).
-# $(4): region.
-# $(5): simplified filesystem type (without block size).
-define Image/Build/Chk
- $(STAGING_DIR_HOST)/bin/mkchkimg -o $(BIN_DIR)/$(IMG_PREFIX)-$(2)-$(5).chk -k $(BIN_DIR)/$(IMG_PREFIX)-$(1).trx -b $(3) -r $(4)
-endef
-
define trxalign/jffs2-128k
-a 0x20000 -f $(KDIR)/root.$(1)
endef
@@ -357,6 +348,7 @@ ifeq ($(SUBTARGET),mips74k)
$(eval $(call NetgearDevice,wndr3400-v2,U12H187T00_NETGEAR,2))
$(eval $(call NetgearDevice,wndr3400-v3,U12H208T00_NETGEAR,1))
$(eval $(call NetgearDevice,wndr3700-v3,U12H194T00_NETGEAR,2))
+# $(eval $(call NetgearDevice,wndr3400-vcna,U12H155T01_NETGEAR,2))
$(eval $(call NetgearDevice,wndr4000,U12H181T00_NETGEAR,2))
$(eval $(call NetgearDevice,wnr1000-v3,U12H139T00_NETGEAR,2))
$(eval $(call NetgearDevice,wnr2000v2,U12H114T00_NETGEAR,2))
@@ -364,7 +356,9 @@ ifeq ($(SUBTARGET),mips74k)
$(eval $(call NetgearDevice,wnr3500l-v1-north-america,U12H136T99_NETGEAR,2))
$(eval $(call NetgearDevice,wnr3500l-v1-other-regions,U12H136T99_NETGEAR,1))
$(eval $(call NetgearDevice,wnr3500l-v2,U12H172T00_NETGEAR,1))
+# $(eval $(call NetgearDevice,wnr3500u,U12H136T00_NETGEAR,2))
$(eval $(call NetgearDevice,wnr3500-v2,U12H127T00_NETGEAR,2))
+# $(eval $(call NetgearDevice,wnr3500-v2-vc,U12H127T70_NETGEAR,2))
endif
#################################################
@@ -400,10 +394,6 @@ define Image/Build
-o $(BIN_DIR)/$(IMG_PREFIX)-$(1)-gz.trx \
-f $(KDIR)/vmlinux.gz \
$(call trxalign/$(1),$(1))
-# $(call Image/Build/Chk,$(1),wgr614_v9,U12H094T00_NETGEAR,2,$(patsubst jffs2-%,jffs2,$(1)))
-# $(call Image/Build/Chk,$(1),wndr3400_vcna,U12H155T01_NETGEAR,2,$(patsubst jffs2-%,jffs2,$(1)))
-# $(call Image/Build/Chk,$(1),wnr3500U,U12H136T00_NETGEAR,2,$(patsubst jffs2-%,jffs2,$(1)))
-# $(call Image/Build/Chk,$(1),wnr3500v2_VC,U12H127T70_NETGEAR,2,$(patsubst jffs2-%,jffs2,$(1)))
ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
$(call Image/Build/Initramfs)
endif