summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm47xx
diff options
context:
space:
mode:
authorRafał Miłecki <zajec5@gmail.com>2015-05-27 13:54:19 +0000
committerRafał Miłecki <zajec5@gmail.com>2015-05-27 13:54:19 +0000
commitf08a10f2b98535c256cc4066c6c90b746890b820 (patch)
tree7d29a37e097164aa15d56ef0bbd16a40d2c26c23 /target/linux/brcm47xx
parent6feb68603a59f53a81e56949e03b3ac1bf18e10e (diff)
downloadmaster-31e0f0ae-f08a10f2b98535c256cc4066c6c90b746890b820.tar.gz
master-31e0f0ae-f08a10f2b98535c256cc4066c6c90b746890b820.tar.bz2
master-31e0f0ae-f08a10f2b98535c256cc4066c6c90b746890b820.zip
brcm47xx: build image for Asus RT-N66U
Signed-off-by: Rafał Miłecki <zajec5@gmail.com> SVN-Revision: 45774
Diffstat (limited to 'target/linux/brcm47xx')
-rw-r--r--target/linux/brcm47xx/image/Makefile20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/brcm47xx/image/Makefile b/target/linux/brcm47xx/image/Makefile
index a3c8489f19..c6ec0fe90c 100644
--- a/target/linux/brcm47xx/image/Makefile
+++ b/target/linux/brcm47xx/image/Makefile
@@ -116,6 +116,11 @@ define Build/trx-with-loader
$(call trxalign/$(FILESYSTEM),$(FILESYSTEM))
endef
+define Build/asus-trx
+ $(STAGING_DIR_HOST)/bin/asustrx -p $(PRODUCTID) -i $@ -o $@.new
+ mv $@.new $@
+endef
+
define Build/linksys-bin
$(STAGING_DIR_HOST)/bin/addpattern -4 -p $(DEVICE_ID) -v v$(VERSION) -i $@ -o $@.new
mv $@.new $@
@@ -134,6 +139,7 @@ endef
# Devices
#################################################
+DEVICE_VARS += PRODUCTID
DEVICE_VARS += DEVICE_ID VERSION
DEVICE_VARS += BOARD_ID REGION
@@ -146,6 +152,19 @@ define Device/Default
IMAGE/trx := trx-with-loader
endef
+define Device/asus
+ IMAGES := trx
+ IMAGE/trx := trx-with-loader | asus-trx
+endef
+
+define AsusDevice
+ define Device/asus-$(1)
+ $$(Device/asus)
+ PRODUCTID := $(2)
+ endef
+ TARGET_DEVICES += asus-$(1)
+endef
+
define Device/linksys
IMAGES := bin
IMAGE/bin := trx-with-loader | linksys-bin
@@ -263,6 +282,7 @@ endif
#################################################
ifeq ($(SUBTARGET),mips74k)
+ $(eval $(call AsusDevice,rt-n66u,RT-N66U))
$(eval $(call LinksysDevice,wrt160n-v3,N150,3.0.3))
$(eval $(call LinksysDevice,wrt310n-v2,310N,2.0.1))
$(eval $(call LinksysDevice,wrt320n-v1,320N,1.0.5))