summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm47xx/patches-2.6.25/130-remove_scache.patch
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2008-06-17 12:57:04 +0000
committerGabor Juhos <juhosg@openwrt.org>2008-06-17 12:57:04 +0000
commit4af6ac74fb0dd4b8f75c82543f3b3a17fbd75fcb (patch)
tree40cb3a459399cd0fc128e0f0cfcb82cab6409ed0 /target/linux/brcm47xx/patches-2.6.25/130-remove_scache.patch
parent3415b8c04439a74b9311b2d5a4beb14a13341525 (diff)
downloadmaster-31e0f0ae-4af6ac74fb0dd4b8f75c82543f3b3a17fbd75fcb.tar.gz
master-31e0f0ae-4af6ac74fb0dd4b8f75c82543f3b3a17fbd75fcb.tar.bz2
master-31e0f0ae-4af6ac74fb0dd4b8f75c82543f3b3a17fbd75fcb.zip
upgrade to 2.6.25.7, and refresh patches
SVN-Revision: 11523
Diffstat (limited to 'target/linux/brcm47xx/patches-2.6.25/130-remove_scache.patch')
-rw-r--r--target/linux/brcm47xx/patches-2.6.25/130-remove_scache.patch36
1 files changed, 14 insertions, 22 deletions
diff --git a/target/linux/brcm47xx/patches-2.6.25/130-remove_scache.patch b/target/linux/brcm47xx/patches-2.6.25/130-remove_scache.patch
index 7d215a1a97..d36b4d8307 100644
--- a/target/linux/brcm47xx/patches-2.6.25/130-remove_scache.patch
+++ b/target/linux/brcm47xx/patches-2.6.25/130-remove_scache.patch
@@ -1,8 +1,6 @@
-Index: linux-2.6.25.4/arch/mips/Kconfig
-===================================================================
---- linux-2.6.25.4.orig/arch/mips/Kconfig
-+++ linux-2.6.25.4/arch/mips/Kconfig
-@@ -228,7 +228,6 @@ config MIPS_MALTA
+--- a/arch/mips/Kconfig
++++ b/arch/mips/Kconfig
+@@ -228,7 +228,6 @@
select I8259
select MIPS_BOARDS_GEN
select MIPS_BONITO64
@@ -10,7 +8,7 @@ Index: linux-2.6.25.4/arch/mips/Kconfig
select PCI_GT64XXX_PCI0
select MIPS_MSC
select SWAP_IO_SPACE
-@@ -1421,13 +1420,6 @@ config IP22_CPU_SCACHE
+@@ -1421,13 +1420,6 @@
bool
select BOARD_SCACHE
@@ -24,11 +22,9 @@ Index: linux-2.6.25.4/arch/mips/Kconfig
config R5000_CPU_SCACHE
bool
select BOARD_SCACHE
-Index: linux-2.6.25.4/arch/mips/kernel/cpu-probe.c
-===================================================================
---- linux-2.6.25.4.orig/arch/mips/kernel/cpu-probe.c
-+++ linux-2.6.25.4/arch/mips/kernel/cpu-probe.c
-@@ -704,6 +704,8 @@ static inline void cpu_probe_mips(struct
+--- a/arch/mips/kernel/cpu-probe.c
++++ b/arch/mips/kernel/cpu-probe.c
+@@ -704,6 +704,8 @@
break;
case PRID_IMP_25KF:
c->cputype = CPU_25KF;
@@ -37,11 +33,9 @@ Index: linux-2.6.25.4/arch/mips/kernel/cpu-probe.c
break;
case PRID_IMP_34K:
c->cputype = CPU_34K;
-Index: linux-2.6.25.4/arch/mips/mm/c-r4k.c
-===================================================================
---- linux-2.6.25.4.orig/arch/mips/mm/c-r4k.c
-+++ linux-2.6.25.4/arch/mips/mm/c-r4k.c
-@@ -1103,7 +1103,6 @@ static void __init loongson2_sc_init(voi
+--- a/arch/mips/mm/c-r4k.c
++++ b/arch/mips/mm/c-r4k.c
+@@ -1103,7 +1103,6 @@
extern int r5k_sc_init(void);
extern int rm7k_sc_init(void);
@@ -49,7 +43,7 @@ Index: linux-2.6.25.4/arch/mips/mm/c-r4k.c
static void __cpuinit setup_scache(void)
{
-@@ -1157,29 +1156,17 @@ static void __cpuinit setup_scache(void)
+@@ -1157,29 +1156,17 @@
#endif
default:
@@ -84,11 +78,9 @@ Index: linux-2.6.25.4/arch/mips/mm/c-r4k.c
/* compute a couple of other cache variables */
c->scache.waysize = scache_size / c->scache.ways;
-Index: linux-2.6.25.4/arch/mips/mm/Makefile
-===================================================================
---- linux-2.6.25.4.orig/arch/mips/mm/Makefile
-+++ linux-2.6.25.4/arch/mips/mm/Makefile
-@@ -32,6 +32,5 @@ obj-$(CONFIG_CPU_VR41XX) += c-r4k.o cex-
+--- a/arch/mips/mm/Makefile
++++ b/arch/mips/mm/Makefile
+@@ -32,6 +32,5 @@
obj-$(CONFIG_IP22_CPU_SCACHE) += sc-ip22.o
obj-$(CONFIG_R5000_CPU_SCACHE) += sc-r5k.o
obj-$(CONFIG_RM7000_CPU_SCACHE) += sc-rm7k.o