summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm47xx/modules.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-06-08 09:45:55 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-06-08 09:45:55 +0000
commitc48140efb8277104993d66f919e244d79604d389 (patch)
tree973325944f849977b570083ed78d3bc383923c71 /target/linux/brcm47xx/modules.mk
parent871dd8ec7e7a5bcc6fb103d4beded98e6ab252b6 (diff)
downloadmaster-31e0f0ae-c48140efb8277104993d66f919e244d79604d389.tar.gz
master-31e0f0ae-c48140efb8277104993d66f919e244d79604d389.tar.bz2
master-31e0f0ae-c48140efb8277104993d66f919e244d79604d389.zip
brcm47xx: fix kmod-usb-brcm47xx build on legacy and mips74k subtargets
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 41052
Diffstat (limited to 'target/linux/brcm47xx/modules.mk')
-rw-r--r--target/linux/brcm47xx/modules.mk8
1 files changed, 5 insertions, 3 deletions
diff --git a/target/linux/brcm47xx/modules.mk b/target/linux/brcm47xx/modules.mk
index 4dd5edb338..5738d6aa0d 100644
--- a/target/linux/brcm47xx/modules.mk
+++ b/target/linux/brcm47xx/modules.mk
@@ -13,9 +13,11 @@ define KernelPackage/usb-brcm47xx
CONFIG_USB_HCD_BCMA \
CONFIG_USB_HCD_SSB
FILES:= \
- $(LINUX_DIR)/drivers/usb/host/bcma-hcd.ko \
- $(LINUX_DIR)/drivers/usb/host/ssb-hcd.ko
- AUTOLOAD:=$(call AutoLoad,19,bcma-hcd ssb-hcd,1)
+ $(if $(CONFIG_USB_HCD_BCMA),$(LINUX_DIR)/drivers/usb/host/bcma-hcd.ko) \
+ $(if $(CONFIG_USB_HCD_SSB),$(LINUX_DIR)/drivers/usb/host/ssb-hcd.ko)
+ AUTOLOAD:=$(call AutoLoad,19, \
+ $(if $(CONFIG_USB_HCD_BCMA),bcma-hcd) \
+ $(if $(CONFIG_USB_HCD_SSB),ssb-hcd),1)
$(call AddDepends/usb)
endef