summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm47xx/modules.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-04-15 16:06:14 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-04-15 16:06:14 +0000
commit83e31eb7e74809d95742dab4f02a18f11bb153bc (patch)
tree6ad0bebaf793c53371d10393d100b7041a1ee535 /target/linux/brcm47xx/modules.mk
parentf1119373f2eead74abfca50510e83e0b1c41a49e (diff)
downloadmaster-31e0f0ae-83e31eb7e74809d95742dab4f02a18f11bb153bc.tar.gz
master-31e0f0ae-83e31eb7e74809d95742dab4f02a18f11bb153bc.tar.bz2
master-31e0f0ae-83e31eb7e74809d95742dab4f02a18f11bb153bc.zip
bcm53xx: add USB 2.0 support
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 45450
Diffstat (limited to 'target/linux/brcm47xx/modules.mk')
-rw-r--r--target/linux/brcm47xx/modules.mk19
1 files changed, 0 insertions, 19 deletions
diff --git a/target/linux/brcm47xx/modules.mk b/target/linux/brcm47xx/modules.mk
index 94bc662666..305643f330 100644
--- a/target/linux/brcm47xx/modules.mk
+++ b/target/linux/brcm47xx/modules.mk
@@ -5,25 +5,6 @@
# See /LICENSE for more information.
#
-define KernelPackage/usb-brcm47xx
- SUBMENU:=$(USB_MENU)
- TITLE:=Support for USB on bcm47xx
- DEPENDS:=@USB_SUPPORT @TARGET_brcm47xx
- KCONFIG:= \
- CONFIG_USB_HCD_BCMA \
- CONFIG_USB_HCD_SSB
- FILES:= \
- $(if $(CONFIG_USB_HCD_BCMA),$(LINUX_DIR)/drivers/usb/host/bcma-hcd.ko) \
- $(if $(CONFIG_USB_HCD_SSB),$(LINUX_DIR)/drivers/usb/host/ssb-hcd.ko)
- AUTOLOAD:=$(call AutoLoad,19, \
- $(if $(CONFIG_USB_HCD_BCMA),bcma-hcd) \
- $(if $(CONFIG_USB_HCD_SSB),ssb-hcd),1)
- $(call AddDepends/usb)
-endef
-
-$(eval $(call KernelPackage,usb-brcm47xx))
-
-
define KernelPackage/ocf-ubsec-ssb
TITLE:=BCM5365P IPSec Core driver
DEPENDS:=@TARGET_brcm47xx @!TARGET_brcm47xx_mips74k +kmod-crypto-ocf