summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm47xx/legacy
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-06-07 15:19:40 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-06-07 15:19:40 +0000
commitdec0d7f025c104f85fafe8c5f47dcb52df17b5b9 (patch)
tree0ff07a3453876845a934a495f57c9b8315aec9cb /target/linux/brcm47xx/legacy
parent8b4dd24444aede8b8b4fc6706b9d32459d1300fb (diff)
downloadmaster-31e0f0ae-dec0d7f025c104f85fafe8c5f47dcb52df17b5b9.tar.gz
master-31e0f0ae-dec0d7f025c104f85fafe8c5f47dcb52df17b5b9.tar.bz2
master-31e0f0ae-dec0d7f025c104f85fafe8c5f47dcb52df17b5b9.zip
brcm47xx: add a "legacy" subtarget that is usable for low-end 802.11g devices like WRT54G
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 41041
Diffstat (limited to 'target/linux/brcm47xx/legacy')
-rw-r--r--target/linux/brcm47xx/legacy/config-default9
-rw-r--r--target/linux/brcm47xx/legacy/profiles/100-Broadcom-b43.mk20
-rw-r--r--target/linux/brcm47xx/legacy/profiles/101-Broadcom-wl.mk20
-rw-r--r--target/linux/brcm47xx/legacy/profiles/WGT634U.mk17
-rw-r--r--target/linux/brcm47xx/legacy/profiles/WRTSL54GS.mk17
-rw-r--r--target/linux/brcm47xx/legacy/target.mk6
6 files changed, 89 insertions, 0 deletions
diff --git a/target/linux/brcm47xx/legacy/config-default b/target/linux/brcm47xx/legacy/config-default
new file mode 100644
index 0000000000..d0799caedc
--- /dev/null
+++ b/target/linux/brcm47xx/legacy/config-default
@@ -0,0 +1,9 @@
+CONFIG_B44=y
+CONFIG_B44_PCI=y
+CONFIG_B44_PCICORE_AUTOSELECT=y
+CONFIG_B44_PCI_AUTOSELECT=y
+# CONFIG_BCM47XX_BCMA is not set
+# CONFIG_BCMA is not set
+CONFIG_LEDS_GPIO_REGISTER=y
+# CONFIG_MTD_NAND is not set
+# CONFIG_SSB_DRIVER_GIGE is not set
diff --git a/target/linux/brcm47xx/legacy/profiles/100-Broadcom-b43.mk b/target/linux/brcm47xx/legacy/profiles/100-Broadcom-b43.mk
new file mode 100644
index 0000000000..50d777010b
--- /dev/null
+++ b/target/linux/brcm47xx/legacy/profiles/100-Broadcom-b43.mk
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2007-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-b43
+ NAME:=Broadcom SoC, all Ethernet, BCM43xx WiFi (b43, default)
+ PACKAGES:=kmod-b43 kmod-b43legacy
+endef
+
+define Profile/Broadcom-b43/Description
+ Package set compatible with hardware any Broadcom BCM47xx or BCM535x
+ SoC with Broadcom BCM43xx Wifi cards using the mac80211, b43 and
+ b43legacy drivers and b44, tg3 or bgmac Ethernet driver.
+endef
+
+$(eval $(call Profile,Broadcom-b43))
+
diff --git a/target/linux/brcm47xx/legacy/profiles/101-Broadcom-wl.mk b/target/linux/brcm47xx/legacy/profiles/101-Broadcom-wl.mk
new file mode 100644
index 0000000000..6a4c5b0394
--- /dev/null
+++ b/target/linux/brcm47xx/legacy/profiles/101-Broadcom-wl.mk
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2010-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-wl
+ NAME:=Broadcom SoC, all Ethernet, BCM43xx WiFi (wl, proprietary)
+ PACKAGES:=-wpad-mini kmod-brcm-wl-mini wlc nas
+endef
+
+define Profile/Broadcom-wl/Description
+ Package set compatible with hardware any Broadcom BCM47xx or BCM535x
+ SoC with Broadcom BCM43xx Wifi cards using the proprietary Broadcom
+ wireless "wl" driver and b44, tg3 or bgmac Ethernet driver.
+endef
+
+$(eval $(call Profile,Broadcom-wl))
+
diff --git a/target/linux/brcm47xx/legacy/profiles/WGT634U.mk b/target/linux/brcm47xx/legacy/profiles/WGT634U.mk
new file mode 100644
index 0000000000..ebe5e2345c
--- /dev/null
+++ b/target/linux/brcm47xx/legacy/profiles/WGT634U.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/WGT634U
+ NAME:=Netgear WGT634U
+ PACKAGES:=kmod-ath5k kmod-usb-core kmod-usb2 kmod-ocf-ubsec-ssb
+endef
+
+define Profile/WGT634U/Description
+ Package set compatible with the Netgear WGT634U. Contains USB support
+endef
+$(eval $(call Profile,WGT634U))
+
diff --git a/target/linux/brcm47xx/legacy/profiles/WRTSL54GS.mk b/target/linux/brcm47xx/legacy/profiles/WRTSL54GS.mk
new file mode 100644
index 0000000000..0e53c7d138
--- /dev/null
+++ b/target/linux/brcm47xx/legacy/profiles/WRTSL54GS.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/WRTSL54GS
+ NAME:=Linksys WRTSL54GS
+ PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-storage kmod-scsi-core kmod-fs-ext3 e2fsprogs kmod-b43
+endef
+
+define Profile/WRTSL54GS/Description
+ Package set compatible with the Linksys WRTSL54GS. Contains USB support
+endef
+$(eval $(call Profile,WRTSL54GS))
+
diff --git a/target/linux/brcm47xx/legacy/target.mk b/target/linux/brcm47xx/legacy/target.mk
new file mode 100644
index 0000000000..7cbf42c08e
--- /dev/null
+++ b/target/linux/brcm47xx/legacy/target.mk
@@ -0,0 +1,6 @@
+BOARDNAME:=Legacy (802.11g)
+
+define Target/Description
+ Build generic firmware for legacy 802.11g Broadcom BCM47xx
+ and BCM53xx MIPS devices.
+endef