summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm47xx/image
diff options
context:
space:
mode:
authorRafał Miłecki <zajec5@gmail.com>2015-03-31 12:17:08 +0000
committerRafał Miłecki <zajec5@gmail.com>2015-03-31 12:17:08 +0000
commit4faba3cc2ea0155590dbf2bf8efde02ad370c24e (patch)
tree163ddd8c5f94191bf7f620cd9a9f885a0c38eeb0 /target/linux/brcm47xx/image
parentedf9b7a2a5369d2e92ed0c1877c6b5abd61ce83c (diff)
downloadmaster-31e0f0ae-4faba3cc2ea0155590dbf2bf8efde02ad370c24e.tar.gz
master-31e0f0ae-4faba3cc2ea0155590dbf2bf8efde02ad370c24e.tar.bz2
master-31e0f0ae-4faba3cc2ea0155590dbf2bf8efde02ad370c24e.zip
brcm47xx: image: convert generic subtarget to the new images system
Signed-off-by: Rafał Miłecki <zajec5@gmail.com> SVN-Revision: 45183
Diffstat (limited to 'target/linux/brcm47xx/image')
-rw-r--r--target/linux/brcm47xx/image/Makefile29
1 files changed, 11 insertions, 18 deletions
diff --git a/target/linux/brcm47xx/image/Makefile b/target/linux/brcm47xx/image/Makefile
index 2d1b230f27..273510253b 100644
--- a/target/linux/brcm47xx/image/Makefile
+++ b/target/linux/brcm47xx/image/Makefile
@@ -178,24 +178,17 @@ endef
# Subtarget generic
#################################################
-# $(1): filesystem type.
-define Image/Build/generic/jffs2-64k
- # BCM4705 with tg3
- $(call Image/Build/CyberTAN,$(1),wrt300n_v11,EWC2,1.51.2,$(patsubst jffs2-%,jffs2,$(1)))
- $(call Image/Build/CyberTAN,$(1),wrt310n_v1,310N,1.0.10,$(patsubst jffs2-%,jffs2,$(1)))
- $(call Image/Build/CyberTAN,$(1),wrt350n_v1,EWCG,1.04.1,$(patsubst jffs2-%,jffs2,$(1)))
- $(call Image/Build/CyberTAN,$(1),wrt610n_v1,610N,1.0.1,$(patsubst jffs2-%,jffs2,$(1)))
-
- # BCMA SoC with SSB WiFi
- $(call Image/Build/CyberTAN,$(1),wrt610n_v2,610N,2.0.0,$(patsubst jffs2-%,jffs2,$(1)))
- $(call Image/Build/CyberTAN,$(1),e3000_v1,61XN,1.0.3,$(patsubst jffs2-%,jffs2,$(1)))
-endef
-
-# $(1): filesystem type.
-define Image/Build/generic/squashfs
- $(call Image/Build/generic/jffs2-64k,$(1))
- $(call Image/Build/generic/jffs2-128k,$(1))
-endef
+ifeq ($(SUBTARGET),generic)
+ # BCM4705 with tg3
+ $(eval $(call LinksysDevice,wrt300n-v1.1,EWC2,1.51.2))
+ $(eval $(call LinksysDevice,wrt310n-v1,310N,1.0.10))
+ $(eval $(call LinksysDevice,wrt350n-v1,EWCG,1.04.1))
+ $(eval $(call LinksysDevice,wrt610n-v1,610N,1.0.1))
+
+ # BCMA SoC with SSB WiFi
+ $(eval $(call LinksysDevice,wrt610n-v2,610N,2.0.0))
+ $(eval $(call LinksysDevice,e3000-v1,61XN,1.0.3))
+endif
#################################################
# Subtarget legacy