summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm47xx/image
diff options
context:
space:
mode:
authorRafał Miłecki <zajec5@gmail.com>2015-03-29 19:53:11 +0000
committerRafał Miłecki <zajec5@gmail.com>2015-03-29 19:53:11 +0000
commit1751676c8b0c263b7de819a0ab50b60e13c1a77e (patch)
tree692ff0375bcadaeb6892f56cb9882f147badbac4 /target/linux/brcm47xx/image
parent8e4b74b9fe5d0cc740806ed200903f4bfd7d2ec5 (diff)
downloadmaster-31e0f0ae-1751676c8b0c263b7de819a0ab50b60e13c1a77e.tar.gz
master-31e0f0ae-1751676c8b0c263b7de819a0ab50b60e13c1a77e.tar.bz2
master-31e0f0ae-1751676c8b0c263b7de819a0ab50b60e13c1a77e.zip
brcm47xx: convert Netgear WNDR3700 V3 to the new image building system
Signed-off-by: Rafał Miłecki <zajec5@gmail.com> SVN-Revision: 45144
Diffstat (limited to 'target/linux/brcm47xx/image')
-rw-r--r--target/linux/brcm47xx/image/Makefile28
1 files changed, 25 insertions, 3 deletions
diff --git a/target/linux/brcm47xx/image/Makefile b/target/linux/brcm47xx/image/Makefile
index 386f42c333..5410ed3560 100644
--- a/target/linux/brcm47xx/image/Makefile
+++ b/target/linux/brcm47xx/image/Makefile
@@ -121,18 +121,28 @@ define Build/linksys-bin
mv $@.new $@
endef
+define Build/netgear-chk
+ $(STAGING_DIR_HOST)/bin/mkchkimg \
+ -o $@.new \
+ -k $@ \
+ -b $(BOARD_ID) \
+ -r $(REGION)
+ mv $@.new $@
+endef
+
#################################################
# Devices
#################################################
DEVICE_VARS += DEVICE_ID VERSION
+DEVICE_VARS += BOARD_ID REGION
define Device/Default
IMAGE_NAME = $$(IMAGE_PREFIX)-$$(1).$$(2)
KERNEL_IMAGE = vmlinux.lzma
FILESYSTEMS := $(FS_64K)
IMAGES := trx
- IMAGE/bin := trx-with-loader
+ IMAGE/trx := trx-with-loader
endef
define Device/linksys
@@ -140,6 +150,11 @@ define Device/linksys
IMAGE/bin := trx-with-loader | linksys-bin
endef
+define Device/netgear
+ IMAGES := chk
+ IMAGE/chk := trx-with-loader | netgear-chk
+endef
+
#################################################
# Subtarget generic
#################################################
@@ -222,7 +237,6 @@ define Image/Build/mips74k/devices-with-64k-blocks
$(call Image/Build/Chk,$(1),wndr3400_v1,U12H155T00_NETGEAR,2,$(patsubst jffs2-%,jffs2,$(1)))
$(call Image/Build/Chk,$(1),wndr3400_v2,U12H187T00_NETGEAR,2,$(patsubst jffs2-%,jffs2,$(1)))
$(call Image/Build/Chk,$(1),wndr3400_v3,U12H208T00_NETGEAR,1,$(patsubst jffs2-%,jffs2,$(1)))
- $(call Image/Build/Chk,$(1),wndr3700_v3,U12H194T00_NETGEAR,2,$(patsubst jffs2-%,jffs2,$(1)))
$(call Image/Build/Chk,$(1),wndr4000,U12H181T00_NETGEAR,2,$(patsubst jffs2-%,jffs2,$(1)))
$(call Image/Build/Chk,$(1),wnr1000_v3,U12H139T00_NETGEAR,2,$(patsubst jffs2-%,jffs2,$(1)))
$(call Image/Build/Chk,$(1),wnr2000v2,U12H114T00_NETGEAR,2,$(patsubst jffs2-%,jffs2,$(1)))
@@ -267,8 +281,16 @@ define Device/linksys-e1200-v2
VERSION := 1.0.4
endef
+define Device/netgear-wndr3700-v3
+ $(Device/netgear)
+ BOARD_ID := U12H194T00_NETGEAR
+ REGION := 2
+endef
+
ifeq ($(SUBTARGET),mips74k)
- TARGET_DEVICES += linksys-e1200-v2
+ TARGET_DEVICES += \
+ linksys-e1200-v2 \
+ netgear-wndr3700-v3
endif
#################################################