summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm47xx/image
diff options
context:
space:
mode:
authorRafał Miłecki <zajec5@gmail.com>2015-03-31 12:44:31 +0000
committerRafał Miłecki <zajec5@gmail.com>2015-03-31 12:44:31 +0000
commit090a5105765e01ca016221233ed8fb2c84b259b7 (patch)
treeb095d997747f7666d82f94aedecb81ee9e0a7232 /target/linux/brcm47xx/image
parent4faba3cc2ea0155590dbf2bf8efde02ad370c24e (diff)
downloadmaster-31e0f0ae-090a5105765e01ca016221233ed8fb2c84b259b7.tar.gz
master-31e0f0ae-090a5105765e01ca016221233ed8fb2c84b259b7.tar.bz2
master-31e0f0ae-090a5105765e01ca016221233ed8fb2c84b259b7.zip
brcm47xx: image: convert legacy Linksys & Netgear devices
Signed-off-by: Rafał Miłecki <zajec5@gmail.com> SVN-Revision: 45184
Diffstat (limited to 'target/linux/brcm47xx/image')
-rw-r--r--target/linux/brcm47xx/image/Makefile43
1 files changed, 31 insertions, 12 deletions
diff --git a/target/linux/brcm47xx/image/Makefile b/target/linux/brcm47xx/image/Makefile
index 273510253b..09405c910c 100644
--- a/target/linux/brcm47xx/image/Makefile
+++ b/target/linux/brcm47xx/image/Makefile
@@ -196,24 +196,12 @@ endif
# $(1): filesystem type.
define Image/Build/legacy/devices-with-128k-blocks
- $(call Image/Build/CyberTAN,$(1),wrt54gs,W54S,4.80.1,$(patsubst jffs2-%,jffs2,$(1)))
- $(call Image/Build/CyberTAN,$(1),wrtsl54gs,W54U,2.08.1,$(patsubst jffs2-%,jffs2,$(1)))
$(call Image/Build/trxV2,$(1),wrt54g3gv2-vf,3G2V,3.00.24,$(patsubst jffs2-%,jffs2,$(1)),6)
$(call Image/Build/wgt634u,$(1),$(patsubst jffs2-%,jffs2,$(1)))
endef
# $(1): filesystem type.
define Image/Build/legacy/devices-with-64k-blocks
- $(call Image/Build/Chk,$(1),wgr614_v8,U12H072T00_NETGEAR,2,$(patsubst jffs2-%,jffs2,$(1)))
- $(call Image/Build/Chk,$(1),wndr3300_v1,U12H093T00_NETGEAR,2,$(patsubst jffs2-%,jffs2,$(1)))
- $(call Image/Build/Chk,$(1),wnr834b_v2,U12H081T00_NETGEAR,2,$(patsubst jffs2-%,jffs2,$(1)))
- $(call Image/Build/CyberTAN,$(1),wrt54g3g,W54F,2.20.1,$(patsubst jffs2-%,jffs2,$(1)))
- $(call Image/Build/CyberTAN,$(1),wrt54g3g-em,W3GN,2.20.1,$(patsubst jffs2-%,jffs2,$(1)))
- $(call Image/Build/CyberTAN,$(1),wrt54g,W54G,4.71.1,$(patsubst jffs2-%,jffs2,$(1)))
- $(call Image/Build/CyberTAN,$(1),wrt54gs_v4,W54s,1.09.1,$(patsubst jffs2-%,jffs2,$(1)))
- $(call Image/Build/CyberTAN,$(1),wrt150n,N150,1.51.3,$(patsubst jffs2-%,jffs2,$(1)))
- $(call Image/Build/CyberTAN,$(1),wrt160n_v1,N150,1.50.1,$(patsubst jffs2-%,jffs2,$(1)))
- $(call Image/Build/CyberTAN,$(1),wrt300n_v1,EWCB,1.03.6,$(patsubst jffs2-%,jffs2,$(1)))
$(call Image/Build/dwl3150,$(1),$(patsubst jffs2-%,jffs2,$(1)))
$(call Image/Build/Edi,$(1),ps1208mfg,$(patsubst jffs2-%,jffs2,$(1)))
$(call Image/Build/Huawei,$(1),e970,$(1))
@@ -239,6 +227,37 @@ define Image/Build/legacy/squashfs
$(call Image/Build/legacy/devices-with-128k-blocks,$(1))
endef
+define Device/linksys-wrt54gs
+ $(Device/linksys)
+ FILESYSTEMS := $(FS_128K)
+ DEVICE_ID := W54S
+ VERSION := 4.80.1
+endef
+
+define Device/linksys-wrtsl54gs
+ $(Device/linksys)
+ FILESYSTEMS := $(FS_128K)
+ DEVICE_ID := W54U
+ VERSION := 2.08.1
+endef
+
+ifeq ($(SUBTARGET),legacy)
+ TARGET_DEVICES += \
+ linksys-wrt54gs \
+ linksys-wrtsl54gs
+
+ $(eval $(call LinksysDevice,wrt54g3g,W54F,2.20.1))
+ $(eval $(call LinksysDevice,wrt54g3g-em,W3GN,2.20.1))
+ $(eval $(call LinksysDevice,wrt54g,W54G,4.71.1))
+ $(eval $(call LinksysDevice,wrt54gs_v4,W54s,1.09.1))
+ $(eval $(call LinksysDevice,wrt150n,N150,1.51.3))
+ $(eval $(call LinksysDevice,wrt160n_v1,N150,1.50.1))
+ $(eval $(call LinksysDevice,wrt300n_v1,EWCB,1.03.6))
+ $(eval $(call NetgearDevice,wgr614_v8,U12H072T00_NETGEAR,2))
+ $(eval $(call NetgearDevice,wndr3300_v1,U12H093T00_NETGEAR,2))
+ $(eval $(call NetgearDevice,wnr834b_v2,U12H081T00_NETGEAR,2))
+endif
+
#################################################
# Subtarget mips74k
#################################################