summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm47xx/generic
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2014-06-05 21:23:58 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2014-06-05 21:23:58 +0000
commitb5d42bc1118d50e527eeb5b8e43763470a24e4db (patch)
tree03b3b5f83a5579b9b771933c97644612568dda0e /target/linux/brcm47xx/generic
parent53fa9374c246f105df82fe42586a7c5dd41f33a7 (diff)
downloadmaster-31e0f0ae-b5d42bc1118d50e527eeb5b8e43763470a24e4db.tar.gz
master-31e0f0ae-b5d42bc1118d50e527eeb5b8e43763470a24e4db.tar.bz2
master-31e0f0ae-b5d42bc1118d50e527eeb5b8e43763470a24e4db.zip
brcm47xx: move current target to "generic" subtarget
This allows creating more subtargets and optimize builds per family. Signed-off-by: Rafał Miłecki <zajec5@gmail.com> Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de> SVN-Revision: 41024
Diffstat (limited to 'target/linux/brcm47xx/generic')
-rw-r--r--target/linux/brcm47xx/generic/profiles/100-Broadcom-b43.mk20
-rw-r--r--target/linux/brcm47xx/generic/profiles/101-Broadcom-wl.mk20
-rw-r--r--target/linux/brcm47xx/generic/profiles/104-Broadcom-ath5k.mk19
-rw-r--r--target/linux/brcm47xx/generic/profiles/105-Broadcom-none.mk18
-rw-r--r--target/linux/brcm47xx/generic/profiles/200-Broadcom-b44-b43.mk20
-rw-r--r--target/linux/brcm47xx/generic/profiles/201-Broadcom-b44-wl.mk20
-rw-r--r--target/linux/brcm47xx/generic/profiles/204-Broadcom-b44-ath5k.mk19
-rw-r--r--target/linux/brcm47xx/generic/profiles/205-Broadcom-b44-none.mk18
-rw-r--r--target/linux/brcm47xx/generic/profiles/210-Broadcom-tg3-b43.mk20
-rw-r--r--target/linux/brcm47xx/generic/profiles/211-Broadcom-tg3-wl.mk20
-rw-r--r--target/linux/brcm47xx/generic/profiles/215-Broadcom-tg3-none.mk18
-rw-r--r--target/linux/brcm47xx/generic/profiles/220-Broadcom-bgmac-b43.mk20
-rw-r--r--target/linux/brcm47xx/generic/profiles/221-Broadcom-bgmac-wl.mk20
-rw-r--r--target/linux/brcm47xx/generic/profiles/225-Broadcom-bgmac-none.mk18
-rw-r--r--target/linux/brcm47xx/generic/profiles/226-Broadcom-bgmac-brcsmac.mk20
-rw-r--r--target/linux/brcm47xx/generic/profiles/PS-1208MFG.mk18
-rw-r--r--target/linux/brcm47xx/generic/profiles/WGT634U.mk17
-rw-r--r--target/linux/brcm47xx/generic/profiles/WL500GPv1-ATH.mk16
-rw-r--r--target/linux/brcm47xx/generic/profiles/WRT350Nv1.mk16
-rw-r--r--target/linux/brcm47xx/generic/profiles/WRTSL54GS.mk17
-rw-r--r--target/linux/brcm47xx/generic/target.mk6
21 files changed, 380 insertions, 0 deletions
diff --git a/target/linux/brcm47xx/generic/profiles/100-Broadcom-b43.mk b/target/linux/brcm47xx/generic/profiles/100-Broadcom-b43.mk
new file mode 100644
index 0000000000..4c420fb299
--- /dev/null
+++ b/target/linux/brcm47xx/generic/profiles/100-Broadcom-b43.mk
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2007-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-b43
+ NAME:=Broadcom SoC, all Ethernet, BCM43xx WiFi (b43, default)
+ PACKAGES:=kmod-b44 kmod-tg3 kmod-bgmac kmod-b43 kmod-b43legacy
+endef
+
+define Profile/Broadcom-b43/Description
+ Package set compatible with hardware any Broadcom BCM47xx or BCM535x
+ SoC with Broadcom BCM43xx Wifi cards using the mac80211, b43 and
+ b43legacy drivers and b44, tg3 or bgmac Ethernet driver.
+endef
+
+$(eval $(call Profile,Broadcom-b43))
+
diff --git a/target/linux/brcm47xx/generic/profiles/101-Broadcom-wl.mk b/target/linux/brcm47xx/generic/profiles/101-Broadcom-wl.mk
new file mode 100644
index 0000000000..21265daff8
--- /dev/null
+++ b/target/linux/brcm47xx/generic/profiles/101-Broadcom-wl.mk
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2010-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-wl
+ NAME:=Broadcom SoC, all Ethernet, BCM43xx WiFi (wl, proprietary)
+ PACKAGES:=-wpad-mini kmod-b44 kmod-tg3 kmod-bgmac kmod-brcm-wl wlc nas
+endef
+
+define Profile/Broadcom-wl/Description
+ Package set compatible with hardware any Broadcom BCM47xx or BCM535x
+ SoC with Broadcom BCM43xx Wifi cards using the proprietary Broadcom
+ wireless "wl" driver and b44, tg3 or bgmac Ethernet driver.
+endef
+
+$(eval $(call Profile,Broadcom-wl))
+
diff --git a/target/linux/brcm47xx/generic/profiles/104-Broadcom-ath5k.mk b/target/linux/brcm47xx/generic/profiles/104-Broadcom-ath5k.mk
new file mode 100644
index 0000000000..ca5295f7e3
--- /dev/null
+++ b/target/linux/brcm47xx/generic/profiles/104-Broadcom-ath5k.mk
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2006-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-ath5k
+ NAME:=Broadcom SoC, all Ethernet, Atheros WiFi (ath5k)
+ PACKAGES:=kmod-b44 kmod-tg3 kmod-bgmac kmod-ath5k
+endef
+
+define Profile/Broadcom-ath5k/Description
+ Package set compatible with hardware any Broadcom BCM47xx or BCM535x
+ SoC with Atheros Wifi cards using the mac80211 and ath5k drivers and
+ b44, tg3 or bgmac Ethernet driver.
+endef
+$(eval $(call Profile,Broadcom-ath5k))
+
diff --git a/target/linux/brcm47xx/generic/profiles/105-Broadcom-none.mk b/target/linux/brcm47xx/generic/profiles/105-Broadcom-none.mk
new file mode 100644
index 0000000000..301d02aebb
--- /dev/null
+++ b/target/linux/brcm47xx/generic/profiles/105-Broadcom-none.mk
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2006-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-none
+ NAME:=Broadcom SoC, all Ethernet, No WiFi
+ PACKAGES:=-wpad-mini kmod-b44 kmod-tg3 kmod-bgmac
+endef
+
+define Profile/Broadcom-none/Description
+ Package set compatible with hardware any Broadcom BCM47xx or BCM535x
+ SoC without any Wifi cards and b44, tg3 or bgmac Ethernet driver.
+endef
+$(eval $(call Profile,Broadcom-none))
+
diff --git a/target/linux/brcm47xx/generic/profiles/200-Broadcom-b44-b43.mk b/target/linux/brcm47xx/generic/profiles/200-Broadcom-b44-b43.mk
new file mode 100644
index 0000000000..662a7c8e94
--- /dev/null
+++ b/target/linux/brcm47xx/generic/profiles/200-Broadcom-b44-b43.mk
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2007-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-b44-b43
+ NAME:=Broadcom SoC, b44 Ethernet, BCM43xx WiFi (b43, default)
+ PACKAGES:=kmod-b44 kmod-b43 kmod-b43legacy
+endef
+
+define Profile/Broadcom-b44-b43/Description
+ Package set compatible with hardware older Broadcom BCM47xx or BCM535x
+ SoC with Broadcom BCM43xx Wifi cards using the mac80211, b43 and
+ b43legacy drivers and b44 Ethernet driver.
+endef
+
+$(eval $(call Profile,Broadcom-b44-b43))
+
diff --git a/target/linux/brcm47xx/generic/profiles/201-Broadcom-b44-wl.mk b/target/linux/brcm47xx/generic/profiles/201-Broadcom-b44-wl.mk
new file mode 100644
index 0000000000..f974c00e45
--- /dev/null
+++ b/target/linux/brcm47xx/generic/profiles/201-Broadcom-b44-wl.mk
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2010-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-b44-wl
+ NAME:=Broadcom SoC, b44 Ethernet, BCM43xx WiFi (wl, proprietary)
+ PACKAGES:=-wpad-mini kmod-b44 kmod-brcm-wl wlc nas
+endef
+
+define Profile/Broadcom-b44-wl/Description
+ Package set compatible with hardware older Broadcom BCM47xx or BCM535x
+ SoC with Broadcom BCM43xx Wifi cards using the proprietary Broadcom
+ wireless "wl" driver and b44 Ethernet driver.
+endef
+
+$(eval $(call Profile,Broadcom-b44-wl))
+
diff --git a/target/linux/brcm47xx/generic/profiles/204-Broadcom-b44-ath5k.mk b/target/linux/brcm47xx/generic/profiles/204-Broadcom-b44-ath5k.mk
new file mode 100644
index 0000000000..e9dda49d66
--- /dev/null
+++ b/target/linux/brcm47xx/generic/profiles/204-Broadcom-b44-ath5k.mk
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2006-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-b44-ath5k
+ NAME:=Broadcom SoC, b44 Ethernet, Atheros WiFi (ath5k)
+ PACKAGES:=kmod-b44 kmod-ath5k
+endef
+
+define Profile/Broadcom-b44-ath5k/Description
+ Package set compatible with hardware older Broadcom BCM47xx or BCM535x
+ SoC with Atheros Wifi cards using the mac80211 and ath5k drivers and
+ b44 Ethernet driver.
+endef
+$(eval $(call Profile,Broadcom-b44-ath5k))
+
diff --git a/target/linux/brcm47xx/generic/profiles/205-Broadcom-b44-none.mk b/target/linux/brcm47xx/generic/profiles/205-Broadcom-b44-none.mk
new file mode 100644
index 0000000000..a936bba203
--- /dev/null
+++ b/target/linux/brcm47xx/generic/profiles/205-Broadcom-b44-none.mk
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2006-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-b44-none
+ NAME:=Broadcom SoC, b44 Ethernet, No WiFi
+ PACKAGES:=-wpad-mini kmod-b44
+endef
+
+define Profile/Broadcom-b44-none/Description
+ Package set compatible with hardware older Broadcom BCM47xx or BCM535x
+ SoC without any Wifi cards and b44 Ethernet driver.
+endef
+$(eval $(call Profile,Broadcom-b44-none))
+
diff --git a/target/linux/brcm47xx/generic/profiles/210-Broadcom-tg3-b43.mk b/target/linux/brcm47xx/generic/profiles/210-Broadcom-tg3-b43.mk
new file mode 100644
index 0000000000..a0bece914d
--- /dev/null
+++ b/target/linux/brcm47xx/generic/profiles/210-Broadcom-tg3-b43.mk
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2007-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-tg3-b43
+ NAME:=Broadcom SoC, tg3 Ethernet, BCM43xx WiFi (b43)
+ PACKAGES:=kmod-b43 kmod-tg3
+endef
+
+define Profile/Broadcom-tg3-b43/Description
+ Package set compatible with hardware Broadcom BCM4705/BCM4785
+ SoCs with Broadcom BCM43xx Wifi cards using the mac80211 and b43
+ driver and tg3 Ethernet driver.
+endef
+
+$(eval $(call Profile,Broadcom-tg3-b43))
+
diff --git a/target/linux/brcm47xx/generic/profiles/211-Broadcom-tg3-wl.mk b/target/linux/brcm47xx/generic/profiles/211-Broadcom-tg3-wl.mk
new file mode 100644
index 0000000000..24ac234fff
--- /dev/null
+++ b/target/linux/brcm47xx/generic/profiles/211-Broadcom-tg3-wl.mk
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2010-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-tg3-wl
+ NAME:=Broadcom SoC, tg3 Ethernet, BCM43xx WiFi (wl, proprietary)
+ PACKAGES:=-wpad-mini kmod-brcm-wl wlc nas kmod-tg3
+endef
+
+define Profile/Broadcom-tg3-wl/Description
+ Package set compatible with hardware Broadcom BCM4705/BCM4785
+ SoC with Broadcom BCM43xx Wifi cards using the proprietary Broadcom
+ wireless "wl" driver and tg3 Ethernet driver.
+endef
+
+$(eval $(call Profile,Broadcom-tg3-wl))
+
diff --git a/target/linux/brcm47xx/generic/profiles/215-Broadcom-tg3-none.mk b/target/linux/brcm47xx/generic/profiles/215-Broadcom-tg3-none.mk
new file mode 100644
index 0000000000..2d13ca80c4
--- /dev/null
+++ b/target/linux/brcm47xx/generic/profiles/215-Broadcom-tg3-none.mk
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2006-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-tg3-none
+ NAME:=Broadcom SoC, tg3 Ethernet, no WiFi
+ PACKAGES:=-wpad-mini kmod-tg3
+endef
+
+define Profile/Broadcom-tg3-none/Description
+ Package set compatible with hardware Broadcom BCM4705/BCM4785
+ SoC without any Wifi cards and tg3 Ethernet driver.
+endef
+$(eval $(call Profile,Broadcom-tg3-none))
+
diff --git a/target/linux/brcm47xx/generic/profiles/220-Broadcom-bgmac-b43.mk b/target/linux/brcm47xx/generic/profiles/220-Broadcom-bgmac-b43.mk
new file mode 100644
index 0000000000..6ef0691a4c
--- /dev/null
+++ b/target/linux/brcm47xx/generic/profiles/220-Broadcom-bgmac-b43.mk
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2007-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-bgmac-b43
+ NAME:=Broadcom SoC, bgmac Ethernet, BCM43xx WiFi (b43)
+ PACKAGES:=kmod-bgmac kmod-b43
+endef
+
+define Profile/Broadcom-bgmac-b43/Description
+ Package set compatible with hardware newer Broadcom BCM47xx or BCM535x
+ SoC with Broadcom BCM43xx Wifi cards using the mac80211 and b43
+ drivers and bgmac Ethernet driver.
+endef
+
+$(eval $(call Profile,Broadcom-bgmac-b43))
+
diff --git a/target/linux/brcm47xx/generic/profiles/221-Broadcom-bgmac-wl.mk b/target/linux/brcm47xx/generic/profiles/221-Broadcom-bgmac-wl.mk
new file mode 100644
index 0000000000..f671cd9599
--- /dev/null
+++ b/target/linux/brcm47xx/generic/profiles/221-Broadcom-bgmac-wl.mk
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2010-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-bgmac-wl
+ NAME:=Broadcom SoC, bgmac Ethernet, BCM43xx WiFi (wl, proprietary)
+ PACKAGES:=-wpad-mini kmod-bgmac kmod-brcm-wl wlc nas
+endef
+
+define Profile/Broadcom-bgmac-wl/Description
+ Package set compatible with hardware newer Broadcom BCM47xx or BCM535x
+ SoC with Broadcom BCM43xx Wifi cards using the proprietary Broadcom
+ wireless "wl" driver and bgmac Ethernet driver.
+endef
+
+$(eval $(call Profile,Broadcom-bgmac-wl))
+
diff --git a/target/linux/brcm47xx/generic/profiles/225-Broadcom-bgmac-none.mk b/target/linux/brcm47xx/generic/profiles/225-Broadcom-bgmac-none.mk
new file mode 100644
index 0000000000..0512119304
--- /dev/null
+++ b/target/linux/brcm47xx/generic/profiles/225-Broadcom-bgmac-none.mk
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2006-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-bgmac-none
+ NAME:=Broadcom SoC, bgmac Ethernet, No WiFi
+ PACKAGES:=-wpad-mini kmod-bgmac
+endef
+
+define Profile/Broadcom-bgmac-none/Description
+ Package set compatible with hardware newer Broadcom BCM47xx or BCM535x
+ SoC without any Wifi cards and bgmac Ethernet driver.
+endef
+$(eval $(call Profile,Broadcom-bgmac-none))
+
diff --git a/target/linux/brcm47xx/generic/profiles/226-Broadcom-bgmac-brcsmac.mk b/target/linux/brcm47xx/generic/profiles/226-Broadcom-bgmac-brcsmac.mk
new file mode 100644
index 0000000000..d9dc9e7a4a
--- /dev/null
+++ b/target/linux/brcm47xx/generic/profiles/226-Broadcom-bgmac-brcsmac.mk
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2007-2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-bgmac-brcmsmac
+ NAME:=Broadcom SoC, bgmac Ethernet, BCM43xx WiFi (brcmsmac)
+ PACKAGES:=kmod-bgmac kmod-brcmsmac
+endef
+
+define Profile/Broadcom-bgmac-brcmsmac/Description
+ Package set compatable with newer gigabit + N based bcm47xx SoCs with
+ Broadcom BCM43xx Wifi cards using the mac80211 brcmsmac driver and
+ bgmac Ethernet driver.
+endef
+
+$(eval $(call Profile,Broadcom-bgmac-brcmsmac))
+
diff --git a/target/linux/brcm47xx/generic/profiles/PS-1208MFG.mk b/target/linux/brcm47xx/generic/profiles/PS-1208MFG.mk
new file mode 100644
index 0000000000..33a2565ff3
--- /dev/null
+++ b/target/linux/brcm47xx/generic/profiles/PS-1208MFG.mk
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2007-2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Ps1208mfg
+ NAME:=Edimax PS-1208MFG
+ PACKAGES:=-firewall -dropbear -dnsmasq -mtd -ppp -wpad-mini kmod-b44 block-mount kmod-usb-storage kmod-usb2 kmod-usb-ohci -iptables -swconfig kmod-fs-ext4 block-extroot
+endef
+
+define Profile/Ps1208mfg/Description
+ Package set optimize for edimax PS-1208MFG printserver
+endef
+
+$(eval $(call Profile,Ps1208mfg))
+
diff --git a/target/linux/brcm47xx/generic/profiles/WGT634U.mk b/target/linux/brcm47xx/generic/profiles/WGT634U.mk
new file mode 100644
index 0000000000..16c8d9de72
--- /dev/null
+++ b/target/linux/brcm47xx/generic/profiles/WGT634U.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/WGT634U
+ NAME:=Netgear WGT634U
+ PACKAGES:=kmod-b44 kmod-ath5k kmod-usb-core kmod-usb2 kmod-ocf-ubsec-ssb
+endef
+
+define Profile/WGT634U/Description
+ Package set compatible with the Netgear WGT634U. Contains USB support
+endef
+$(eval $(call Profile,WGT634U))
+
diff --git a/target/linux/brcm47xx/generic/profiles/WL500GPv1-ATH.mk b/target/linux/brcm47xx/generic/profiles/WL500GPv1-ATH.mk
new file mode 100644
index 0000000000..3cdd8a0b33
--- /dev/null
+++ b/target/linux/brcm47xx/generic/profiles/WL500GPv1-ATH.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/WL500GPv1
+ NAME:=ASUS WL-500g Premium v1 (Atheros WiFi using ath5k)
+ PACKAGES:=kmod-b44 kmod-ath5k kmod-usb-core kmod-usb-uhci kmod-usb2
+endef
+
+define Profile/WL500GPv1/Description
+ Package set optimized for the WL-500g Premium v1 with USB and Atheros WiFi card support
+endef
+$(eval $(call Profile,WL500GPv1))
diff --git a/target/linux/brcm47xx/generic/profiles/WRT350Nv1.mk b/target/linux/brcm47xx/generic/profiles/WRT350Nv1.mk
new file mode 100644
index 0000000000..c861615aad
--- /dev/null
+++ b/target/linux/brcm47xx/generic/profiles/WRT350Nv1.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/WRT350Nv1
+ NAME:=Linksys WRT350Nv1
+ PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-tg3 kmod-ocf-ubsec-ssb
+endef
+
+define Profile/WRT350Nv1/Description
+ Package set compatible with the Linksys WRT350Nv1. Contains USB support
+endef
+$(eval $(call Profile,WRT350Nv1))
diff --git a/target/linux/brcm47xx/generic/profiles/WRTSL54GS.mk b/target/linux/brcm47xx/generic/profiles/WRTSL54GS.mk
new file mode 100644
index 0000000000..68d9a17fe8
--- /dev/null
+++ b/target/linux/brcm47xx/generic/profiles/WRTSL54GS.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/WRTSL54GS
+ NAME:=Linksys WRTSL54GS
+ PACKAGES:=kmod-b44 kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-storage kmod-scsi-core kmod-fs-ext3 e2fsprogs kmod-b43
+endef
+
+define Profile/WRTSL54GS/Description
+ Package set compatible with the Linksys WRTSL54GS. Contains USB support
+endef
+$(eval $(call Profile,WRTSL54GS))
+
diff --git a/target/linux/brcm47xx/generic/target.mk b/target/linux/brcm47xx/generic/target.mk
new file mode 100644
index 0000000000..0bcc5f031d
--- /dev/null
+++ b/target/linux/brcm47xx/generic/target.mk
@@ -0,0 +1,6 @@
+BOARDNAME:=Generic
+
+define Target/Description
+ Build generic firmware for all Broadcom BCM47xx and BCM53xx MIPS
+ devices. It runs on both architectures BMIPS3300 and MIPS 74K.
+endef