summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm47xx-2.6/patches-2.6.22/110-flash_map.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-06-21 23:41:09 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-06-21 23:41:09 +0000
commit20a359e19561ba37908955d4598fc32a409706cf (patch)
treea7f632d74fb7a0327b970020d7358729e7a0b45c /target/linux/brcm47xx-2.6/patches-2.6.22/110-flash_map.patch
parent77e68d6aa06e3d741d02c227db7c4a6306fd0204 (diff)
downloadmaster-31e0f0ae-20a359e19561ba37908955d4598fc32a409706cf.tar.gz
master-31e0f0ae-20a359e19561ba37908955d4598fc32a409706cf.tar.bz2
master-31e0f0ae-20a359e19561ba37908955d4598fc32a409706cf.zip
set the kernel version of brcm47xx-2.6 in the target makefile, keep patch compatibility with 2.6.21.5 in case we need to revert before the next release
SVN-Revision: 7698
Diffstat (limited to 'target/linux/brcm47xx-2.6/patches-2.6.22/110-flash_map.patch')
-rw-r--r--target/linux/brcm47xx-2.6/patches-2.6.22/110-flash_map.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/target/linux/brcm47xx-2.6/patches-2.6.22/110-flash_map.patch b/target/linux/brcm47xx-2.6/patches-2.6.22/110-flash_map.patch
new file mode 100644
index 0000000000..74fe01a25f
--- /dev/null
+++ b/target/linux/brcm47xx-2.6/patches-2.6.22/110-flash_map.patch
@@ -0,0 +1,29 @@
+Index: linux-2.6.22-rc4/drivers/mtd/maps/Kconfig
+===================================================================
+--- linux-2.6.22-rc4.orig/drivers/mtd/maps/Kconfig 2007-06-10 21:32:13.000000000 +0100
++++ linux-2.6.22-rc4/drivers/mtd/maps/Kconfig 2007-06-10 21:33:14.000000000 +0100
+@@ -358,6 +358,12 @@
+ Mapping for the Flaga digital module. If you don't have one, ignore
+ this setting.
+
++config MTD_BCM47XX
++ tristate "BCM47xx flash device"
++ depends on MIPS && MTD_CFI && BCM947XX
++ help
++ Support for the flash chips on the BCM947xx board.
++
+ config MTD_WALNUT
+ tristate "Flash device mapped on IBM 405GP Walnut"
+ depends on MTD_JEDECPROBE && WALNUT
+Index: linux-2.6.22-rc4/drivers/mtd/maps/Makefile
+===================================================================
+--- linux-2.6.22-rc4.orig/drivers/mtd/maps/Makefile 2007-06-10 21:32:13.000000000 +0100
++++ linux-2.6.22-rc4/drivers/mtd/maps/Makefile 2007-06-10 21:33:14.000000000 +0100
+@@ -33,6 +33,7 @@
+ obj-$(CONFIG_MTD_PCMCIA) += pcmciamtd.o
+ obj-$(CONFIG_MTD_RPXLITE) += rpxlite.o
+ obj-$(CONFIG_MTD_TQM8XXL) += tqm8xxl.o
++obj-$(CONFIG_MTD_BCM47XX) += bcm47xx-flash.o
+ obj-$(CONFIG_MTD_SA1100) += sa1100-flash.o
+ obj-$(CONFIG_MTD_IPAQ) += ipaq-flash.o
+ obj-$(CONFIG_MTD_SBC_GXX) += sbc_gxx.o