summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm47xx-2.6/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-01-07 15:35:36 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-01-07 15:35:36 +0000
commitb266b01045575ec2056f03d42861ca0b1c5d2e18 (patch)
tree53b6c4510fe619ceb8cd66f02c30e608f1f70f92 /target/linux/brcm47xx-2.6/Makefile
parent8ca620c2a62afad2448c98f72f15a1b30cecc4dc (diff)
downloadmaster-31e0f0ae-b266b01045575ec2056f03d42861ca0b1c5d2e18.tar.gz
master-31e0f0ae-b266b01045575ec2056f03d42861ca0b1c5d2e18.tar.bz2
master-31e0f0ae-b266b01045575ec2056f03d42861ca0b1c5d2e18.zip
Add initial version of the brcm-2.6 rewrite, called brcm47xx-2.6 to better distinguish it from 63xx.
Boots on WGT643U, includes ethernet support, but doesn't do much otherwise. Thanks to Michael Buesch for his SSB (Sonics SiliconBackplane) work and Vladdy for some fixes and porting to 2.6.19. SVN-Revision: 6015
Diffstat (limited to 'target/linux/brcm47xx-2.6/Makefile')
-rw-r--r--target/linux/brcm47xx-2.6/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/target/linux/brcm47xx-2.6/Makefile b/target/linux/brcm47xx-2.6/Makefile
new file mode 100644
index 0000000000..46e76503fc
--- /dev/null
+++ b/target/linux/brcm47xx-2.6/Makefile
@@ -0,0 +1,26 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=mipsel
+BOARD:=brcm47xx
+BOARDNAME:=Broadcom BCM947xx/953xx (new code)
+FEATURES:=squashfs broken
+
+define Target/Description
+ Build firmware images for Broadcom based routers
+ (e.g. Linksys WRT54G(S), Asus WL-500g, Motorola WR850G)
+
+ This one builds the generic .trx images, activate one of the
+ options below for creating device specific files for use
+ with TFTP client too.
+endef
+
+include $(INCLUDE_DIR)/kernel-build.mk
+# DEFAULT_PACKAGES += kmod-switch
+
+$(eval $(call BuildKernel))