summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-05-18 13:43:57 +0200
committerFelix Fietkau <nbd@nbd.name>2016-05-20 14:37:52 +0200
commitcf58007abcbd14fbd64d2efca1f132fd6eb8b2f0 (patch)
tree8861aa163c7a6a78465311f6576b62ba9b93a897 /target/linux/brcm2708
parentc11505866918ccc95c06c60bb5aca4f84d631a61 (diff)
downloadmaster-31e0f0ae-cf58007abcbd14fbd64d2efca1f132fd6eb8b2f0.tar.gz
master-31e0f0ae-cf58007abcbd14fbd64d2efca1f132fd6eb8b2f0.tar.bz2
master-31e0f0ae-cf58007abcbd14fbd64d2efca1f132fd6eb8b2f0.zip
bcm2708: explicitly check for SUBTARGET instead of using the device SUBTARGETS variable
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'target/linux/brcm2708')
-rw-r--r--target/linux/brcm2708/image/Makefile15
1 files changed, 9 insertions, 6 deletions
diff --git a/target/linux/brcm2708/image/Makefile b/target/linux/brcm2708/image/Makefile
index 35a72958da..af45cf47c6 100644
--- a/target/linux/brcm2708/image/Makefile
+++ b/target/linux/brcm2708/image/Makefile
@@ -54,25 +54,28 @@ endef
DEVICE_VARS += DEVICE_DTS
define Device/rpi
- SUBTARGETS := bcm2708
DEVICE_TITLE := Raspberry Pi B/B+/CM
DEVICE_DTS := bcm2708-rpi-b bcm2708-rpi-b-plus bcm2708-rpi-cm
endef
-TARGET_DEVICES += rpi
+ifeq ($(SUBTARGET),bcm2708)
+ TARGET_DEVICES += rpi
+endif
define Device/rpi-2
- SUBTARGETS := bcm2709
DEVICE_TITLE := Raspberry Pi 2 B
DEVICE_DTS := bcm2709-rpi-2-b
endef
-TARGET_DEVICES += rpi-2
+ifeq ($(SUBTARGET),bcm2708)
+ TARGET_DEVICES += rpi-2
+endif
define Device/rpi-3
- SUBTARGETS := bcm2710
DEVICE_TITLE := Raspberry Pi 3 B
DEVICE_DTS := bcm2710-rpi-3-b
DEVICE_PACKAGES := brcmfmac43430-firmware-sdio kmod-brcmfmac wpad-mini
endef
-TARGET_DEVICES += rpi-3
+ifeq ($(SUBTARGET),bcm2708)
+ TARGET_DEVICES += rpi-3
+endif
$(eval $(call BuildImage))