summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708
diff options
context:
space:
mode:
authorÁlvaro Fernández Rojas <noltari@gmail.com>2016-05-12 19:49:20 +0200
committerÁlvaro Fernández Rojas <noltari@gmail.com>2016-05-14 13:25:08 +0200
commit424a94d81a5ff90e626a38517661795297f62274 (patch)
tree2e46cf8775b831e21614a629229747858ada7fcf /target/linux/brcm2708
parent20b069c440c1061bda64808018be9254cea7f220 (diff)
downloadmaster-31e0f0ae-424a94d81a5ff90e626a38517661795297f62274.tar.gz
master-31e0f0ae-424a94d81a5ff90e626a38517661795297f62274.tar.bz2
master-31e0f0ae-424a94d81a5ff90e626a38517661795297f62274.zip
brcm2708: convert to the new building system
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Diffstat (limited to 'target/linux/brcm2708')
-rw-r--r--target/linux/brcm2708/bcm2708/profiles/RaspberryPi.mk14
-rw-r--r--target/linux/brcm2708/bcm2709/profiles/RaspberryPi2.mk14
-rw-r--r--target/linux/brcm2708/bcm2710/profiles/RaspberryPi3.mk15
-rw-r--r--target/linux/brcm2708/image/Makefile49
4 files changed, 20 insertions, 72 deletions
diff --git a/target/linux/brcm2708/bcm2708/profiles/RaspberryPi.mk b/target/linux/brcm2708/bcm2708/profiles/RaspberryPi.mk
deleted file mode 100644
index 9f698a711d..0000000000
--- a/target/linux/brcm2708/bcm2708/profiles/RaspberryPi.mk
+++ /dev/null
@@ -1,14 +0,0 @@
-#
-# Copyright (C) 2015 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/RaspberryPi
- NAME:=Raspberry Pi Models B/B+/CM
-endef
-define Profile/RaspberryPi/Description
- Raspberry Pi Models B/B+/CM
-endef
-$(eval $(call Profile,RaspberryPi))
diff --git a/target/linux/brcm2708/bcm2709/profiles/RaspberryPi2.mk b/target/linux/brcm2708/bcm2709/profiles/RaspberryPi2.mk
deleted file mode 100644
index ef7483d841..0000000000
--- a/target/linux/brcm2708/bcm2709/profiles/RaspberryPi2.mk
+++ /dev/null
@@ -1,14 +0,0 @@
-#
-# Copyright (C) 2015 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/RaspberryPi_2
- NAME:=Raspberry Pi 2 Model B
-endef
-define Profile/RaspberryPi_2/Description
- Raspberry Pi 2 Model B
-endef
-$(eval $(call Profile,RaspberryPi_2))
diff --git a/target/linux/brcm2708/bcm2710/profiles/RaspberryPi3.mk b/target/linux/brcm2708/bcm2710/profiles/RaspberryPi3.mk
deleted file mode 100644
index c39cf5257b..0000000000
--- a/target/linux/brcm2708/bcm2710/profiles/RaspberryPi3.mk
+++ /dev/null
@@ -1,15 +0,0 @@
-#
-# Copyright (C) 2016 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/RaspberryPi_3
- NAME:=Raspberry Pi 3 Model B
- PACKAGES:=brcmfmac43430-firmware-sdio kmod-brcmfmac wpad-mini
-endef
-define Profile/RaspberryPi_3/Description
- Raspberry Pi 3 Model B
-endef
-$(eval $(call Profile,RaspberryPi_3))
diff --git a/target/linux/brcm2708/image/Makefile b/target/linux/brcm2708/image/Makefile
index 04c27ccf83..35a72958da 100644
--- a/target/linux/brcm2708/image/Makefile
+++ b/target/linux/brcm2708/image/Makefile
@@ -43,45 +43,36 @@ define Build/sdcard-img
$(if $(CONFIG_TARGET_IMAGES_GZIP),gzip -9n -c $@ > $(BIN_DIR)/$(notdir $@).gz)
endef
-### Device macros ###
+### Devices ###
define Device/Default
FILESYSTEMS := ext4
- PROFILES = Default $$(DEVICE_PROFILE)
KERNEL := kernel-bin | kernel-img
IMAGES := sdcard.img
IMAGE/sdcard.img := boot-img | sdcard-img
- DEVICE_PROFILE :=
DEVICE_DTS :=
endef
-DEVICE_VARS += DEVICE_PROFILE DEVICE_DTS
+DEVICE_VARS += DEVICE_DTS
-# $(1) = profile
-# $(2) = image name
-# $(3) = dts
-define bcm27xx
- define Device/$(2)
- DEVICE_PROFILE := $(1)
- DEVICE_DTS := $(3)
- endef
- TARGET_DEVICES += $(2)
+define Device/rpi
+ SUBTARGETS := bcm2708
+ DEVICE_TITLE := Raspberry Pi B/B+/CM
+ DEVICE_DTS := bcm2708-rpi-b bcm2708-rpi-b-plus bcm2708-rpi-cm
endef
+TARGET_DEVICES += rpi
-### BCM2708/BCM2835 ###
-ifeq ($(SUBTARGET),bcm2708)
- # Raspberry Pi Models B/B+/CM
- $(eval $(call bcm27xx,RaspberryPi,rpi,bcm2708-rpi-b bcm2708-rpi-b-plus bcm2708-rpi-cm))
-endif
-
-### BCM2709/BCM2836 ###
-ifeq ($(SUBTARGET),bcm2709)
- # Raspberry Pi 2 Model B
- $(eval $(call bcm27xx,RaspberryPi_2,rpi-2,bcm2709-rpi-2-b))
-endif
+define Device/rpi-2
+ SUBTARGETS := bcm2709
+ DEVICE_TITLE := Raspberry Pi 2 B
+ DEVICE_DTS := bcm2709-rpi-2-b
+endef
+TARGET_DEVICES += rpi-2
-### BCM2710/BCM2837 ###
-ifeq ($(SUBTARGET),bcm2710)
- # Raspberry Pi 3 Model B
- $(eval $(call bcm27xx,RaspberryPi_3,rpi-3,bcm2710-rpi-3-b))
-endif
+define Device/rpi-3
+ SUBTARGETS := bcm2710
+ DEVICE_TITLE := Raspberry Pi 3 B
+ DEVICE_DTS := bcm2710-rpi-3-b
+ DEVICE_PACKAGES := brcmfmac43430-firmware-sdio kmod-brcmfmac wpad-mini
+endef
+TARGET_DEVICES += rpi-3
$(eval $(call BuildImage))