summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-10-05 10:27:18 +0000
committerJohn Crispin <john@openwrt.org>2015-10-05 10:27:18 +0000
commita32acfe73c0d5d0905d284b257d9155d35454df8 (patch)
treeb0f07ef036b3738dac936cacb61a9f4cac046a3b /target/linux/brcm2708
parentb4db6d29d3873ebf71bdef82303c2399eb2d89b5 (diff)
downloadmaster-31e0f0ae-a32acfe73c0d5d0905d284b257d9155d35454df8.tar.gz
master-31e0f0ae-a32acfe73c0d5d0905d284b257d9155d35454df8.tar.bz2
master-31e0f0ae-a32acfe73c0d5d0905d284b257d9155d35454df8.zip
brcm2708: fix kmod-sound-soc-bcm2708-i2s config
Right now, selecting kmod-sound-soc-bcm2708-i2s causes build errors due to missing configs. kmod-regmap enables I2C and SPI, causing build errors due to depending variables not defined. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> SVN-Revision: 47123
Diffstat (limited to 'target/linux/brcm2708')
-rw-r--r--target/linux/brcm2708/modules.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/linux/brcm2708/modules.mk b/target/linux/brcm2708/modules.mk
index 68a7d38028..9c201d0997 100644
--- a/target/linux/brcm2708/modules.mk
+++ b/target/linux/brcm2708/modules.mk
@@ -28,6 +28,8 @@ $(eval $(call KernelPackage,sound-arm-bcm2835))
define KernelPackage/sound-soc-bcm2708-i2s
TITLE:=SoC Audio support for the Broadcom 2708 I2S module
KCONFIG:= \
+ CONFIG_BCM2708_SPIDEV=n \
+ CONFIG_MFD_RPISENSE_CORE=n \
CONFIG_SND_BCM2708_SOC_I2S \
CONFIG_SND_SOC_DMAENGINE_PCM=y \
CONFIG_SND_SOC_GENERIC_DMAENGINE_PCM=y