summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2015-08-14 13:05:22 +0000
committerJonas Gorski <jogo@openwrt.org>2015-08-14 13:05:22 +0000
commit8e69c9f7ef2e1ca40b33a4a33c76b460c1f62861 (patch)
tree350321a0e1cd4bf2449f960da1422253c73d2cff /target/linux/brcm2708
parent4ecae78c1605e48d35f130dbd62b7b3dcb9a0540 (diff)
downloadmaster-31e0f0ae-8e69c9f7ef2e1ca40b33a4a33c76b460c1f62861.tar.gz
master-31e0f0ae-8e69c9f7ef2e1ca40b33a4a33c76b460c1f62861.tar.bz2
master-31e0f0ae-8e69c9f7ef2e1ca40b33a4a33c76b460c1f62861.zip
image.mk: store the device name variable
Make the device name accessible for any build commands instead of forcing targets to define it themselves. Signed-off-by: Jonas Gorski <jogo@openwrt.org> SVN-Revision: 46597
Diffstat (limited to 'target/linux/brcm2708')
-rw-r--r--target/linux/brcm2708/image/Makefile4
1 files changed, 1 insertions, 3 deletions
diff --git a/target/linux/brcm2708/image/Makefile b/target/linux/brcm2708/image/Makefile
index 2afd29b592..76e0abff1d 100644
--- a/target/linux/brcm2708/image/Makefile
+++ b/target/linux/brcm2708/image/Makefile
@@ -61,10 +61,9 @@ define Device/Default
IMAGES := sdcard.bin
IMAGE/sdcard.bin := build-dtb | gen-cfg | boot-img | sdcard-img
DEVICE_PROFILE :=
- DEVICE_NAME :=
DEVICE_DTS :=
endef
-DEVICE_VARS += DEVICE_PROFILE DEVICE_NAME DEVICE_DTS
+DEVICE_VARS += DEVICE_PROFILE DEVICE_DTS
# $(1) = profile
# $(2) = image name
@@ -72,7 +71,6 @@ DEVICE_VARS += DEVICE_PROFILE DEVICE_NAME DEVICE_DTS
define add_bcm2708
define Device/$(2)
DEVICE_PROFILE := $(1)
- DEVICE_NAME := $(2)
DEVICE_DTS := $(3)
endef
TARGET_DEVICES += $(2)