summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-07-17 12:50:52 +0000
committerJohn Crispin <john@openwrt.org>2015-07-17 12:50:52 +0000
commit84b89e4ec459b75b40ec9a643c9aa21743ce7c81 (patch)
tree3d3985daf24ebd406c745f257ca88b4e13aa042e /target/linux/brcm2708
parent08a416e3b9ff3be8dc01041f7f7c74f071b0e7b3 (diff)
downloadmaster-31e0f0ae-84b89e4ec459b75b40ec9a643c9aa21743ce7c81.tar.gz
master-31e0f0ae-84b89e4ec459b75b40ec9a643c9aa21743ce7c81.tar.bz2
master-31e0f0ae-84b89e4ec459b75b40ec9a643c9aa21743ce7c81.zip
brcm2708: add gzip image compression
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> SVN-Revision: 46404
Diffstat (limited to 'target/linux/brcm2708')
-rw-r--r--target/linux/brcm2708/image/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/target/linux/brcm2708/image/Makefile b/target/linux/brcm2708/image/Makefile
index de178c67ea..2afd29b592 100644
--- a/target/linux/brcm2708/image/Makefile
+++ b/target/linux/brcm2708/image/Makefile
@@ -11,6 +11,16 @@ include $(INCLUDE_DIR)/host.mk
FAT32_BLOCK_SIZE=1024
FAT32_BLOCKS=$(shell echo $$(($(CONFIG_BRCM2708_SD_BOOT_PARTSIZE)*1024*1024/$(FAT32_BLOCK_SIZE))))
+ifneq ($(CONFIG_TARGET_IMAGES_GZIP),)
+ define Image/gzip
+ gzip -9n -c $(1) > $(1).gz
+ mv $(1).gz $(BIN_DIR)
+ endef
+else
+ define Image/gzip
+ endef
+endif
+
### Image scripts ###
define Build/build-dtb
$(LINUX_DIR)/scripts/dtc/dtc -O dtb -o $@.dtb $(DTS_DIR)/$(DEVICE_DTS).dts
@@ -40,6 +50,7 @@ endef
define Build/sdcard-img
./gen_rpi_sdcard_img.sh $@ $@.boot $(word 2,$^) \
$(CONFIG_BRCM2708_SD_BOOT_PARTSIZE) $(CONFIG_TARGET_ROOTFS_PARTSIZE)
+ $(call Image/gzip,$@)
endef
### Device macros ###