summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-07-17 12:49:27 +0000
committerJohn Crispin <john@openwrt.org>2015-07-17 12:49:27 +0000
commit08a416e3b9ff3be8dc01041f7f7c74f071b0e7b3 (patch)
tree1a719179ff8b5d1e312d6bfc239f588d2b0bb1e8 /target/linux/brcm2708
parentf7ac790356e51061ff679a601bccc294f433c28f (diff)
downloadmaster-31e0f0ae-08a416e3b9ff3be8dc01041f7f7c74f071b0e7b3.tar.gz
master-31e0f0ae-08a416e3b9ff3be8dc01041f7f7c74f071b0e7b3.tar.bz2
master-31e0f0ae-08a416e3b9ff3be8dc01041f7f7c74f071b0e7b3.zip
brcm2708: add Raspberry Pi Compute Module support
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> SVN-Revision: 46403
Diffstat (limited to 'target/linux/brcm2708')
-rw-r--r--target/linux/brcm2708/bcm2708/profiles/RaspberryPi.mk8
-rw-r--r--target/linux/brcm2708/image/Makefile2
2 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/brcm2708/bcm2708/profiles/RaspberryPi.mk b/target/linux/brcm2708/bcm2708/profiles/RaspberryPi.mk
index 82a7910ba1..dcf6e0599b 100644
--- a/target/linux/brcm2708/bcm2708/profiles/RaspberryPi.mk
+++ b/target/linux/brcm2708/bcm2708/profiles/RaspberryPi.mk
@@ -28,3 +28,11 @@ define Profile/RaspberryPi_BPlus/Description
Raspberry Pi Model B+
endef
$(eval $(call Profile,RaspberryPi_BPlus))
+
+define Profile/RaspberryPi_CM
+ NAME:=Raspberry Pi Compute Module
+endef
+define Profile/RaspberryPi_CM/Description
+ Raspberry Pi Model Compute Module
+endef
+$(eval $(call Profile,RaspberryPi_CM))
diff --git a/target/linux/brcm2708/image/Makefile b/target/linux/brcm2708/image/Makefile
index 00bee22555..de178c67ea 100644
--- a/target/linux/brcm2708/image/Makefile
+++ b/target/linux/brcm2708/image/Makefile
@@ -73,6 +73,8 @@ ifeq ($(SUBTARGET),bcm2708)
$(eval $(call add_bcm2708,RaspberryPi_B,rpi-b,bcm2708-rpi-b))
# Raspberry Pi Model B+
$(eval $(call add_bcm2708,RaspberryPi_BPlus,rpi-b-plus,bcm2708-rpi-b-plus))
+ # Raspberry Pi Compute Module
+ $(eval $(call add_bcm2708,RaspberryPi_CM,rpi-cm,bcm2708-rpi-cm))
endif
### BCM2709/BCM2836 ###