summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708/patches-3.18/0030-ASoC-Add-support-for-BCM2708.patch
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-02-13 07:38:27 +0000
committerJohn Crispin <john@openwrt.org>2015-02-13 07:38:27 +0000
commit9b74de00f7b35427bbea34c5d59d6f05fc0e3a8f (patch)
treed195a3dab5e103006253d85283b3bd4b21708e09 /target/linux/brcm2708/patches-3.18/0030-ASoC-Add-support-for-BCM2708.patch
parent2dbcf5e91f4f9db57d618d801674c3792d4504e7 (diff)
downloadmaster-31e0f0ae-9b74de00f7b35427bbea34c5d59d6f05fc0e3a8f.tar.gz
master-31e0f0ae-9b74de00f7b35427bbea34c5d59d6f05fc0e3a8f.tar.bz2
master-31e0f0ae-9b74de00f7b35427bbea34c5d59d6f05fc0e3a8f.zip
brcm2708: refresh patches
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> SVN-Revision: 44433
Diffstat (limited to 'target/linux/brcm2708/patches-3.18/0030-ASoC-Add-support-for-BCM2708.patch')
-rw-r--r--[-rwxr-xr-x]target/linux/brcm2708/patches-3.18/0030-ASoC-Add-support-for-BCM2708.patch15
1 files changed, 1 insertions, 14 deletions
diff --git a/target/linux/brcm2708/patches-3.18/0030-ASoC-Add-support-for-BCM2708.patch b/target/linux/brcm2708/patches-3.18/0030-ASoC-Add-support-for-BCM2708.patch
index 59a1d9fb09..adaf624be4 100755..100644
--- a/target/linux/brcm2708/patches-3.18/0030-ASoC-Add-support-for-BCM2708.patch
+++ b/target/linux/brcm2708/patches-3.18/0030-ASoC-Add-support-for-BCM2708.patch
@@ -56,8 +56,6 @@ to avoid the name clash when registering debugfs entries.
create mode 100644 sound/soc/bcm/bcm2708-i2s.c
create mode 100644 sound/soc/bcm/bcm2708-i2s.h
-diff --git a/sound/soc/bcm/Kconfig b/sound/soc/bcm/Kconfig
-index 6a834e1..7e5b945 100644
--- a/sound/soc/bcm/Kconfig
+++ b/sound/soc/bcm/Kconfig
@@ -7,3 +7,14 @@ config SND_BCM2835_SOC_I2S
@@ -75,11 +73,9 @@ index 6a834e1..7e5b945 100644
+ Say Y or M if you want to add support for codecs attached to
+ the BCM2708 I2S interface. You will also need
+ to select the audio interfaces to support below.
-diff --git a/sound/soc/bcm/Makefile b/sound/soc/bcm/Makefile
-index bc816b7..f8bbe1f 100644
--- a/sound/soc/bcm/Makefile
+++ b/sound/soc/bcm/Makefile
-@@ -3,3 +3,7 @@ snd-soc-bcm2835-i2s-objs := bcm2835-i2s.o
+@@ -3,3 +3,7 @@ snd-soc-bcm2835-i2s-objs := bcm2835-i2s.
obj-$(CONFIG_SND_BCM2835_SOC_I2S) += snd-soc-bcm2835-i2s.o
@@ -87,9 +83,6 @@ index bc816b7..f8bbe1f 100644
+snd-soc-bcm2708-i2s-objs := bcm2708-i2s.o
+
+obj-$(CONFIG_SND_BCM2708_SOC_I2S) += snd-soc-bcm2708-i2s.o
-diff --git a/sound/soc/bcm/bcm2708-i2s.c b/sound/soc/bcm/bcm2708-i2s.c
-new file mode 100644
-index 0000000..0b5322a
--- /dev/null
+++ b/sound/soc/bcm/bcm2708-i2s.c
@@ -0,0 +1,998 @@
@@ -1091,9 +1084,6 @@ index 0000000..0b5322a
+MODULE_DESCRIPTION("BCM2708 I2S interface");
+MODULE_AUTHOR("Florian Meier <florian.meier@koalo.de>");
+MODULE_LICENSE("GPL v2");
-diff --git a/sound/soc/bcm/bcm2708-i2s.h b/sound/soc/bcm/bcm2708-i2s.h
-new file mode 100644
-index 0000000..6fdcbc1
--- /dev/null
+++ b/sound/soc/bcm/bcm2708-i2s.h
@@ -0,0 +1,35 @@
@@ -1132,6 +1122,3 @@ index 0000000..6fdcbc1
+extern void bcm2708_i2s_set_gpio(int gpio);
+
+#endif
---
-1.8.3.2
-