summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708/image
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2016-03-08 18:11:55 +0000
committerJohn Crispin <john@openwrt.org>2016-03-08 18:11:55 +0000
commit993989880a1f2f5ad0877ba47d4e99919cfa8bf2 (patch)
treed4c66c67ad86224de9d4ba84e8bdb7a948e321f6 /target/linux/brcm2708/image
parentcd2114e19ceffb17b0f093718334148859f1adac (diff)
downloadmaster-31e0f0ae-993989880a1f2f5ad0877ba47d4e99919cfa8bf2.tar.gz
master-31e0f0ae-993989880a1f2f5ad0877ba47d4e99919cfa8bf2.tar.bz2
master-31e0f0ae-993989880a1f2f5ad0877ba47d4e99919cfa8bf2.zip
brcm2708: add Raspberry Pi 3 support
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> SVN-Revision: 48967
Diffstat (limited to 'target/linux/brcm2708/image')
-rw-r--r--target/linux/brcm2708/image/Makefile12
-rw-r--r--target/linux/brcm2708/image/cmdline.txt2
2 files changed, 10 insertions, 4 deletions
diff --git a/target/linux/brcm2708/image/Makefile b/target/linux/brcm2708/image/Makefile
index f96dccb09f..8cf83a4563 100644
--- a/target/linux/brcm2708/image/Makefile
+++ b/target/linux/brcm2708/image/Makefile
@@ -57,7 +57,7 @@ DEVICE_VARS += DEVICE_PROFILE DEVICE_DTS
# $(1) = profile
# $(2) = image name
# $(3) = dts
-define bcm270x
+define bcm27xx
define Device/$(2)
DEVICE_PROFILE := $(1)
DEVICE_DTS := $(3)
@@ -68,13 +68,19 @@ endef
### BCM2708/BCM2835 ###
ifeq ($(SUBTARGET),bcm2708)
# Raspberry Pi Models B/B+/CM
- $(eval $(call bcm270x,RaspberryPi,rpi,bcm2708-rpi-b bcm2708-rpi-b-plus bcm2708-rpi-cm))
+ $(eval $(call bcm27xx,RaspberryPi,rpi,bcm2708-rpi-b bcm2708-rpi-b-plus bcm2708-rpi-cm))
endif
### BCM2709/BCM2836 ###
ifeq ($(SUBTARGET),bcm2709)
# Raspberry Pi 2 Model B
- $(eval $(call bcm270x,RaspberryPi_2,rpi-2,bcm2709-rpi-2-b))
+ $(eval $(call bcm27xx,RaspberryPi_2,rpi-2,bcm2709-rpi-2-b))
+endif
+
+### BCM2710/BCM2837 ###
+ifeq ($(SUBTARGET),bcm2710)
+ # Raspberry Pi 3 Model B
+ $(eval $(call bcm27xx,RaspberryPi_3,rpi-3,bcm2710-rpi-3-b))
endif
$(eval $(call BuildImage))
diff --git a/target/linux/brcm2708/image/cmdline.txt b/target/linux/brcm2708/image/cmdline.txt
index 95848bb293..24f4f0c276 100644
--- a/target/linux/brcm2708/image/cmdline.txt
+++ b/target/linux/brcm2708/image/cmdline.txt
@@ -1 +1 @@
-dwc_otg.lpm_enable=0 rpitestmode=1 console=tty1 console=ttyAMA0,115200 kgdboc=ttyAMA0,115200 root=/dev/mmcblk0p2 rootfstype=ext4 rootwait
+dwc_otg.lpm_enable=0 console=serial0,115200 kgdboc=serial0,115200 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 rootwait