summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708/image
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-07-17 12:47:50 +0000
committerJohn Crispin <john@openwrt.org>2015-07-17 12:47:50 +0000
commit8ef50ec40b825a2937eb90570eccb91a2ad79b9d (patch)
tree46e852d492af3705a1ebd9111539ecaae6cd0f54 /target/linux/brcm2708/image
parentb052a00c0b5533f331ac5d10d402e8e5f22bab14 (diff)
downloadmaster-31e0f0ae-8ef50ec40b825a2937eb90570eccb91a2ad79b9d.tar.gz
master-31e0f0ae-8ef50ec40b825a2937eb90570eccb91a2ad79b9d.tar.bz2
master-31e0f0ae-8ef50ec40b825a2937eb90570eccb91a2ad79b9d.zip
brcm2708: improve profiles and image generation
- Add profiles for bcm2708 subtarget. - Check subtarget for image generation. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> SVN-Revision: 46396
Diffstat (limited to 'target/linux/brcm2708/image')
-rw-r--r--target/linux/brcm2708/image/Makefile19
1 files changed, 13 insertions, 6 deletions
diff --git a/target/linux/brcm2708/image/Makefile b/target/linux/brcm2708/image/Makefile
index 10ecfdaef0..00bee22555 100644
--- a/target/linux/brcm2708/image/Makefile
+++ b/target/linux/brcm2708/image/Makefile
@@ -67,11 +67,18 @@ define add_bcm2708
TARGET_DEVICES += $(2)
endef
-# Raspberry Pi Model B
-$(eval $(call add_bcm2708,RaspberryPi,rpi-b,bcm2708-rpi-b))
-# Raspberry Pi Model B+
-$(eval $(call add_bcm2708,RaspberryPi,rpi-b-plus,bcm2708-rpi-b-plus))
-# Raspberry Pi 2 Model B
-$(eval $(call add_bcm2708,RaspberryPi2,rpi-2-b,bcm2709-rpi-2-b))
+### BCM2708/BCM2835 ###
+ifeq ($(SUBTARGET),bcm2708)
+ # Raspberry Pi Model B
+ $(eval $(call add_bcm2708,RaspberryPi_B,rpi-b,bcm2708-rpi-b))
+ # Raspberry Pi Model B+
+ $(eval $(call add_bcm2708,RaspberryPi_BPlus,rpi-b-plus,bcm2708-rpi-b-plus))
+endif
+
+### BCM2709/BCM2836 ###
+ifeq ($(SUBTARGET),bcm2709)
+ # Raspberry Pi 2 Model B
+ $(eval $(call add_bcm2708,RaspberryPi_2,rpi-2-b,bcm2709-rpi-2-b))
+endif
$(eval $(call BuildImage))