summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708/image
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-10-11 16:23:18 +0000
committerJohn Crispin <john@openwrt.org>2015-10-11 16:23:18 +0000
commit4412334bea9d7946cb5b0d61647d81b330c7f2a9 (patch)
treecec62cbb267798db394e497119b47fb7f65236b4 /target/linux/brcm2708/image
parent19a491b04774115aa590b7744c506effa744d544 (diff)
downloadmaster-31e0f0ae-4412334bea9d7946cb5b0d61647d81b330c7f2a9.tar.gz
master-31e0f0ae-4412334bea9d7946cb5b0d61647d81b330c7f2a9.tar.bz2
master-31e0f0ae-4412334bea9d7946cb5b0d61647d81b330c7f2a9.zip
brcm2708: use mmd for overlays subdirectory
Fixes https://dev.openwrt.org/ticket/20704 Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> SVN-Revision: 47171
Diffstat (limited to 'target/linux/brcm2708/image')
-rw-r--r--target/linux/brcm2708/image/Makefile9
1 files changed, 2 insertions, 7 deletions
diff --git a/target/linux/brcm2708/image/Makefile b/target/linux/brcm2708/image/Makefile
index 3744cace58..cc0bfb0a26 100644
--- a/target/linux/brcm2708/image/Makefile
+++ b/target/linux/brcm2708/image/Makefile
@@ -21,12 +21,6 @@ else
endef
endif
-define Image/Prepare
- rm -rf $(KDIR)/overlays
- mkdir -p $(KDIR)/overlays
- $(CP) $(DTS_DIR)/overlays/*.dtb $(KDIR)/overlays/
-endef
-
### Image scripts ###
define Build/gen-cfg
cat config.txt > $@.config
@@ -47,7 +41,8 @@ define Build/boot-img
mcopy -i $@.boot $@.config ::config.txt
mcopy -i $@.boot $(word 1,$^) ::kernel.img
mcopy -i $@.boot $(DTS_DIR)/$(DEVICE_DTS).dtb ::$(DEVICE_DTS).dtb
- mcopy -s -i $@.boot $(KDIR)/overlays ::
+ mmd -i $@.boot ::/overlays
+ mcopy -i $@.boot $(DTS_DIR)/overlays/*.dtb ::/overlays/
endef
define Build/sdcard-img