summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708/image
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-11-21 21:24:44 +0000
committerJohn Crispin <john@openwrt.org>2015-11-21 21:24:44 +0000
commit223d88f84352b5c7c5959d2c939d7b55f0b42f4d (patch)
tree386aa363a4f95ff0d3f55e7ca8b318ac9cda8651 /target/linux/brcm2708/image
parent40ddc71cc98085e93b0ae8e3c4a0a249c66dbdde (diff)
downloadmaster-31e0f0ae-223d88f84352b5c7c5959d2c939d7b55f0b42f4d.tar.gz
master-31e0f0ae-223d88f84352b5c7c5959d2c939d7b55f0b42f4d.tar.bz2
master-31e0f0ae-223d88f84352b5c7c5959d2c939d7b55f0b42f4d.zip
brcm2708: simplify gzip image generation
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> SVN-Revision: 47558
Diffstat (limited to 'target/linux/brcm2708/image')
-rw-r--r--target/linux/brcm2708/image/Makefile12
1 files changed, 1 insertions, 11 deletions
diff --git a/target/linux/brcm2708/image/Makefile b/target/linux/brcm2708/image/Makefile
index cf263bdf01..ecf6f71835 100644
--- a/target/linux/brcm2708/image/Makefile
+++ b/target/linux/brcm2708/image/Makefile
@@ -11,16 +11,6 @@ include $(INCLUDE_DIR)/host.mk
FAT32_BLOCK_SIZE=1024
FAT32_BLOCKS=$(shell echo $$(($(CONFIG_BRCM2708_SD_BOOT_PARTSIZE)*1024*1024/$(FAT32_BLOCK_SIZE))))
-ifneq ($(CONFIG_TARGET_IMAGES_GZIP),)
- define Image/gzip
- gzip -9n -c $(1) > $(1).gz
- mv $(1).gz $(BIN_DIR)
- endef
-else
- define Image/gzip
- endef
-endif
-
### Image scripts ###
define Build/gen-cfg
cat config.txt > $@.config
@@ -49,7 +39,7 @@ endef
define Build/sdcard-img
./gen_rpi_sdcard_img.sh $@ $@.boot $(word 2,$^) \
$(CONFIG_BRCM2708_SD_BOOT_PARTSIZE) $(CONFIG_TARGET_ROOTFS_PARTSIZE)
- $(call Image/gzip,$@)
+ $(if $(CONFIG_TARGET_IMAGES_GZIP),gzip -9n -c $@ > $(BIN_DIR)/$(notdir $@).gz)
endef
### Device macros ###