summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708/bcm2708
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-07-17 12:47:50 +0000
committerJohn Crispin <john@openwrt.org>2015-07-17 12:47:50 +0000
commit8ef50ec40b825a2937eb90570eccb91a2ad79b9d (patch)
tree46e852d492af3705a1ebd9111539ecaae6cd0f54 /target/linux/brcm2708/bcm2708
parentb052a00c0b5533f331ac5d10d402e8e5f22bab14 (diff)
downloadmaster-31e0f0ae-8ef50ec40b825a2937eb90570eccb91a2ad79b9d.tar.gz
master-31e0f0ae-8ef50ec40b825a2937eb90570eccb91a2ad79b9d.tar.bz2
master-31e0f0ae-8ef50ec40b825a2937eb90570eccb91a2ad79b9d.zip
brcm2708: improve profiles and image generation
- Add profiles for bcm2708 subtarget. - Check subtarget for image generation. Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> SVN-Revision: 46396
Diffstat (limited to 'target/linux/brcm2708/bcm2708')
-rw-r--r--target/linux/brcm2708/bcm2708/profiles/RaspberryPi.mk22
1 files changed, 18 insertions, 4 deletions
diff --git a/target/linux/brcm2708/bcm2708/profiles/RaspberryPi.mk b/target/linux/brcm2708/bcm2708/profiles/RaspberryPi.mk
index 94d0a068c0..82a7910ba1 100644
--- a/target/linux/brcm2708/bcm2708/profiles/RaspberryPi.mk
+++ b/target/linux/brcm2708/bcm2708/profiles/RaspberryPi.mk
@@ -5,12 +5,26 @@
# See /LICENSE for more information.
#
-define Profile/RaspberryPi
+define Profile/Default
NAME:=Raspberry Pi
endef
+define Profile/Default/Description
+ Raspberry Pi
+endef
+$(eval $(call Profile,Default))
-define Profile/RaspberryPi/Description
- Raspberry Pi board
+define Profile/RaspberryPi_B
+ NAME:=Raspberry Pi Model B
+endef
+define Profile/RaspberryPi_B/Description
+ Raspberry Pi Model B
endef
+$(eval $(call Profile,RaspberryPi_B))
-$(eval $(call Profile,RaspberryPi))
+define Profile/RaspberryPi_BPlus
+ NAME:=Raspberry Pi Model B+
+endef
+define Profile/RaspberryPi_BPlus/Description
+ Raspberry Pi Model B+
+endef
+$(eval $(call Profile,RaspberryPi_BPlus))