summaryrefslogtreecommitdiffstats
path: root/target/linux/brcm2708/bcm2708
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-11-21 21:25:04 +0000
committerJohn Crispin <john@openwrt.org>2015-11-21 21:25:04 +0000
commit31f9aec7d61f24f50f2ce37a47558afbad410317 (patch)
tree040a9d1fd52fc5e5402707656b8c8610d3029cee /target/linux/brcm2708/bcm2708
parenta429d6998e7352481c6c3ace466be3e35e7fc31a (diff)
downloadmaster-31e0f0ae-31f9aec7d61f24f50f2ce37a47558afbad410317.tar.gz
master-31e0f0ae-31f9aec7d61f24f50f2ce37a47558afbad410317.tar.bz2
master-31e0f0ae-31f9aec7d61f24f50f2ce37a47558afbad410317.zip
brcm2708: add support for multi-device images
Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com> SVN-Revision: 47561
Diffstat (limited to 'target/linux/brcm2708/bcm2708')
-rw-r--r--target/linux/brcm2708/bcm2708/profiles/RaspberryPi.mk34
1 files changed, 5 insertions, 29 deletions
diff --git a/target/linux/brcm2708/bcm2708/profiles/RaspberryPi.mk b/target/linux/brcm2708/bcm2708/profiles/RaspberryPi.mk
index dcf6e0599b..9f698a711d 100644
--- a/target/linux/brcm2708/bcm2708/profiles/RaspberryPi.mk
+++ b/target/linux/brcm2708/bcm2708/profiles/RaspberryPi.mk
@@ -5,34 +5,10 @@
# See /LICENSE for more information.
#
-define Profile/Default
- NAME:=Raspberry Pi
+define Profile/RaspberryPi
+ NAME:=Raspberry Pi Models B/B+/CM
endef
-define Profile/Default/Description
- Raspberry Pi
+define Profile/RaspberryPi/Description
+ Raspberry Pi Models B/B+/CM
endef
-$(eval $(call Profile,Default))
-
-define Profile/RaspberryPi_B
- NAME:=Raspberry Pi Model B
-endef
-define Profile/RaspberryPi_B/Description
- Raspberry Pi Model B
-endef
-$(eval $(call Profile,RaspberryPi_B))
-
-define Profile/RaspberryPi_BPlus
- NAME:=Raspberry Pi Model B+
-endef
-define Profile/RaspberryPi_BPlus/Description
- Raspberry Pi Model B+
-endef
-$(eval $(call Profile,RaspberryPi_BPlus))
-
-define Profile/RaspberryPi_CM
- NAME:=Raspberry Pi Compute Module
-endef
-define Profile/RaspberryPi_CM/Description
- Raspberry Pi Model Compute Module
-endef
-$(eval $(call Profile,RaspberryPi_CM))
+$(eval $(call Profile,RaspberryPi))